pacho       15/05/17 09:20:04

  Modified:             metadata.xml ChangeLog
  Added:                vte-0.36.4.ebuild
  Removed:              vte-0.38.2.ebuild vte-0.34.9.ebuild
  Log:
  Version bump, drop old
  
  (Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  Changes    Path
1.5                  x11-libs/vte/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/metadata.xml?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/metadata.xml?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/metadata.xml?r1=1.4&r2=1.5

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-libs/vte/metadata.xml,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- metadata.xml        1 Apr 2011 10:57:22 -0000       1.4
+++ metadata.xml        17 May 2015 09:20:04 -0000      1.5
@@ -4,7 +4,5 @@
 <herd>gnome</herd>
 <use>
        <flag name='glade'>Provide integration with 
<pkg>dev-util/glade</pkg>.</flag>
-       <flag name="introspection">Use 
<pkg>dev-libs/gobject-introspection</pkg> for
-       introspection</flag>
 </use>
 </pkgmetadata>



1.409                x11-libs/vte/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/ChangeLog?rev=1.409&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/ChangeLog?rev=1.409&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/ChangeLog?r1=1.408&r2=1.409

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v
retrieving revision 1.408
retrieving revision 1.409
diff -u -r1.408 -r1.409
--- ChangeLog   8 Apr 2015 17:28:02 -0000       1.408
+++ ChangeLog   17 May 2015 09:20:04 -0000      1.409
@@ -1,6 +1,12 @@
 # ChangeLog for x11-libs/vte
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.408 2015/04/08 
17:28:02 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.409 2015/05/17 
09:20:04 pacho Exp $
+
+*vte-0.36.4 (17 May 2015)
+
+  17 May 2015; Pacho Ramos <pa...@gentoo.org> +vte-0.36.4.ebuild,
+  -vte-0.34.9.ebuild, -vte-0.38.2.ebuild, metadata.xml:
+  Version bump, drop old
 
   08 Apr 2015; Michał Górny <mgo...@gentoo.org> vte-0.28.2-r206.ebuild:
   Drop old Python implementations



1.1                  x11-libs/vte/vte-0.36.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/vte-0.36.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/vte/vte-0.36.4.ebuild?rev=1.1&content-type=text/plain

Index: vte-0.36.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.36.4.ebuild,v 1.1 
2015/05/17 09:20:04 pacho Exp $

EAPI="5"
GCONF_DEBUG="no"

inherit eutils gnome2

DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE";

LICENSE="LGPL-2+"
SLOT="2.90"
IUSE="debug glade +introspection"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 
~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux 
~x64-solaris ~x86-solaris"

PDEPEND=">=x11-libs/gnome-pty-helper-${PV}"
RDEPEND="
        >=dev-libs/glib-2.31.13:2
        >=x11-libs/gtk+-3.1.9:3[introspection?]
        >=x11-libs/pango-1.22.0

        sys-libs/ncurses
        x11-libs/libX11
        x11-libs/libXft

        glade? ( >=dev-util/glade-3.9:3.10 )
        introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
"
DEPEND="${RDEPEND}
        >=dev-util/gtk-doc-am-1.13
        >=dev-util/intltool-0.35
        sys-devel/gettext
        virtual/pkgconfig
"

src_prepare() {
        # https://bugzilla.gnome.org/show_bug.cgi?id=663779
        epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
        gnome2_src_prepare
}

src_configure() {
        local myconf=""

        if [[ ${CHOST} == *-interix* ]]; then
                myconf="${myconf} --disable-Bsymbolic"

                # interix stropts.h is empty...
                export ac_cv_header_stropts_h=no
        fi

        # Python bindings are via gobject-introspection
        # Ex: from gi.repository import Vte
        # Do not disable gnome-pty-helper, bug #401389
        gnome2_src_configure \
                --disable-deprecation \
                --disable-static \
                $(use_enable debug) \
                $(use_enable glade glade-catalogue) \
                $(use_enable introspection)
}

src_install() {
        DOCS="AUTHORS ChangeLog HACKING NEWS README"
        gnome2_src_install
        rm -v "${ED}usr/libexec/gnome-pty-helper" || die
}




Reply via email to