wired       14/05/08 05:59:22

  Modified:             ChangeLog
  Added:                dunst-1.0.0-r1.ebuild
  Log:
  backported a couple of fixes from git.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
EB9B4AFA)

Revision  Changes    Path
1.6                  x11-misc/dunst/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/dunst/ChangeLog?rev=1.6&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/dunst/ChangeLog?rev=1.6&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/dunst/ChangeLog?r1=1.5&r2=1.6

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-misc/dunst/ChangeLog,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- ChangeLog   12 Sep 2013 17:16:38 -0000      1.5
+++ ChangeLog   8 May 2014 05:59:22 -0000       1.6
@@ -1,6 +1,13 @@
 # ChangeLog for x11-misc/dunst
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dunst/ChangeLog,v 1.5 2013/09/12 
17:16:38 wired Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dunst/ChangeLog,v 1.6 2014/05/08 
05:59:22 wired Exp $
+
+*dunst-1.0.0-r1 (08 May 2014)
+
+  08 May 2014; Alex Alexander <wi...@gentoo.org> +dunst-1.0.0-r1.ebuild,
+  +files/dunst-1.0.0-correctly_handle_num_lock.patch,
+  +files/dunst-1.0.0-fix_pause_resume.patch:
+  backported a couple of fixes from git.
 
   12 Sep 2013; Alex Alexander <wi...@gentoo.org> dunst-1.0.0.ebuild:
   epatch_user support, bug #484356



1.1                  x11-misc/dunst/dunst-1.0.0-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/dunst/dunst-1.0.0-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/dunst/dunst-1.0.0-r1.ebuild?rev=1.1&content-type=text/plain

Index: dunst-1.0.0-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-misc/dunst/dunst-1.0.0-r1.ebuild,v 1.1 
2014/05/08 05:59:22 wired Exp $

EAPI=5

inherit eutils

DESCRIPTION="customizable and lightweight notification-daemon"
HOMEPAGE="http://www.knopwob.org/dunst/";
SRC_URI="http://www.knopwob.org/public/dunst-release/${P}.tar.bz2";

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dunstify"

CDEPEND="
        dev-libs/glib:2
        dev-libs/libxdg-basedir
        sys-apps/dbus
        x11-libs/libXScrnSaver
        x11-libs/libXft
        x11-libs/libXinerama
        x11-libs/cairo[X,glib]
        x11-libs/pango[X]
        dunstify? ( x11-libs/libnotify )
"

DEPEND="${CDEPEND}
                dev-lang/perl
                virtual/pkgconfig"

RDEPEND="${CDEPEND}"

src_prepare() {
        # fixes backported from git
        epatch "${FILESDIR}"/${P}-correctly_handle_num_lock.patch
        epatch "${FILESDIR}"/${P}-fix_pause_resume.patch

        # Remove nasty CFLAGS which override user choice
        sed -ie "/^CFLAGS/ {
                s:-g::
                s:-O.::
        }" config.mk || die "sed failed"

        if ! use dunstify; then
                # don't build dunstify: it pulls in deps but is not being 
installed
                sed -ie "/^all:/ s:dunstify::" Makefile || die "sed failed"
        fi

        epatch_user
}

src_install() {
        emake DESTDIR="${D}" PREFIX="/usr" install

        if use dunstify; then
                dobin dunstify
        fi

        dodoc CHANGELOG
}




Reply via email to