[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-cpp/eigen: eigen-2.0.6.ebuild ChangeLog

2009-09-26 Thread Peter Volkov
В Сбт, 26/09/2009 в 00:18 +, Patrick Lauer (patrick) пишет:
 patrick 09/09/26 00:18:02
   Log:
   Bump to 2.0.6, fixes #286462
   (Portage version: 2.2_rc41/cvs/Linux x86_64)

 1.1  dev-cpp/eigen/eigen-2.0.6.ebuild
 
 file : 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-cpp/eigen/eigen-2.0.6.ebuild?rev=1.1view=markup
 plain: 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-cpp/eigen/eigen-2.0.6.ebuild?rev=1.1content-type=text/plain

 src_test() {
   mycmakeargs=${mycmakeargs}
   -DEIGEN_BUILD_TESTS=ON
   -DEIGEN_TEST_NO_FORTRAN=ON
   cmake-utils_src_configure
   cmake-utils_src_compile
   cmake-utils_src_test
 }

Does this mean that with tests enabled user will get different package?
If that's true I think user should be at least notified about that as
this is counterintuitive. If not why -D*TEST* are not added at
src_configure phase?

-- 
Peter.




Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-cpp/eigen: eigen-2.0.6.ebuild ChangeLog

2009-09-26 Thread Tomáš Chvátal
Dne sobota 26 Září 2009 18:26:48 Peter Volkov napsal(a):
  src_test() {
  mycmakeargs=${mycmakeargs}
  -DEIGEN_BUILD_TESTS=ON
  -DEIGEN_TEST_NO_FORTRAN=ON
  cmake-utils_src_configure
  cmake-utils_src_compile
  cmake-utils_src_test
  }
 
 Does this mean that with tests enabled user will get different package?
 If that's true I think user should be at least notified about that as
 this is counterintuitive. If not why -D*TEST* are not added at
 src_configure phase?

No this means that it will add to configure options tests feature.
Since cmake is cascading it will configure and compile in only the required 
test stuff.
Then it runs the test.

I dont think users really need tests out of the test scope so why to do it 
elsewhere.

It has 0 effect on what is installed in the end

Tomas


signature.asc
Description: This is a digitally signed message part.