Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-21 Thread Arfrever Frehtes Taifersar Arahesis
2010-06-21 00:27:00 Mike Frysinger napisał(a):
 On Sunday, June 20, 2010 09:55:39 Arfrever Frehtes Taifersar Arahesis wrote:
  2010-06-19 22:53:37 Mike Frysinger napisał(a):
   On Thursday, June 10, 2010 16:45:29 Arfrever Frehtes Taifersar wrote:
2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
 On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar wrote:
  2010-06-10 21:27:40 Jeremy Olexa napisał(a):
  I see no reason to *not* add a ChangeLog entry here.
  
  ChangeLog entries are not required for trivial changes.
 
 A trivial change is fixing a typo, or a manifest problem, a missing
 quotation mark, etc. Anything else is not trivial.
 
 Anything that changes how an ebuild functions, what it does, or the
 installed files (and/or their contents) is NOT a trivial change.

This commit only removed some compiler warnings.
   
   mucking with CFLAGS without documentation is wrong.  compiler warnings
   come and go, so a flag that was relevant one day could be completely
   extraneous the next.
   
   however, especially with strict aliasing, you arent just fixing
   warnings, you're changing optimization behavior of gcc to workaround
   broken C code. this obviously does not fall anywhere near the trivial
   mark.
   
   i see you still havent fixed this, so get on it already.  a bug needs to
   be opened somewhere to get the package properly *fixed*
  
  This problem is probably caused by bugs in Python 2, which have been fixed
  in Python 3.
 
 the new information you've provided here only reinforces the fact the current 
 code is wrong.  properly document the append-flags and properly restrict it 
 to 
 when python-2 is being used.

I have added the comment to the ebuild. dev-python/traits supports only Python 
2.

 considering python-2 is going to be in our lives for a while, how hard is it 
 to backport the changes in question to the headers ?  presumably it's 
 struct/union/cast shuffling in the headers.

I don't know what exactly would need to be backported. I suspect that Python 
developers
would have backported the fix if it wasn't breaking backward compatibility.

-- 
Arfrever Frehtes Taifersar Arahesis


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-20 Thread Arfrever Frehtes Taifersar Arahesis
2010-06-19 22:53:37 Mike Frysinger napisał(a):
 On Thursday, June 10, 2010 16:45:29 Arfrever Frehtes Taifersar Arahesis wrote:
  2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
   On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar wrote:
2010-06-10 21:27:40 Jeremy Olexa napisał(a):
I see no reason to *not* add a ChangeLog entry here.

ChangeLog entries are not required for trivial changes.
   
   A trivial change is fixing a typo, or a manifest problem, a missing
   quotation mark, etc. Anything else is not trivial.
   
   Anything that changes how an ebuild functions, what it does, or the
   installed files (and/or their contents) is NOT a trivial change.
  
  This commit only removed some compiler warnings.
 
 mucking with CFLAGS without documentation is wrong.  compiler warnings come 
 and go, so a flag that was relevant one day could be completely extraneous 
 the 
 next.
 
 however, especially with strict aliasing, you arent just fixing warnings, 
 you're changing optimization behavior of gcc to workaround broken C code.  
 this obviously does not fall anywhere near the trivial mark.
 
 i see you still havent fixed this, so get on it already.  a bug needs to be 
 opened somewhere to get the package properly *fixed*

This problem is probably caused by bugs in Python 2, which have been fixed in 
Python 3.

$ echo 'a = True'  test.pyx
$ cython test.pyx
$ gcc -O2 -Wall -I/usr/include/python3.1 -c test.c
$ gcc -O2 -Wall -I/usr/include/python2.6 -c test.c
test.c: In function ‘inittest’:
test.c:479: warning: dereferencing type-punned pointer will break 
strict-aliasing rules
test.c:479: warning: dereferencing type-punned pointer will break 
strict-aliasing rules
test.c:479: warning: dereferencing pointer ‘_Py_TrueStruct.42’ does break 
strict-aliasing rules
test.c:479: warning: dereferencing pointer ‘_Py_TrueStruct.42’ does break 
strict-aliasing rules
test.c:479: note: initialized from here
test.c:482: warning: dereferencing pointer ‘__pyx_t_1’ does break 
strict-aliasing rules
test.c:482: warning: dereferencing pointer ‘__pyx_t_1’ does break 
strict-aliasing rules
test.c:482: warning: dereferencing pointer ‘__pyx_t_1’ does break 
strict-aliasing rules
test.c:482: warning: dereferencing pointer ‘__pyx_t_1’ does break 
strict-aliasing rules
test.c:479: note: initialized from here

-- 
Arfrever Frehtes Taifersar Arahesis


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-20 Thread Mike Frysinger
On Sunday, June 20, 2010 09:55:39 Arfrever Frehtes Taifersar Arahesis wrote:
 2010-06-19 22:53:37 Mike Frysinger napisał(a):
  On Thursday, June 10, 2010 16:45:29 Arfrever Frehtes Taifersar wrote:
   2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar wrote:
 2010-06-10 21:27:40 Jeremy Olexa napisał(a):
 I see no reason to *not* add a ChangeLog entry here.
 
 ChangeLog entries are not required for trivial changes.

A trivial change is fixing a typo, or a manifest problem, a missing
quotation mark, etc. Anything else is not trivial.

Anything that changes how an ebuild functions, what it does, or the
installed files (and/or their contents) is NOT a trivial change.
   
   This commit only removed some compiler warnings.
  
  mucking with CFLAGS without documentation is wrong.  compiler warnings
  come and go, so a flag that was relevant one day could be completely
  extraneous the next.
  
  however, especially with strict aliasing, you arent just fixing
  warnings, you're changing optimization behavior of gcc to workaround
  broken C code. this obviously does not fall anywhere near the trivial
  mark.
  
  i see you still havent fixed this, so get on it already.  a bug needs to
  be opened somewhere to get the package properly *fixed*
 
 This problem is probably caused by bugs in Python 2, which have been fixed
 in Python 3.

the new information you've provided here only reinforces the fact the current 
code is wrong.  properly document the append-flags and properly restrict it to 
when python-2 is being used.

considering python-2 is going to be in our lives for a while, how hard is it 
to backport the changes in question to the headers ?  presumably it's 
struct/union/cast shuffling in the headers.
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-20 Thread Brian Harring
On Sun, Jun 20, 2010 at 06:27:00PM -0400, Mike Frysinger wrote:
 On Sunday, June 20, 2010 09:55:39 Arfrever Frehtes Taifersar Arahesis wrote:
  2010-06-19 22:53:37 Mike Frysinger napisał(a):
   On Thursday, June 10, 2010 16:45:29 Arfrever Frehtes Taifersar wrote:
2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
 On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar wrote:
  2010-06-10 21:27:40 Jeremy Olexa napisał(a):
  I see no reason to *not* add a ChangeLog entry here.
  
  ChangeLog entries are not required for trivial changes.
 
 A trivial change is fixing a typo, or a manifest problem, a missing
 quotation mark, etc. Anything else is not trivial.
 
 Anything that changes how an ebuild functions, what it does, or the
 installed files (and/or their contents) is NOT a trivial change.

This commit only removed some compiler warnings.
   
   mucking with CFLAGS without documentation is wrong.  compiler warnings
   come and go, so a flag that was relevant one day could be completely
   extraneous the next.
   
   however, especially with strict aliasing, you arent just fixing
   warnings, you're changing optimization behavior of gcc to workaround
   broken C code. this obviously does not fall anywhere near the trivial
   mark.
   
   i see you still havent fixed this, so get on it already.  a bug needs to
   be opened somewhere to get the package properly *fixed*
  
  This problem is probably caused by bugs in Python 2, which have been fixed
  in Python 3.
 
 the new information you've provided here only reinforces the fact the current 
 code is wrong.  properly document the append-flags and properly restrict it 
 to 
 when python-2 is being used.
 
 considering python-2 is going to be in our lives for a while, how hard is it 
 to backport the changes in question to the headers ?  presumably it's 
 struct/union/cast shuffling in the headers.

This is upstream python bug 969718 offhand; basically if cflags exists 
for distutils consumers, base cflags don't make it fully through- 
meaning no -fno-strict-aliasing as is generally needed for building 
python extensions.

As for py3k, looks of it py3.1 still suffers it.


Either way, this is the wrong thing to fix- python's distutils 
needs fixing, not consumers.  In snakeoil, we detect and fix it on the 
fly to provide a fixed version of distutils, but obviously not many 
pkgs consume that...

~harring


pgppdSJIknTLf.pgp
Description: PGP signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-19 Thread Mike Frysinger
On Thursday, June 10, 2010 16:45:29 Arfrever Frehtes Taifersar Arahesis wrote:
 2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
  On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar wrote:
   2010-06-10 21:27:40 Jeremy Olexa napisał(a):
   I see no reason to *not* add a ChangeLog entry here.
   
   ChangeLog entries are not required for trivial changes.
  
  A trivial change is fixing a typo, or a manifest problem, a missing
  quotation mark, etc. Anything else is not trivial.
  
  Anything that changes how an ebuild functions, what it does, or the
  installed files (and/or their contents) is NOT a trivial change.
 
 This commit only removed some compiler warnings.

mucking with CFLAGS without documentation is wrong.  compiler warnings come 
and go, so a flag that was relevant one day could be completely extraneous the 
next.

however, especially with strict aliasing, you arent just fixing warnings, 
you're changing optimization behavior of gcc to workaround broken C code.  
this obviously does not fall anywhere near the trivial mark.

i see you still havent fixed this, so get on it already.  a bug needs to be 
opened somewhere to get the package properly *fixed*, and your change either 
out right reverted or add a comment around the flag to indicate the open bug 
on the issue.
append-flags ... #12345
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-12 Thread Jeroen Roovers
On Thu, 10 Jun 2010 22:25:48 +0200
Arfrever Frehtes Taifersar Arahesis arfre...@gentoo.org wrote:

 If a change in EAPI doesn't require any other changes in ebuild, then
 it's a trivial change.

Trivial is when you fix spelling in text sent to stdout/stderr or
change the text of a comment. Any change to code, including variables,
is not trivial and should be documented in the ChangeLog.


 jer



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-11 Thread Alex Alexander
On Thu, Jun 10, 2010 at 11:45:14PM +0200, Rémi Cardona wrote:
 Le 10/06/2010 22:45, Arfrever Frehtes Taifersar Arahesis a écrit :
  2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
  On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar Arahesis
  arfre...@gentoo.org wrote:
  2010-06-10 21:27:40 Jeremy Olexa napisał(a):
  I see no reason to *not* add a ChangeLog entry here.
 
  ChangeLog entries are not required for trivial changes.
 
 
  A trivial change is fixing a typo, or a manifest problem, a missing
  quotation mark, etc. Anything else is not trivial.
 
  Anything that changes how an ebuild functions, what it does, or the
  installed files (and/or their contents) is NOT a trivial change.
  
  This commit only removed some compiler warnings.
  
 
 Why argue about this? Just always add a ChangeLog entry, like everyone
 else. This is in everyone's interest, including yours.

+1

besides, fixing dependencies or messing with cflags doesn't seem trivial
to me =]

-- 
Alex Alexander :: wired
Gentoo Developer
www.linuxized.com


pgpPR8plFTSTJ.pgp
Description: PGP signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-11 Thread Alexis Ballier
On Thursday 10 June 2010 23:45:29 Arfrever Frehtes Taifersar Arahesis wrote:
[...]
 This commit only removed some compiler warnings.

This adds a cflag preventing the compiler to make some assumptions on the code 
for its optimisations, hence making the code slower/bigger. While the 
changelog entry will help figuring out why this was added, a comment in the 
ebuild explaining why will be even better.
Once you'll have to dig into 4 years of cvs log to figure out wth a cflag 
filtering/addition was added into an ebuild maybe you'll reconsider your 
opinion.

Please always keep in mind that you're not the only one that will ever commit 
to $package and even less the only one that will have a look at a given 
ebuild.

A.


signature.asc
Description: This is a digitally signed message part.


[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-10 Thread Jeremy Olexa
On Thu, 10 Jun 2010 19:19:33 + (UTC), Arfrever Frehtes Taifersar
Arahesis (arfrever) arfre...@gentoo.org wrote:
 arfrever10/06/10 19:19:33
 
   Modified: traits-3.4.0.ebuild
   Log:
   Fix dependencies. Use -fno-strict-aliasing.
   (Portage version: HEAD/cvs/Linux x86_64)
 
 Revision  ChangesPath
 1.3  dev-python/traits/traits-3.4.0.ebuild

I see no reason to *not* add a ChangeLog entry here. Please, consider
the fact that some people don't want to go digging in cvs log to see who
added -fno-strict-aliasing or why. (as an example. I, personally, don't
care about -fno-strict-aliasing)

-Jeremy



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-10 Thread Nirbheek Chauhan
On Fri, Jun 11, 2010 at 1:55 AM, Arfrever Frehtes Taifersar Arahesis
arfre...@gentoo.org wrote:
 2010-06-10 22:16:23 Fabian Groffen napisał(a):
 On 10-06-2010 22:00:19 +0200, Arfrever Frehtes Taifersar Arahesis wrote:
  2010-06-10 21:27:40 Jeremy Olexa napisał(a):
   I see no reason to *not* add a ChangeLog entry here.
 
  ChangeLog entries are not required for trivial changes.

 Apart from whether or not this is true, do I understand well that you
 consider masqueraded EAPI bumps as homepage updates as trivial changes
 too? (traitsbackendwx)

 If a change in EAPI doesn't require any other changes in ebuild, then it's a 
 trivial change.


Your definitions of trivial are getting more and more convenient with
each commit.


-- 
~Nirbheek Chauhan

Gentoo GNOME+Mozilla Team



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-10 Thread Arfrever Frehtes Taifersar Arahesis
2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
 On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar Arahesis
 arfre...@gentoo.org wrote:
  2010-06-10 21:27:40 Jeremy Olexa napisał(a):
  I see no reason to *not* add a ChangeLog entry here.
 
  ChangeLog entries are not required for trivial changes.
 
 
 A trivial change is fixing a typo, or a manifest problem, a missing
 quotation mark, etc. Anything else is not trivial.
 
 Anything that changes how an ebuild functions, what it does, or the
 installed files (and/or their contents) is NOT a trivial change.

This commit only removed some compiler warnings.

-- 
Arfrever Frehtes Taifersar Arahesis


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-10 Thread Fabian Groffen
On 10-06-2010 22:00:19 +0200, Arfrever Frehtes Taifersar Arahesis wrote:
 2010-06-10 21:27:40 Jeremy Olexa napisał(a):
  I see no reason to *not* add a ChangeLog entry here.
 
 ChangeLog entries are not required for trivial changes.

Apart from whether or not this is true, do I understand well that you
consider masqueraded EAPI bumps as homepage updates as trivial changes
too? (traitsbackendwx)


-- 
Fabian Groffen
Gentoo on a different level



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-10 Thread Arfrever Frehtes Taifersar Arahesis
2010-06-10 22:16:23 Fabian Groffen napisał(a):
 On 10-06-2010 22:00:19 +0200, Arfrever Frehtes Taifersar Arahesis wrote:
  2010-06-10 21:27:40 Jeremy Olexa napisał(a):
   I see no reason to *not* add a ChangeLog entry here.
  
  ChangeLog entries are not required for trivial changes.
 
 Apart from whether or not this is true, do I understand well that you
 consider masqueraded EAPI bumps as homepage updates as trivial changes
 too? (traitsbackendwx)

If a change in EAPI doesn't require any other changes in ebuild, then it's a 
trivial change.

-- 
Arfrever Frehtes Taifersar Arahesis


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-10 Thread Rémi Cardona
Le 10/06/2010 22:45, Arfrever Frehtes Taifersar Arahesis a écrit :
 2010-06-10 22:20:44 Nirbheek Chauhan napisał(a):
 On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar Arahesis
 arfre...@gentoo.org wrote:
 2010-06-10 21:27:40 Jeremy Olexa napisał(a):
 I see no reason to *not* add a ChangeLog entry here.

 ChangeLog entries are not required for trivial changes.


 A trivial change is fixing a typo, or a manifest problem, a missing
 quotation mark, etc. Anything else is not trivial.

 Anything that changes how an ebuild functions, what it does, or the
 installed files (and/or their contents) is NOT a trivial change.
 
 This commit only removed some compiler warnings.
 

Why argue about this? Just always add a ChangeLog entry, like everyone
else. This is in everyone's interest, including yours.

Cheers,

Rémi



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in dev-python/traits: traits-3.4.0.ebuild

2010-06-10 Thread Nirbheek Chauhan
On Fri, Jun 11, 2010 at 1:30 AM, Arfrever Frehtes Taifersar Arahesis
arfre...@gentoo.org wrote:
 2010-06-10 21:27:40 Jeremy Olexa napisał(a):
 I see no reason to *not* add a ChangeLog entry here.

 ChangeLog entries are not required for trivial changes.


A trivial change is fixing a typo, or a manifest problem, a missing
quotation mark, etc. Anything else is not trivial.

Anything that changes how an ebuild functions, what it does, or the
installed files (and/or their contents) is NOT a trivial change.

-- 
~Nirbheek Chauhan

Gentoo GNOME+Mozilla Team