Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-06 Thread Todd Goodman
* Mike Frysinger vap...@gentoo.org [110705 19:01]:
 On Tuesday, July 05, 2011 19:05:23 Francesco R wrote:
  rm -f chuck norris
  rm: cannot remove `Chuck Norris': Operation not contemplated
 
 chuck norris != Chuck Norris
 -mike

If he had said Chuck Norris instead of chuck norris he wouldn'
t have just gotten a message, he'd have gotten his a$$ kicked...

Todd



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-05 Thread Francesco R
2011/7/3 Paul Arthur junk+use...@flowerysong.com:
 On 2011-07-03, Jonathan Callen a...@gentoo.org wrote:
 Peter Volkov wrote:

 rm -rf ${D}/usr/share/doc/aria2

 || die

 `rm -f` never fails -- if the target does not exist, then rm simply returns
 true. (The only reason it would fail that I can think of is /bin/rm not
 existing, in which case you have a bigger problem.)

 To test, try `rm -f /nonexistant/file; echo $?`

 jill-zeke /var/tmp $ rm -f testfile
 rm: cannot remove `testfile': Operation not permitted
 jill-zeke /var/tmp $ echo $?
 1

rm -f chuck norris
rm: cannot remove `Chuck Norris': Operation not contemplated
echo $?
42


 jill-zeke /var/tmp $ rm -rf testdir
 rm: cannot remove `testdir/test': Permission denied
 jill-zeke /var/tmp $ echo $?
 1


 --
 Suddenly, the door crashed open. Outside, purple prose rained down
 like a bad metaphor.
    --SteveD on RPGnet






Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-05 Thread Mike Frysinger
On Sunday, July 03, 2011 18:49:52 Paul Arthur wrote:
 On 2011-07-03, Jonathan Callen a...@gentoo.org wrote:
  Peter Volkov wrote:
  rm -rf ${D}/usr/share/doc/aria2
  
  || die
  
  `rm -f` never fails -- if the target does not exist, then rm simply
  returns true. (The only reason it would fail that I can think of is
  /bin/rm not existing, in which case you have a bigger problem.)
  
  To test, try `rm -f /nonexistant/file; echo $?`
 
 jill-zeke /var/tmp $ rm -f testfile
 rm: cannot remove `testfile': Operation not permitted
 jill-zeke /var/tmp $ echo $?
 1
 jill-zeke /var/tmp $ rm -rf testdir
 rm: cannot remove `testdir/test': Permission denied
 jill-zeke /var/tmp $ echo $?
 1

if this occurs *inside the ebuild env*, then most likely something else is 
screwed up and will be caught anyways

personally, i generally like to use:
rm -r ${D}/usr/share/doc/aria2 || die
that way when the package stops installing aria2, i notice and can remove the 
call to `rm` altogether ...
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-05 Thread Mike Frysinger
On Tuesday, July 05, 2011 19:05:23 Francesco R wrote:
 rm -f chuck norris
 rm: cannot remove `Chuck Norris': Operation not contemplated

chuck norris != Chuck Norris
-mike


signature.asc
Description: This is a digitally signed message part.


[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-03 Thread Jonathan Callen
Peter Volkov wrote:
 
 rm -rf ${D}/usr/share/doc/aria2
 
 || die

`rm -f` never fails -- if the target does not exist, then rm simply returns 
true. (The only reason it would fail that I can think of is /bin/rm not 
existing, in which case you have a bigger problem.)

To test, try `rm -f /nonexistant/file; echo $?`

-- 
Jonathan Callen



[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-01 Thread Peter Volkov
В Чтв, 30/06/2011 в 19:27 +, Sebastian Pipping (sping) пишет: 
 Log:
   net-misc/aria2: Bump to 1.12.0, looks trivial
  
 EAPI=2
 
 inherit bash-completion
...
 pkg_setup() {
   if use scripts  use !xmlrpc  use !metalink; then
   ewarn Please also enable the 'xmlrpc' USE flag to actually use 
 the additional scripts
   fi
 }

This really calls for REQUIRED_USE from EAPI=4.

REQUIRED_USE=scripts? ( ^^ ( xmlrpc metalink ) )

 src_install() {
   emake DESTDIR=${D} install || die emake install failed
 
   rm -rf ${D}/usr/share/doc/aria2

|| die

--
Peter. 




Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-01 Thread Ciaran McCreesh
On Fri, 01 Jul 2011 12:03:41 +0400
Peter Volkov p...@gentoo.org wrote:
  pkg_setup() {
  if use scripts  use !xmlrpc  use !metalink; then
 
 This really calls for REQUIRED_USE from EAPI=4.
 
 REQUIRED_USE=scripts? ( ^^ ( xmlrpc metalink ) )

That's not the same condition as the one in the pkg_setup.

-- 
Ciaran McCreesh


signature.asc
Description: PGP signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-01 Thread Peter Volkov
В Птн, 01/07/2011 в 09:09 +0100, Ciaran McCreesh пишет:
 On Fri, 01 Jul 2011 12:03:41 +0400
 Peter Volkov p...@gentoo.org wrote:
   pkg_setup() {
 if use scripts  use !xmlrpc  use !metalink; then
  
  This really calls for REQUIRED_USE from EAPI=4.
  
  REQUIRED_USE=scripts? ( ^^ ( xmlrpc metalink ) )
 
 That's not the same condition as the one in the pkg_setup.

Ah, yea. I guess any of xmlrpc or metalink are required for scripts. So,
correct one should be:

REQUIRED_USE=scripts? ( || ( xmlrpc metalink ) )

--
Peter.




[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-01 Thread Sebastian Pipping
On 07/01/2011 10:03 AM, Peter Volkov wrote:
 В Чтв, 30/06/2011 в 19:27 +, Sebastian Pipping (sping) пишет: 
 Log:
   net-misc/aria2: Bump to 1.12.0, looks trivial
  
 EAPI=2

 inherit bash-completion
 ...
 pkg_setup() {
  if use scripts  use !xmlrpc  use !metalink; then
  ewarn Please also enable the 'xmlrpc' USE flag to actually use 
 the additional scripts
  fi
 }
 
 This really calls for REQUIRED_USE from EAPI=4.
 
 REQUIRED_USE=scripts? ( ^^ ( xmlrpc metalink ) )

If we use EAPI 4 in that ebuild we cannot make it stable anytime soon,
correct?



Sebastian



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-01 Thread Patrick Lauer
On 07/01/11 21:25, Sebastian Pipping wrote:
[SNIP]
 If we use EAPI 4 in that ebuild we cannot make it stable anytime soon,
 correct?

As far as I'm aware we have a stable portage with EAPI 4 in the tree for
a few weeks now, so you can actively use it everywhere.


-- 
Patrick Lauer http://service.gentooexperimental.org

Gentoo Council Member and Evangelist
Part of Gentoo Benchmarks, Forensics, PostgreSQL, KDE herds



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-misc/aria2: aria2-1.12.0.ebuild ChangeLog

2011-07-01 Thread Jorge Manuel B. S. Vicetto
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

On 01-07-2011 19:33, Patrick Lauer wrote:
 On 07/01/11 21:25, Sebastian Pipping wrote:
 [SNIP]
 If we use EAPI 4 in that ebuild we cannot make it stable anytime soon,
 correct?
 
 As far as I'm aware we have a stable portage with EAPI 4 in the tree for
 a few weeks now, so you can actively use it everywhere.

This prompted me to search the council meeting logs about EAPI 4 use for
stable packages. Contrary to my recollection, this topic fell off the
council radar a few months ago.
In any case, as decided in the February[1] meeting, EAPI 4 was approved
for tree use. The first portage version with EAPI-4 support[2] was
marked stable over 3 months ago[3].
I did a quick grep in the tree and count over 500 ebuilds with EAPI 4
and amd64 or x86 keywords, so we already have quite a few EAPI=4 stable
packages in the tree.

 [1] -
http://www.gentoo.org/proj/en/council/meeting-logs/20110201-summary.txt
 [2] - https://bugs.gentoo.org/358009
 [3] -
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-apps/portage/portage-2.1.9.42.ebuild?view=log

- -- 
Regards,

Jorge Vicetto (jmbsvicetto) - jmbsvicetto at gentoo dot org
Gentoo- forums / Userrel / Devrel / KDE / Elections / RelEng
-BEGIN PGP SIGNATURE-
Version: GnuPG v2.0.17 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBCAAGBQJODnYtAAoJEC8ZTXQF1qEPub8P/1hYj/8jyw6eligk+pUV3P8W
/yUK/71w3Em151IlVF4nkCRLhCM0FW+TpqVcmau/EKja5wzL/X+vaIaGKwjqfh39
Z3O0cjCs8hV/SZ/AscHkdiLG4TmL8M0zeHmTc7xKw1FW7QuLe6nOuZoBOSlYVwqX
M+g/dm/snxQcfsxn0YNNn2g/GYrk8whUg6YBmqdqSlElh5xJS1Zvi+BokAPQqgu8
mK4DMs2yxEb6aOXsvCYDiwLgPfxZVCbAkXoqqEOQtHjoA76lDUt3LByP11fCTZXo
ysUqDlXbL98ToX/jPRNNDLjdFKKKnaTcYjdEM1mzyou1i/tvQWJaTuvPrZzPohCy
ph21dEJKEq70ECSCBUr26HQ9bOSyEDcyV415SENFt1Rp8lXhK4dIwPDXsMrHkC1F
DzBa/8sGwFjtlLqj+x2pOzROx8lBrSRZE7vVwW4fabpoqM1VSqtqQSsQLufqpzz5
MpEtvf8kr9d6G2rHUzEDN0PuOj5ouwEi0AyG0IutAgIRx7UO4SmGrY0tbfImdgvd
O9ynGdbrGd9zlRBsbrdtGHlNmAzF8C9+ZgxzMUduHKFfNNYdPeAmV6lO8EjZDKF6
PLyUVKx0dh1RUsYwtJRV/RSWzRjtuqeoLDjMR5lxchB+MaF4qw1FGYTiU/Sg6Szw
gUmWGfpa/FQzM6uThtmp
=TiQL
-END PGP SIGNATURE-