Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in sys-cluster/drbd: ChangeLog drbd-8.0.6.ebuild

2007-09-23 Thread Daniel Drake

Donnie Berkholz wrote:

cd ${S}



cp -R /usr/src/linux-${KV} ${WORKDIR}
emake -j1 KDIR=/${WORKDIR}/linux-${KV} O=${KBUILD_OUTPUT} || die 
compile problem


This is not the way that linux-mod is intended to be used. You should be 
setting MODULE_NAMES, BUILD_PARAMS, BUILD_TARGETS, etc. Then 
linux_mod_src_compile and src_install will handle compilation and 
installation of the module.


Look at coda-kernel for a simple example.

Daniel

--
[EMAIL PROTECTED] mailing list



[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in sys-cluster/drbd: ChangeLog drbd-8.0.6.ebuild

2007-09-20 Thread Donnie Berkholz
On 08:35 Thu 20 Sep , Christian Zoffoli (xmerlin) wrote:
 xmerlin 07/09/20 08:35:22
 
   Modified: ChangeLog
   Added:drbd-8.0.6.ebuild
   Log:
   Version Bump.
   (Portage version: 2.1.2.2)

 1.1  sys-cluster/drbd/drbd-8.0.6.ebuild
 
 file : 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-cluster/drbd/drbd-8.0.6.ebuild?rev=1.1view=markup
 plain: 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-cluster/drbd/drbd-8.0.6.ebuild?rev=1.1content-type=text/plain

 pkg_setup() {
   linux-mod_pkg_setup
 }

You're just doing the default here.

   cd ${S}

   cp -R /usr/src/linux-${KV} ${WORKDIR}
   emake -j1 KDIR=/${WORKDIR}/linux-${KV} O=${KBUILD_OUTPUT} || 
 die compile problem

 src_install() {
   emake PREFIX=${D} install || die install problem

   rm -f ${D}/etc/drbd.conf

Might want to quote S, WORKDIR and D, to allow for spaces.

Thanks,
Donnie
-- 
[EMAIL PROTECTED] mailing list



Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in sys-cluster/drbd: ChangeLog drbd-8.0.6.ebuild

2007-09-20 Thread Mike Frysinger
On Thursday 20 September 2007, Donnie Berkholz wrote:
 On 08:35 Thu 20 Sep , Christian Zoffoli (xmerlin) wrote:
  1.1  sys-cluster/drbd/drbd-8.0.6.ebuild
 
  cp -R /usr/src/linux-${KV} ${WORKDIR}

that cant be right

  emake -j1 KDIR=/${WORKDIR}/linux-${KV} O=${KBUILD_OUTPUT} || die

prefixing $WORKDIR with a / is just silly
-mike


signature.asc
Description: This is a digitally signed message part.