Re: [gentoo-dev] Re: gentoo-x86 commit in app-forensics/sleuthkit: ChangeLog sleuthkit-3.0.0.ebuild

2009-01-05 Thread Nirbheek Chauhan
On Mon, Jan 5, 2009 at 5:42 AM, Torsten Veller ml...@veller.net wrote:
 src_unpack() {
   unpack ${A}
   ^^ often not wanted

Did you mean to point to the quotes? If so, not often, *never* wanted
since SRC_URI is whitespace-separated, and URLs having spaces should
escape them to %20

Actually, I'm surprised that this ebuild made it through repoman since
_atleast_ the IUSE check is an error

-- 
~Nirbheek Chauhan



[gentoo-dev] Re: gentoo-x86 commit in app-forensics/sleuthkit: ChangeLog sleuthkit-3.0.0.ebuild

2009-01-04 Thread Torsten Veller
* Patrick Lauer (patrick) patr...@gentoo.org:
 file : 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.0.0.ebuild?rev=1.1view=markup
 plain: 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.0.0.ebuild?rev=1.1content-type=text/plain
 
 
 inherit eutils flag-o-matic autotools
 
 SLOT=0
 
 DESCRIPTION=A collection of file system and media management forensic 
 analysis tools
 HOMEPAGE=http://www.sleuthkit.org/sleuthkit/;
 SRC_URI=mirror://sourceforge/sleuthkit/${P}.tar.gz
 
 LICENSE=GPL-2 IBM
 KEYWORDS=~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86

no IUSE.

 # disabling until imported into portage - patrick
 #DEPEND=ewf? ( app-forensics/libewf )
 # aff? ( app-forensics/afflib )
 RDEPEND=dev-perl/DateManip
 
 src_unpack() {
   unpack ${A}
   ^^ often not wanted
   cd ${S}
   # AC_FUNC_REALLOC in configure.ac that hasn't been propagated
   eautoreconf
 }
 
 src_compile() {
   use hfs  append-flags -DTSK_USE_HFS
^^^
   econf   || die configure failed
   emake || die make failed
 }
 
 src_install() {
   emake install DESTDIR=${D}
^ || die
   dodoc docs/*.txt README.txt CHANGES.txt TODO.txt
 }