[gentoo-dev] Re: gentoo-x86 commit in x11-wm/awesome: awesome-1.2.ebuild Manifest metadata.xml ChangeLog

2007-09-29 Thread Torsten Veller
* Matsuu Takuto (matsuu) [EMAIL PROTECTED]:
 Revision  ChangesPath
 1.1  x11-wm/awesome/awesome-1.2.ebuild
 
 file : 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/x11-wm/awesome/awesome-1.2.ebuild?rev=1.1view=markup
 plain: 
 http://sources.gentoo.org/viewcvs.py/gentoo-x86/x11-wm/awesome/awesome-1.2.ebuild?rev=1.1content-type=text/plain
 
 src_unpack() {
   unpack ${A}
   cd ${S}
 
   sed -i \
   -e /^CFLAGS/s/=.*-O3/= ${CFLAGS}/ \
   -e /^LDFLAGS/s/-ggdb3/${LDFLAGS}/ \
   -e /^CC/s/cc/$(tc-getCC)/ \
 ^
This fails if tc-getCC returns the path to the compiler, if tc-getCC
contains a slash.

   -e s:/usr/lib:/usr/$(get_libdir): \
   -e s:/usr/local:/usr: \
   config.mk || die sed failed
 }

-- 
.: Torsten |   :.
-- 
[EMAIL PROTECTED] mailing list



Re: [gentoo-dev] Re: gentoo-x86 commit in x11-wm/awesome: awesome-1.2.ebuild Manifest metadata.xml ChangeLog

2007-09-29 Thread Mike Frysinger
On Saturday 29 September 2007, Piotr Jaroszyński wrote:
 On Sunday 30 of September 2007 02:53:47 Mike Frysinger wrote:
  On Saturday 29 September 2007, Piotr Jaroszyński wrote:
   On Sunday 30 of September 2007 00:54:29 Torsten Veller wrote:
This fails if tc-getCC returns the path to the compiler
  
   It doesn't, see toolchain-funcs.eclass.
 
  it may, see toolchain-funcs.eclass
 
  $CC is respected from user env and nothing stops the user from doing
  CC=/moo/moo/mr/compiler (and in fact, users have)
 
  the generally accepted sed separator is :, not /, for specifically this
  reason ... your CFLAGS/LDFLAGS should also get changed as that prevents
  people from doing `-L/foo` or `-I /moo` or such things

 right, sorry for the noise especially as it wasn't my commit in the first
 place :)

it isnt noise if you learned something ... you *did* learn *something* didnt 
you ?

flying puppies are awesome
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: gentoo-x86 commit in x11-wm/awesome: awesome-1.2.ebuild Manifest metadata.xml ChangeLog

2007-09-29 Thread Mike Frysinger
On Saturday 29 September 2007, Piotr Jaroszyński wrote:
 On Sunday 30 of September 2007 00:54:29 Torsten Veller wrote:
  This fails if tc-getCC returns the path to the compiler

 It doesn't, see toolchain-funcs.eclass.

it may, see toolchain-funcs.eclass

$CC is respected from user env and nothing stops the user from doing 
CC=/moo/moo/mr/compiler (and in fact, users have)

the generally accepted sed separator is :, not /, for specifically this 
reason ... your CFLAGS/LDFLAGS should also get changed as that prevents 
people from doing `-L/foo` or `-I /moo` or such things
-mike


signature.asc
Description: This is a digitally signed message part.


Re: [gentoo-dev] Re: gentoo-x86 commit in x11-wm/awesome: awesome-1.2.ebuild Manifest metadata.xml ChangeLog

2007-09-29 Thread Piotr Jaroszyński
On Sunday 30 of September 2007 00:54:29 Torsten Veller wrote:
 This fails if tc-getCC returns the path to the compiler
It doesn't, see toolchain-funcs.eclass.

-- 
Best Regards,
Piotr Jaroszyński
--
[EMAIL PROTECTED] mailing list



Re: [gentoo-dev] Re: gentoo-x86 commit in x11-wm/awesome: awesome-1.2.ebuild Manifest metadata.xml ChangeLog

2007-09-29 Thread Piotr Jaroszyński
On Sunday 30 of September 2007 02:53:47 Mike Frysinger wrote:
 On Saturday 29 September 2007, Piotr Jaroszyński wrote:
  On Sunday 30 of September 2007 00:54:29 Torsten Veller wrote:
   This fails if tc-getCC returns the path to the compiler
 
  It doesn't, see toolchain-funcs.eclass.

 it may, see toolchain-funcs.eclass

 $CC is respected from user env and nothing stops the user from doing
 CC=/moo/moo/mr/compiler (and in fact, users have)

 the generally accepted sed separator is :, not /, for specifically this
 reason ... your CFLAGS/LDFLAGS should also get changed as that prevents
 people from doing `-L/foo` or `-I /moo` or such things
 -mike

right, sorry for the noise especially as it wasn't my commit in the first 
place :)

-- 
Best Regards,
Piotr Jaroszyński
--
[EMAIL PROTECTED] mailing list