Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-11 Thread laforge
laforge has submitted this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..

Intoduce Packet Switch CGI

This structure is needed in order to identify a given cell within the
BSS during RIM transactions.
The naming was made up by myself since I couldn't find any naming
reference for this kind of data (RAI + CI).
Since LAI + CI = CGI, then RAI + CI = CGI-PS

osmo_rai_name2 family of functions get a "2" suffix due to already
existing functions handling struct struct gprs_ra_id in gsm48.h

Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
---
M include/osmocom/gsm/gsm0808_utils.h
M include/osmocom/gsm/gsm23003.h
M include/osmocom/gsm/protocol/gsm_08_08.h
M src/gsm/gsm0808_utils.c
M src/gsm/gsm23003.c
M src/gsm/libosmogsm.map
6 files changed, 136 insertions(+), 0 deletions(-)

Approvals:
  laforge: Looks good to me, approved
  dexter: Looks good to me, but someone else must approve
  Jenkins Builder: Verified



diff --git a/include/osmocom/gsm/gsm0808_utils.h 
b/include/osmocom/gsm/gsm0808_utils.h
index 59db6ed..76e9064 100644
--- a/include/osmocom/gsm/gsm0808_utils.h
+++ b/include/osmocom/gsm/gsm0808_utils.h
@@ -44,6 +44,7 @@
uint16_tci;
struct osmo_location_area_idlai_and_lac;
uint16_tlac;
+   struct osmo_cell_global_id_ps   global_ps;
 };

 /*! Parsed representation of Cell Identifier IE (3GPP TS 48.008 3.2.2.17) */
diff --git a/include/osmocom/gsm/gsm23003.h b/include/osmocom/gsm/gsm23003.h
index 69f00f6..fbe0ca0 100644
--- a/include/osmocom/gsm/gsm23003.h
+++ b/include/osmocom/gsm/gsm23003.h
@@ -30,6 +30,11 @@
uint16_t cell_identity;
 };

+struct osmo_cell_global_id_ps {
+   struct osmo_routing_area_id rai;
+   uint16_t cell_identity;
+};
+
 /*! Bitmask of items contained in a struct osmo_cell_global_id.
  * See also gsm0808_cell_id_to_cgi().
  */
@@ -37,6 +42,7 @@
OSMO_CGI_PART_PLMN = 1,
OSMO_CGI_PART_LAC = 2,
OSMO_CGI_PART_CI = 4,
+   OSMO_CGI_PART_RAC = 8,
 };

 /* Actually defined in 3GPP TS 48.008 3.2.2.27 Cell Identifier List,
@@ -117,10 +123,17 @@
 const char *osmo_lai_name(const struct osmo_location_area_id *lai);
 char *osmo_lai_name_buf(char *buf, size_t buf_len, const struct 
osmo_location_area_id *lai);
 char *osmo_lai_name_c(const void *ctx, const struct osmo_location_area_id 
*lai);
+const char *osmo_rai_name2(const struct osmo_routing_area_id *rai);
+char *osmo_rai_name2_buf(char *buf, size_t buf_len, const struct 
osmo_routing_area_id *rai);
+char *osmo_rai_name2_c(const void *ctx, const struct osmo_routing_area_id 
*rai);
 const char *osmo_cgi_name(const struct osmo_cell_global_id *cgi);
 const char *osmo_cgi_name2(const struct osmo_cell_global_id *cgi);
 char *osmo_cgi_name_buf(char *buf, size_t buf_len, const struct 
osmo_cell_global_id *cgi);
 char *osmo_cgi_name_c(const void *ctx, const struct osmo_cell_global_id *cgi);
+const char *osmo_cgi_ps_name(const struct osmo_cell_global_id_ps *cgi_ps);
+const char *osmo_cgi_ps_name2(const struct osmo_cell_global_id_ps *cgi_ps);
+char *osmo_cgi_ps_name_buf(char *buf, size_t buf_len, const struct 
osmo_cell_global_id_ps *cgi_ps);
+char *osmo_cgi_ps_name_c(const void *ctx, const struct osmo_cell_global_id_ps 
*cgi_ps);
 const char *osmo_gummei_name(const struct osmo_gummei *gummei);
 char *osmo_gummei_name_buf(char *buf, size_t buf_len, const struct osmo_gummei 
*gummei);
 char *osmo_gummei_name_c(const void *ctx, const struct osmo_gummei *gummei);
diff --git a/include/osmocom/gsm/protocol/gsm_08_08.h 
b/include/osmocom/gsm/protocol/gsm_08_08.h
index 1390f0e..fe7776b 100644
--- a/include/osmocom/gsm/protocol/gsm_08_08.h
+++ b/include/osmocom/gsm/protocol/gsm_08_08.h
@@ -25,6 +25,9 @@
CELL_IDENT_UTRAN_PLMN_LAC_RNC   = 8,
CELL_IDENT_UTRAN_RNC= 9,
CELL_IDENT_UTRAN_LAC_RNC= 10,
+
+   /* Not in 03.03 nor 08.08 */
+   CELL_IDENT_WHOLE_GLOBAL_PS  = 11, /* CGI with + RAC */
 };
 /* Keep this misnamed CELL_IDENT for API backwards compatibility (see 
OS#3124). */
 #define CELL_IDENT_LAI_AND_LAC CELL_IDENT_LAI
diff --git a/src/gsm/gsm0808_utils.c b/src/gsm/gsm0808_utils.c
index 6bf771f..c1b0a00 100644
--- a/src/gsm/gsm0808_utils.c
+++ b/src/gsm/gsm0808_utils.c
@@ -784,6 +784,8 @@
case CELL_IDENT_BSS:
case CELL_IDENT_NO_CELL:
return 0;
+   case CELL_IDENT_WHOLE_GLOBAL_PS:
+   return 8;
default:
return -EINVAL;
}
@@ -828,6 +830,13 @@
case CELL_IDENT_NO_CELL:
/* Does not have any list items */
break;
+   case CELL_IDENT_WHOLE_GLOBAL_PS:
+   if (len < 8)
+   return -EINVAL;
+   decode_lai(buf, (struct osmo_location_area_id 
*)>global_ps.rai); /* rai 

Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-11 Thread laforge
laforge has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..


Patch Set 6: Code-Review+2


--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 6
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter 
Gerrit-Reviewer: laforge 
Gerrit-Comment-Date: Mon, 11 Jan 2021 14:22:07 +
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-08 Thread dexter
dexter has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..


Patch Set 6: Code-Review+1


--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 6
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter 
Gerrit-Reviewer: laforge 
Gerrit-Comment-Date: Fri, 08 Jan 2021 16:30:42 +
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-08 Thread pespin
Hello Jenkins Builder, laforge, dexter,

I'd like you to reexamine a change. Please visit

https://gerrit.osmocom.org/c/libosmocore/+/22013

to look at the new patch set (#6).

Change subject: Intoduce Packet Switch CGI
..

Intoduce Packet Switch CGI

This structure is needed in order to identify a given cell within the
BSS during RIM transactions.
The naming was made up by myself since I couldn't find any naming
reference for this kind of data (RAI + CI).
Since LAI + CI = CGI, then RAI + CI = CGI-PS

osmo_rai_name2 family of functions get a "2" suffix due to already
existing functions handling struct struct gprs_ra_id in gsm48.h

Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
---
M include/osmocom/gsm/gsm0808_utils.h
M include/osmocom/gsm/gsm23003.h
M include/osmocom/gsm/protocol/gsm_08_08.h
M src/gsm/gsm0808_utils.c
M src/gsm/gsm23003.c
M src/gsm/libosmogsm.map
6 files changed, 136 insertions(+), 0 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/13/22013/6
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 6
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter 
Gerrit-Reviewer: laforge 
Gerrit-MessageType: newpatchset


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-08 Thread pespin
Hello Jenkins Builder, laforge, dexter,

I'd like you to reexamine a change. Please visit

https://gerrit.osmocom.org/c/libosmocore/+/22013

to look at the new patch set (#5).

Change subject: Intoduce Packet Switch CGI
..

Intoduce Packet Switch CGI

This structure is needed in order to identify a given cell within the
BSS during RIM transactions.
The naming was made up by myself since I couldn't find any naming
reference for this kind of data (RAI + CI).
Since LAI + CI = CGI, then RAI + CI = CGI-PS

osmo_rai_name2 family of functions get a "2" suffix due to already
existing functions handling struct struct gprs_ra_id in gsm48.h

Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
---
M include/osmocom/gsm/gsm0808_utils.h
M include/osmocom/gsm/gsm23003.h
M include/osmocom/gsm/protocol/gsm_08_08.h
M src/gsm/gsm0808_utils.c
M src/gsm/gsm23003.c
M src/gsm/libosmogsm.map
6 files changed, 136 insertions(+), 0 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/13/22013/5
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 5
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter 
Gerrit-Reviewer: laforge 
Gerrit-MessageType: newpatchset


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-08 Thread dexter
dexter has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..


Patch Set 4: Code-Review+1


--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 4
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter 
Gerrit-Reviewer: laforge 
Gerrit-Comment-Date: Fri, 08 Jan 2021 15:26:36 +
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-08 Thread pespin
Hello Jenkins Builder, laforge, dexter,

I'd like you to reexamine a change. Please visit

https://gerrit.osmocom.org/c/libosmocore/+/22013

to look at the new patch set (#4).

Change subject: Intoduce Packet Switch CGI
..

Intoduce Packet Switch CGI

This structure is needed in order to identify a given cell within the
BSS during RIM transactions.
The naming was made up by myself since I couldn't find any naming
reference for this kind of data (RAI + CI).
Since LAI + CI = CGI, then RAI + CI = CGI-PS

osmo_rai_name2 family of functions get a "2" suffix due to already
existing functions handling struct struct gprs_ra_id in gsm48.h

Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
---
M include/osmocom/gsm/gsm0808_utils.h
M include/osmocom/gsm/gsm23003.h
M include/osmocom/gsm/protocol/gsm_08_08.h
M src/gsm/gsm0808_utils.c
M src/gsm/gsm23003.c
5 files changed, 129 insertions(+), 0 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/13/22013/4
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 4
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter 
Gerrit-Reviewer: laforge 
Gerrit-MessageType: newpatchset


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-08 Thread dexter
dexter has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..


Patch Set 3: Code-Review+1


--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 3
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter 
Gerrit-Reviewer: laforge 
Gerrit-Comment-Date: Fri, 08 Jan 2021 15:07:54 +
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-07 Thread laforge
laforge has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..


Patch Set 3: Code-Review+2


--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 3
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge 
Gerrit-Comment-Date: Thu, 07 Jan 2021 18:52:07 +
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-07 Thread pespin
Hello Jenkins Builder, laforge,

I'd like you to reexamine a change. Please visit

https://gerrit.osmocom.org/c/libosmocore/+/22013

to look at the new patch set (#3).

Change subject: Intoduce Packet Switch CGI
..

Intoduce Packet Switch CGI

This structure is needed in order to identify a given cell within the
BSS during RIM transactions.
The naming was made up by myself since I couldn't find any naming
reference for this kind of data (RAI + CI).
Since LAI + CI = CGI, then RAI + CI = CGI-PS

Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
---
M include/osmocom/gsm/gsm0808_utils.h
M include/osmocom/gsm/gsm23003.h
M include/osmocom/gsm/protocol/gsm_08_08.h
M src/gsm/gsm0808_utils.c
4 files changed, 15 insertions(+), 0 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/13/22013/3
--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 3
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge 
Gerrit-MessageType: newpatchset


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-07 Thread laforge
laforge has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..


Patch Set 2: Code-Review+1

(1 comment)

https://gerrit.osmocom.org/c/libosmocore/+/22013/2//COMMIT_MSG
Commit Message:

https://gerrit.osmocom.org/c/libosmocore/+/22013/2//COMMIT_MSG@1
PS2, Line 1: Parent: cea0c305 (gsm_08_18: add struct to parse RIM PDU 
Indications)
I'm sure it doesn't identify a SGSN, right?  A Cell within the BSS/RAN/PCU?



--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 2
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge 
Gerrit-Comment-Date: Thu, 07 Jan 2021 17:28:46 +
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment


Change in libosmocore[master]: Intoduce Packet Switch CGI

2021-01-07 Thread pespin
pespin has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/22013 )

Change subject: Intoduce Packet Switch CGI
..


Patch Set 2:

This change is ready for review.


--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22013
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: If48f412c32e8e5a3e604a78d12b74787a4786374
Gerrit-Change-Number: 22013
Gerrit-PatchSet: 2
Gerrit-Owner: pespin 
Gerrit-Reviewer: Jenkins Builder
Gerrit-Comment-Date: Thu, 07 Jan 2021 14:18:05 +
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment