Change in libosmocore[master]: rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI

2018-12-19 Thread Harald Welte
Harald Welte has submitted this change and it was merged. ( 
https://gerrit.osmocom.org/12374 )

Change subject: rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI
..

rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI

The name "LAI AND LAC" makes no sense because a LAC
is part of a LAI. Keep the old name available for
API backwards compatibility.

Change-Id: I2749cf75b7b45de0cd43cf4c696a6b6984f5a065
Related: OS#3124
---
M include/osmocom/gsm/protocol/gsm_08_08.h
1 file changed, 3 insertions(+), 2 deletions(-)

Approvals:
  Jenkins Builder: Verified
  Harald Welte: Looks good to me, approved



diff --git a/include/osmocom/gsm/protocol/gsm_08_08.h 
b/include/osmocom/gsm/protocol/gsm_08_08.h
index cb9fe01..676d1cf 100644
--- a/include/osmocom/gsm/protocol/gsm_08_08.h
+++ b/include/osmocom/gsm/protocol/gsm_08_08.h
@@ -18,14 +18,15 @@
CELL_IDENT_LAC_AND_CI   = 1,
CELL_IDENT_CI   = 2,
CELL_IDENT_NO_CELL  = 3,
-   CELL_IDENT_LAI_AND_LAC  = 4,
+   CELL_IDENT_LAI  = 4,
CELL_IDENT_LAC  = 5,
CELL_IDENT_BSS  = 6,
CELL_IDENT_UTRAN_PLMN_LAC_RNC   = 8,
CELL_IDENT_UTRAN_RNC= 9,
CELL_IDENT_UTRAN_LAC_RNC= 10,
 };
-
+/* Keep this misnamed CELL_IDENT for API backwards compatibility (see 
OS#3124). */
+#define CELL_IDENT_LAI_AND_LAC CELL_IDENT_LAI

 /* GSM 08.06 § 6.3 */
 enum BSSAP_MSG_TYPE {

--
To view, visit https://gerrit.osmocom.org/12374
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-MessageType: merged
Gerrit-Change-Id: I2749cf75b7b45de0cd43cf4c696a6b6984f5a065
Gerrit-Change-Number: 12374
Gerrit-PatchSet: 2
Gerrit-Owner: Stefan Sperling 
Gerrit-Reviewer: Harald Welte 
Gerrit-Reviewer: Jenkins Builder (102)


Change in libosmocore[master]: rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI

2018-12-19 Thread Harald Welte
Harald Welte has posted comments on this change. ( 
https://gerrit.osmocom.org/12374 )

Change subject: rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI
..


Patch Set 2: Code-Review+2


--
To view, visit https://gerrit.osmocom.org/12374
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I2749cf75b7b45de0cd43cf4c696a6b6984f5a065
Gerrit-Change-Number: 12374
Gerrit-PatchSet: 2
Gerrit-Owner: Stefan Sperling 
Gerrit-Reviewer: Harald Welte 
Gerrit-Reviewer: Jenkins Builder (102)
Gerrit-Comment-Date: Wed, 19 Dec 2018 20:49:59 +
Gerrit-HasComments: No
Gerrit-HasLabels: Yes


Change in libosmocore[master]: rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI

2018-12-19 Thread Stefan Sperling
Stefan Sperling has uploaded this change for review. ( 
https://gerrit.osmocom.org/12374


Change subject: rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI
..

rename CELL_IDENT_LAI_AND_LAC to CELL_IDENT_LAI

The name "LAI AND LAC" makes no sense because a LAC
is part of a LAI. Keep the old name available for
API backwards compatibility.

Change-Id: I2749cf75b7b45de0cd43cf4c696a6b6984f5a065
Related: OS#3124
---
M include/osmocom/gsm/protocol/gsm_08_08.h
1 file changed, 3 insertions(+), 2 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/74/12374/1

diff --git a/include/osmocom/gsm/protocol/gsm_08_08.h 
b/include/osmocom/gsm/protocol/gsm_08_08.h
index cb9fe01..676d1cf 100644
--- a/include/osmocom/gsm/protocol/gsm_08_08.h
+++ b/include/osmocom/gsm/protocol/gsm_08_08.h
@@ -18,14 +18,15 @@
CELL_IDENT_LAC_AND_CI   = 1,
CELL_IDENT_CI   = 2,
CELL_IDENT_NO_CELL  = 3,
-   CELL_IDENT_LAI_AND_LAC  = 4,
+   CELL_IDENT_LAI  = 4,
CELL_IDENT_LAC  = 5,
CELL_IDENT_BSS  = 6,
CELL_IDENT_UTRAN_PLMN_LAC_RNC   = 8,
CELL_IDENT_UTRAN_RNC= 9,
CELL_IDENT_UTRAN_LAC_RNC= 10,
 };
-
+/* Keep this misnamed CELL_IDENT for API backwards compatibility (see 
OS#3124). */
+#define CELL_IDENT_LAI_AND_LAC CELL_IDENT_LAI

 /* GSM 08.06 § 6.3 */
 enum BSSAP_MSG_TYPE {

--
To view, visit https://gerrit.osmocom.org/12374
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: I2749cf75b7b45de0cd43cf4c696a6b6984f5a065
Gerrit-Change-Number: 12374
Gerrit-PatchSet: 1
Gerrit-Owner: Stefan Sperling