Change in osmo-trx[master]: tests: rename convolve_test -> ConvolveTest

2018-12-12 Thread osmith
osmith has abandoned this change. ( https://gerrit.osmocom.org/12244 )

Change subject: tests: rename convolve_test -> ConvolveTest
..


Abandoned
--
To view, visit https://gerrit.osmocom.org/12244
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-trx
Gerrit-Branch: master
Gerrit-MessageType: abandon
Gerrit-Change-Id: I4ca533ca8c5e19b6dbe7b0aba672ee14cf5c3bd1
Gerrit-Change-Number: 12244
Gerrit-PatchSet: 1
Gerrit-Owner: osmith 
Gerrit-Reviewer: Jenkins Builder (102)
Gerrit-Reviewer: Neels Hofmeyr 
Gerrit-Reviewer: Pau Espin Pedrol 


Change in osmo-trx[master]: tests: rename convolve_test -> ConvolveTest

2018-12-11 Thread Pau Espin Pedrol
Pau Espin Pedrol has posted comments on this change. ( 
https://gerrit.osmocom.org/12244 )

Change subject: tests: rename convolve_test -> ConvolveTest
..


Patch Set 1: Code-Review-1

> hmm, the others are *.cpp files and this is a *.c file, so the
 > naming schemes sort of match before this patch?

Agree with Neels. I'd actually move all to foo_bar, but no need to spend time 
on that :)


--
To view, visit https://gerrit.osmocom.org/12244
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-trx
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I4ca533ca8c5e19b6dbe7b0aba672ee14cf5c3bd1
Gerrit-Change-Number: 12244
Gerrit-PatchSet: 1
Gerrit-Owner: osmith 
Gerrit-Reviewer: Jenkins Builder (102)
Gerrit-Reviewer: Neels Hofmeyr 
Gerrit-Reviewer: Pau Espin Pedrol 
Gerrit-Comment-Date: Tue, 11 Dec 2018 17:38:30 +
Gerrit-HasComments: No
Gerrit-HasLabels: Yes


Change in osmo-trx[master]: tests: rename convolve_test -> ConvolveTest

2018-12-11 Thread Neels Hofmeyr
Neels Hofmeyr has posted comments on this change. ( 
https://gerrit.osmocom.org/12244 )

Change subject: tests: rename convolve_test -> ConvolveTest
..


Patch Set 1: Code-Review-1

hmm, the others are *.cpp files and this is a *.c file, so the naming schemes 
sort of match before this patch?


--
To view, visit https://gerrit.osmocom.org/12244
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-trx
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I4ca533ca8c5e19b6dbe7b0aba672ee14cf5c3bd1
Gerrit-Change-Number: 12244
Gerrit-PatchSet: 1
Gerrit-Owner: osmith 
Gerrit-Reviewer: Jenkins Builder (102)
Gerrit-Reviewer: Neels Hofmeyr 
Gerrit-Comment-Date: Tue, 11 Dec 2018 16:01:32 +
Gerrit-HasComments: No
Gerrit-HasLabels: Yes


Change in osmo-trx[master]: tests: rename convolve_test -> ConvolveTest

2018-12-11 Thread osmith
osmith has uploaded this change for review. ( https://gerrit.osmocom.org/12244


Change subject: tests: rename convolve_test -> ConvolveTest
..

tests: rename convolve_test -> ConvolveTest

Make the test's name consistent with all other tests in this
repository. This makes adding new tests to
tests/Transceiver52M/Makefile.am less awkward (follow-up commit),
because it is clear now which casing should be used.

Change-Id: I4ca533ca8c5e19b6dbe7b0aba672ee14cf5c3bd1
---
M .gitignore
R tests/Transceiver52M/ConvolveTest.c
R tests/Transceiver52M/ConvolveTest.ok
M tests/Transceiver52M/Makefile.am
M tests/testsuite.at
5 files changed, 12 insertions(+), 12 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/osmo-trx refs/changes/44/12244/1

diff --git a/.gitignore b/.gitignore
index ad4c4e3..92fc723 100644
--- a/.gitignore
+++ b/.gitignore
@@ -17,7 +17,7 @@
 tests/CommonLibs/URLEncodeTest
 tests/CommonLibs/VectorTest
 tests/CommonLibs/PRBSTest
-tests/Transceiver52M/convolve_test
+tests/Transceiver52M/ConvolveTest

 # automake/autoconf
 *.in
diff --git a/tests/Transceiver52M/convolve_test.c 
b/tests/Transceiver52M/ConvolveTest.c
similarity index 100%
rename from tests/Transceiver52M/convolve_test.c
rename to tests/Transceiver52M/ConvolveTest.c
diff --git a/tests/Transceiver52M/convolve_test.ok 
b/tests/Transceiver52M/ConvolveTest.ok
similarity index 100%
rename from tests/Transceiver52M/convolve_test.ok
rename to tests/Transceiver52M/ConvolveTest.ok
diff --git a/tests/Transceiver52M/Makefile.am b/tests/Transceiver52M/Makefile.am
index 06db5b0..a9d3992 100644
--- a/tests/Transceiver52M/Makefile.am
+++ b/tests/Transceiver52M/Makefile.am
@@ -2,17 +2,17 @@

 AM_CFLAGS = -Wall -I$(top_srcdir)/Transceiver52M 
-I$(top_srcdir)/Transceiver52M/arch/common $(STD_DEFINES_AND_INCLUDES) -g

-EXTRA_DIST = convolve_test.ok
+EXTRA_DIST = ConvolveTest.ok

 noinst_PROGRAMS = \
-   convolve_test
+   ConvolveTest

-convolve_test_SOURCES = convolve_test.c
-convolve_test_CFLAGS = $(AM_CFLAGS)
-convolve_test_LDADD = $(COMMON_LA) $(ARCH_LA)
+ConvolveTest_SOURCES = ConvolveTest.c
+ConvolveTest_CFLAGS = $(AM_CFLAGS)
+ConvolveTest_LDADD = $(COMMON_LA) $(ARCH_LA)
 if HAVE_SSE3
-convolve_test_CFLAGS += $(SIMD_FLAGS)
+ConvolveTest_CFLAGS += $(SIMD_FLAGS)
 endif
 if HAVE_SSE4_1
-convolve_test_CFLAGS += $(SIMD_FLAGS)
+ConvolveTest_CFLAGS += $(SIMD_FLAGS)
 endif
diff --git a/tests/testsuite.at b/tests/testsuite.at
index f84225e..1968481 100644
--- a/tests/testsuite.at
+++ b/tests/testsuite.at
@@ -44,10 +44,10 @@
 AT_CHECK([$abs_top_builddir/tests/CommonLibs/VectorTest], [], [expout], [])
 AT_CLEANUP

-AT_SETUP([convolve_test])
-AT_KEYWORDS([convolve_test])
+AT_SETUP([ConvolveTest])
+AT_KEYWORDS([ConvolveTest])
 # Different results for i686, x86_64 and ARM. see  OS#2826, OS#2828, and 
https://lists.osmocom.org/pipermail/openbsc/2018-January/011655.html
 AT_SKIP_IF(true)
-cat $abs_srcdir/Transceiver52M/convolve_test.ok > expout
-AT_CHECK([$abs_top_builddir/tests/Transceiver52M/convolve_test], [], [expout], 
[])
+cat $abs_srcdir/Transceiver52M/ConvolveTest.ok > expout
+AT_CHECK([$abs_top_builddir/tests/Transceiver52M/ConvolveTest], [], [expout], 
[])
 AT_CLEANUP

--
To view, visit https://gerrit.osmocom.org/12244
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-trx
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: I4ca533ca8c5e19b6dbe7b0aba672ee14cf5c3bd1
Gerrit-Change-Number: 12244
Gerrit-PatchSet: 1
Gerrit-Owner: osmith