[PATCH v4 0/1] general style: replaces memcmp() with starts_with()

2014-03-17 Thread Quint Guvernator
Hi again, all.

I've gone through the patch again to filter for the use of magic numbers so
that I can leave those hunks alone. Junio says, and Michael agrees, that:

 The original hunks show that the code knows and relies on magic numbers 7
 and 8 very clearly and there are rooms for improvement.  The result after
 the conversion, however, still have the same magic numbers, but one less
 of them each.  Doesn't it make it harder to later spot the patterns to
 come up with a better abstraction that does not rely on the magic number?

I cut this one down very sharply; Michael says:

 It would be much better for you to submit only a handful of changes (or
 even only one!) that is perfect, rather than throwing a bunch at the wall
 and asking the reviewer to pick between the good and the bad.

Thanks for the guidance, everyone.

This work is microproject #14 for GSoC.

Quint Guvernator (1):
  general style: replaces memcmp() with starts_with()

 builtin/apply.c|  6 +++---
 builtin/for-each-ref.c |  2 +-
 builtin/mktag.c|  4 ++--
 builtin/patch-id.c | 10 +-
 connect.c  |  4 ++--
 imap-send.c|  6 +++---
 remote.c   |  2 +-
 7 files changed, 17 insertions(+), 17 deletions(-)

-- 
1.9.0

--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v4 0/1] general style: replaces memcmp() with starts_with()

2014-03-17 Thread Quint Guvernator
My mistake, folks. This is [PATCH v4]. Apologies for the confusion.

Quint
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html