Re: What's cooking in git.git (Dec 2017, #05; Wed, 27)

2018-01-03 Thread Kaartic Sivaraam

On Wednesday 03 January 2018 02:56 PM, Daniel Knittl-Frank wrote:

On Wed, Dec 27, 2017 at 10:34 PM, Junio C Hamano  wrote:

* dk/describe-all-output-fix (2017-12-27) 1 commit
  - describe: prepend "tags/" when describing tags with embedded name

  An old regression in "git describe --all $annotated_tag^0" has been
  fixed.

  Will merge to 'next'.


Shouldn't this be merged to 'maint' since it is a bugfix (for a long
standing bug)? Or am I misinterpreting the meaning of the 'maint'
branch?



IIUC, the pipe line here is something like,

  [PATCH]

 |

 (after the patch gets some consensus
  when it's not trivial)

 |
 V

   Merge to 'pu'


 |

 (after waiting for some time to see if someone
  shouts about a build failing or complaining
   a regression about the PATCH in 'pu')

 |
 V

   Merge to 'next'

 |

 (after waiting for some time to see if someone
  shouts about a build failing or complaining
   a regression about the PATCH in 'next')

 |
/ \
   /   \
  / \
 /   \
| |

  (if it's a bugfix for  (if it's a new feature or
   an already releasedan enhancement)
   version of Git)

| |
V V
  Merge to 'maint'Merge to 'master'



Of course 'maint' and 'master' are not diverged completely. They are 
'synced' at times.


Disclaimer: I won't say I'm 100% correct with the pipeline. This is just 
what I've understood in observing the mailing list, the "What's cooking" 
emails and the history of 'git' in the short time that I've been here. 
So, there are possibilities that I've said something incorrectly. I 
guess the "Documentation/howto/maintain-git.txt" document covers it more 
comprehensively especially "The Policy" section describes the branches 
more clearly.


--
Kaartic

Quote: "Be creative. Be adventurous. Be original. And above all else, be 
young." - Wonder Woman


Re: What's cooking in git.git (Dec 2017, #05; Wed, 27)

2018-01-03 Thread Daniel Knittl-Frank
On Wed, Dec 27, 2017 at 10:34 PM, Junio C Hamano  wrote:
> * dk/describe-all-output-fix (2017-12-27) 1 commit
>  - describe: prepend "tags/" when describing tags with embedded name
>
>  An old regression in "git describe --all $annotated_tag^0" has been
>  fixed.
>
>  Will merge to 'next'.

Shouldn't this be merged to 'maint' since it is a bugfix (for a long
standing bug)? Or am I misinterpreting the meaning of the 'maint'
branch?

Daniel

--
typed with http://neo-layout.org


Re: What's cooking in git.git (Dec 2017, #05; Wed, 27)

2018-01-02 Thread Jonathan Nieder
Stefan Beller wrote:
> On Thu, Dec 28, 2017 at 11:02 AM, Junio C Hamano  wrote:
>> Elijah Newren  writes:

>>> surprised by the branch name, though.  Was 'ew/' a typo,
>>
>> Blush X-<.  Yes it is a typo.
>
> Note on that series:
> I have reviewed the first three patches (which could form an independent 
> series)
> that it would warrant a Reviewed-By: Stefan Beller 
>
> While I reviewed the earlier versions of the later patches, I would
> prefer if there is another reviewer for these as it seems like a bigger
> contribution at a core functionality.
>
> I cc'd some people who were active in some form of rename detection
> work earlier; could you review this series, please?

I'm missing context about which series you mean (though I think I can
guess).  Do you mind resending this request-for-review in a reply to
the patch thread?

That way, the request would be in context where my mail reader can
bring up the thread and it's easy for others to see that the request
happened, all in one place.

Thanks,
Jonathan


Re: What's cooking in git.git (Dec 2017, #05; Wed, 27)

2018-01-02 Thread Stefan Beller
On Thu, Dec 28, 2017 at 11:02 AM, Junio C Hamano  wrote:
> Elijah Newren  writes:
>
>> surprised by the branch name, though.  Was 'ew/' a typo,
>
> Blush X-<.  Yes it is a typo.

Note on that series:
I have reviewed the first three patches (which could form an independent series)
that it would warrant a Reviewed-By: Stefan Beller 

While I reviewed the earlier versions of the later patches, I would
prefer if there is another reviewer for these as it seems like a bigger
contribution at a core functionality.

I cc'd some people who were active in some form of rename detection
work earlier; could you review this series, please?

Thanks,
Stefan


Re: What's cooking in git.git (Dec 2017, #05; Wed, 27)

2017-12-28 Thread Junio C Hamano
Elijah Newren  writes:

> surprised by the branch name, though.  Was 'ew/' a typo,

Blush X-<.  Yes it is a typo.


Re: What's cooking in git.git (Dec 2017, #05; Wed, 27)

2017-12-27 Thread Elijah Newren
On Wed, Dec 27, 2017 at 1:34 PM, Junio C Hamano  wrote:

> * ew/empty-merge-with-dirty-index (2017-12-22) 1 commit
>  - Merge branch 'ew/empty-merge-with-dirty-index-maint' into 
> ew/empty-merge-with-dirty-index
>  (this branch uses ew/empty-merge-with-dirty-index-maint.)

> * ew/empty-merge-with-dirty-index-maint (2017-12-22) 3 commits
>  - merge-recursive: avoid incorporating uncommitted changes in a merge
>  - move index_has_changes() from builtin/am.c to merge.c for reuse
>  - t6044: recursive can silently incorporate dirty changes in a merge
>  (this branch is used by ew/empty-merge-with-dirty-index.)
>
>  "git merge -s recursive" did not correctly abort when the index is
>  dirty, if the merged tree happened to be the same as the current
>  HEAD, which has been fixed.

As promised, I looked through both to check for mis-merges or problems
in applying to maint.  The changes all look good to me.  I was
surprised by the branch name, though.  Was 'ew/' a typo, or does that
part of the branch name mean something other than what I always
assumed?


What's cooking in git.git (Dec 2017, #05; Wed, 27)

2017-12-27 Thread Junio C Hamano
Here are the topics that have been cooking.  Commits prefixed with
'-' are only in 'pu' (proposed updates) while commits prefixed with
'+' are in 'next'.  The ones marked with '.' do not appear in any of
the integration branches, but I am still holding onto them.

You can find the changes described here in the integration branches
of the repositories listed at

http://git-blame.blogspot.com/p/git-public-repositories.html

--
[Graduated to "master"]

* bw/submodule-sans-cache-compat (2017-12-12) 3 commits
  (merged to 'next' on 2017-12-14 at 6893bdeed3)
 + submodule: convert get_next_submodule to not rely on the_index
 + submodule: used correct index in is_staging_gitmodules_ok
 + submodule: convert stage_updated_gitmodules to take a struct index_state

 Code clean-up.


* db/doc-workflows-neuter-the-maintainer (2017-12-08) 1 commit
  (merged to 'next' on 2017-12-14 at 740788d890)
 + doc: reword gitworkflows.txt for neutrality

 Docfix.


* es/clone-shared-worktree (2017-12-11) 1 commit
  (merged to 'next' on 2017-12-14 at 248ef92bda)
 + clone: support 'clone --shared' from a worktree

 "git clone --shared" to borrow from a (secondary) worktree did not
 work, even though "git clone --local" did.  Both are now accepted.


* es/worktree-checkout-hook (2017-12-07) 1 commit
  (merged to 'next' on 2017-12-14 at 907d958351)
 + worktree: invoke post-checkout hook (unless --no-checkout)

 "git worktree add" learned to run the post-checkout hook, just like
 "git checkout" does, after the initial checkout.


* jh/object-filtering (2017-12-05) 9 commits
  (merged to 'next' on 2017-12-05 at 3a56b51085)
 + rev-list: support --no-filter argument
 + list-objects-filter-options: support --no-filter
 + list-objects-filter-options: fix 'keword' typo in comment
  (merged to 'next' on 2017-11-27 at e5008c3b28)
 + pack-objects: add list-objects filtering
 + rev-list: add list-objects filtering support
 + list-objects: filter objects in traverse_commit_list
 + oidset: add iterator methods to oidset
 + oidmap: add oidmap iterator methods
 + dir: allow exclusions from blob in addition to file
 (this branch is used by jh/fsck-promisors and jh/partial-clone.)

 In preparation for implementing narrow/partial clone, the object
 walking machinery has been taught a way to tell it to "filter" some
 objects from enumeration.


* jk/cvsimport-quoting (2017-12-08) 1 commit
  (merged to 'next' on 2017-12-14 at ea99dc966c)
 + cvsimport: apply shell-quoting regex globally

 Typo/Logico fix.


* jt/decorate-api (2017-12-08) 1 commit
  (merged to 'next' on 2017-12-14 at b14858df40)
 + decorate: clean up and document API

 A few structures and variables that are implementation details of
 the decorate API have been renamed and then the API got documented
 better.


* jt/transport-no-more-rsync (2017-12-12) 1 commit
  (merged to 'next' on 2017-12-14 at 456913ad25)
 + transport: remove unused "push" in vtable
 (this branch is used by jt/transport-hide-vtable.)

 Code clean-up.


* ks/branch-cleanup (2017-12-07) 4 commits
  (merged to 'next' on 2017-12-14 at af0a906984)
 + builtin/branch: strip refs/heads/ using skip_prefix
 + branch: update warning message shown when copying a misnamed branch
 + branch: group related arguments of create_branch()
 + branch: improve documentation and naming of create_branch() parameters

 Code clean-up.


* lb/rebase-i-short-command-names (2017-12-05) 9 commits
  (merged to 'next' on 2017-12-14 at 0637be0782)
 + t3404: add test case for abbreviated commands
 + rebase -i: learn to abbreviate command names
 + rebase -i -x: add exec commands via the rebase--helper
 + rebase -i: update functions to use a flags parameter
 + rebase -i: replace reference to sha1 with oid
 + rebase -i: refactor transform_todo_ids
 + rebase -i: set commit to null in exec commands
 + Documentation: use preferred name for the 'todo list' script
 + Documentation: move rebase.* configs to new file

 With a configuration variable rebase.abbreviateCommands set,
 "git rebase -i" produces the todo list with a single-letter
 command names.


* ot/pretty (2017-12-12) 2 commits
  (merged to 'next' on 2017-12-14 at d80fe80aed)
 + format: create docs for pretty.h
 + format: create pretty.h file

 Code clean-up.


* rb/quick-install-doc (2017-12-12) 1 commit
  (merged to 'next' on 2017-12-14 at 96c17a83fa)
 + install-doc-quick: allow specifying what ref to install

 The build procedure now allows not just the repositories but also
 the refs to be used to take pre-formatted manpages and html
 documents to install.


* rs/am-builtin-leakfix (2017-12-07) 1 commit
  (merged to 'next' on 2017-12-14 at 30bf70d2cb)
 + am: release strbuf after use in split_mail_mbox()

 Leakfix.


* rs/fmt-merge-msg-leakfix (2017-12-08) 1 commit
  (merged to 'next' on 2017-12-14 at b87794d837)
 + transport-helper: plug strbuf and string_list leaks

 Leakfix.


* rs/fmt-merge-msg-string-leak-fix (2017-12-07) 1 commit
  (merged to