Re: [Haskell-cafe] global variables

2007-05-23 Thread Adrian Hey

Isaac Dupree wrote:


var :: IORef Int
var = {-# EVALUATE_THIS_TEXT_ONLY_ONCE #-} (unsafePerformIO (newIORef 3))


I think I still prefer..

var :: IORef Int
var - newIORef 3

or, more likely..

var :: IORef Int
var - ACIO.newIORef 3

The - syntax should make the intended semantics clear and unambiguous,
so it becomes the problem of individual implementors (not standards
writers) to make sure that whatever optimisations or transformations
that may be appropriate for their implementation preserve those
semantics. (IOW there's no need to worry about what a pragma really
means in operational terms, AFAICS).

The ACIO monad also restricts what programmers may use on the rhs of
the -.

But if you want a good name for the pragma how about this..


var :: IORef Int
var = {-# - #-} (unsafePerformIO (newIORef 3))


:-)

Regards
--
Adrian Hey








___
Haskell-prime mailing list
Haskell-prime@haskell.org
http://www.haskell.org/mailman/listinfo/haskell-prime


Re: Suggestion for module system (to get rid of many uses of unsafePerformIO)

2007-05-23 Thread Adrian Hey

Stephen Dolan wrote:


Would this be useful, useless, or just downright silly?


The silence is deafening :-)

I think what you're describing seems to be so completely different
from Haskell as it is now that that people either don't understand
it, or they do understand it and do think it's downright silly, but
are just too polite to say that. Maybe you should try writing it up
in a more comprehensible form on a Haskell wiki page.

I would say that I get worried when people talk about module
initialisation and/or (potentially) side effecting imports. I'm
not sure if this is a problem with what you're proposing, but
I think it's important that we don't get into a situation where
the mere presence or absence of some definition in a module can
influence program behaviour, even if it isn't referenced by main
somehow.

Regards
--
Adrian Hey






___
Haskell-prime mailing list
Haskell-prime@haskell.org
http://www.haskell.org/mailman/listinfo/haskell-prime


Re: Suggestion for module system (to get rid of many uses of unsafePerformIO)

2007-05-23 Thread Stephen Dolan

I think what you're describing seems to be so completely different
from Haskell as it is now that that people either don't understand
it, or they do understand it and do think it's downright silly, but
are just too polite to say that. Maybe you should try writing it up
in a more comprehensible form on a Haskell wiki page.


Yeah, that certainly wasn't my most readable piece of writing.



I would say that I get worried when people talk about module
initialisation and/or (potentially) side effecting imports. I'm
not sure if this is a problem with what you're proposing, but
I think it's important that we don't get into a situation where
the mere presence or absence of some definition in a module can
influence program behaviour, even if it isn't referenced by main
somehow.


No, the point of what I was proposing was that, when a module requires
side-effecting initialisation, it would have to be imported inside a
do block like any other side-effecting piece of code. At the moment,
we have the situation of modules using unsafePerformIO newIORef, which
influences program behaviour without being referenced by main. If the
import statement was inside a do block, it would be clear when the
side-effects are taking place.

Regards,
Stephen Dolan
___
Haskell-prime mailing list
Haskell-prime@haskell.org
http://www.haskell.org/mailman/listinfo/haskell-prime