[jira] [Comment Edited] (HDDS-182) CleanUp Reimplemented classes

2018-07-05 Thread Bharat Viswanadham (JIRA)


[ 
https://issues.apache.org/jira/browse/HDDS-182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16534091#comment-16534091
 ] 

Bharat Viswanadham edited comment on HDDS-182 at 7/5/18 8:12 PM:
-

Hi [~hanishakoneru] 

Thanks for the patch. 

Just one minor comment, do we need below code in ContainerData.java, as those 
are primitive fields.

Preconditions.checkNotNull(containerId);
Preconditions.checkNotNull(layOutVersion);

 

 


was (Author: bharatviswa):
Hi [~hanishakoneru] 

Thanks for the patch.

Just one minor comment, do we need below code in ContainerData.java, as those 
are primitive fields.

Preconditions.checkNotNull(containerId);
Preconditions.checkNotNull(layOutVersion);

> CleanUp Reimplemented classes
> -
>
> Key: HDDS-182
> URL: https://issues.apache.org/jira/browse/HDDS-182
> Project: Hadoop Distributed Data Store
>  Issue Type: Sub-task
>Reporter: Hanisha Koneru
>Assignee: Hanisha Koneru
>Priority: Major
> Attachments: HDDS-182-HDDS-48.001.patch, HDDS-182-HDDS-48.002.patch
>
>
> Cleanup container-service's ozone.container.common package. The following 
> classes have been refactored and re-implemented. The unused classes/ methods 
> should be cleaned up.
>  # org.apache.hadoop.ozone.container.common.helpers.ChunkUtils
>  # org.apache.hadoop.ozone.container.common.helpers.KeyUtils
>  # org.apache.hadoop.ozone.container.common.helpers.ContainerData
>  # org.apache.hadoop.ozone.container.common.impl.Dispatcher
>  # org.apache.hadoop.ozone.container.common.impl.ChunkManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.KeyManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.ContainerManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.Dispatcher
> Also, fix integration tests broken by deleting these classes.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Comment Edited] (HDDS-182) CleanUp Reimplemented classes

2018-07-03 Thread Hanisha Koneru (JIRA)


[ 
https://issues.apache.org/jira/browse/HDDS-182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16530573#comment-16530573
 ] 

Hanisha Koneru edited comment on HDDS-182 at 7/3/18 5:33 PM:
-

* Fixed the following integration tests in this patch
 ## TestContainerPersistence
 ## TestContainerServer
 ## TestSCMCli - Ignoring this test for now. Will open a new Jira to fix this.
 * Changed containerId to containerID in ContainerData to be consistent with 
naming convention (for eg. clusterID, scmID).
 * Removed restriction of not updating the existing container metadata fields.
 * Fixed TestKeyValueHandler failing in Jenkins run.


was (Author: hanishakoneru):
* Fixed the following integration tests in this patch
*# TestContainerPersistence
*# TestContainerServer
*# TestSCMCli - Ignoring this test for now. Will open a new Jira to fix this.
* Changed containerId to containerID in ContainerData to be consistent with 
naming convention (for eg. clusterID, scmID).
* Removed restriction of not updating the existing container metadata fields.

> CleanUp Reimplemented classes
> -
>
> Key: HDDS-182
> URL: https://issues.apache.org/jira/browse/HDDS-182
> Project: Hadoop Distributed Data Store
>  Issue Type: Sub-task
>Reporter: Hanisha Koneru
>Assignee: Hanisha Koneru
>Priority: Major
> Attachments: HDDS-182-HDDS-48.001.patch
>
>
> Cleanup container-service's ozone.container.common package. The following 
> classes have been refactored and re-implemented. The unused classes/ methods 
> should be cleaned up.
>  # org.apache.hadoop.ozone.container.common.helpers.ChunkUtils
>  # org.apache.hadoop.ozone.container.common.helpers.KeyUtils
>  # org.apache.hadoop.ozone.container.common.helpers.ContainerData
>  # org.apache.hadoop.ozone.container.common.impl.Dispatcher
>  # org.apache.hadoop.ozone.container.common.impl.ChunkManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.KeyManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.ContainerManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.Dispatcher
> Also, fix integration tests broken by deleting these classes.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Comment Edited] (HDDS-182) CleanUp Reimplemented classes

2018-07-02 Thread Hanisha Koneru (JIRA)


[ 
https://issues.apache.org/jira/browse/HDDS-182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16530573#comment-16530573
 ] 

Hanisha Koneru edited comment on HDDS-182 at 7/2/18 11:37 PM:
--

* Fixed the following integration tests in this patch
*# TestContainerPersistence
*# TestContainerServer
*# TestSCMCli - Ignoring this test for now. Will open a new Jira to fix this.
* Changed containerId to containerID in ContainerData to be consistent with 
naming convention (for eg. clusterID, scmID).
* Removed restriction of not updating the existing container metadata fields.


was (Author: hanishakoneru):
Fixed the following integration tests in this patch
# TestContainerPersistence
# TestContainerServer
# TestSCMCli - Ignoring this test for now. Will open a new Jira to fix this.

> CleanUp Reimplemented classes
> -
>
> Key: HDDS-182
> URL: https://issues.apache.org/jira/browse/HDDS-182
> Project: Hadoop Distributed Data Store
>  Issue Type: Sub-task
>Reporter: Hanisha Koneru
>Assignee: Hanisha Koneru
>Priority: Major
> Attachments: HDDS-182-HDDS-48.000.patch
>
>
> Cleanup container-service's ozone.container.common package. The following 
> classes have been refactored and re-implemented. The unused classes/ methods 
> should be cleaned up.
>  # org.apache.hadoop.ozone.container.common.helpers.ChunkUtils
>  # org.apache.hadoop.ozone.container.common.helpers.KeyUtils
>  # org.apache.hadoop.ozone.container.common.helpers.ContainerData
>  # org.apache.hadoop.ozone.container.common.impl.Dispatcher
>  # org.apache.hadoop.ozone.container.common.impl.ChunkManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.KeyManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.ContainerManagerImpl
>  # org.apache.hadoop.ozone.container.common.impl.Dispatcher
> Also, fix integration tests broken by deleting these classes.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org