[jira] [Updated] (HDFS-12118) Ozone: Ozone shell: Add more testing for volume shell commands

2017-07-17 Thread Chen Liang (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-12118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Chen Liang updated HDFS-12118:
--
Resolution: Fixed
Status: Resolved  (was: Patch Available)

> Ozone: Ozone shell: Add more testing for volume shell commands
> --
>
> Key: HDFS-12118
> URL: https://issues.apache.org/jira/browse/HDFS-12118
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>  Components: ozone, tools
>Affects Versions: HDFS-7240
>Reporter: Yiqun Lin
>Assignee: Yiqun Lin
> Attachments: HDFS-12118-HDFS-7240.001.patch, 
> HDFS-12118-HDFS-7240.002.patch, HDFS-12118-HDFS-7240.003.patch, 
> HDFS-12118-HDFS-7240.004.patch
>
>
> Currently there are missing enough testings to cover all the ozone command. 
> Now we have to test this in a manual way to see if commands run okay as 
> expected. There will be lots of test cases we should add for all the volume, 
> bucket and key commands. In order to easy reviewed, I'd like to separate this 
> work to three subtasks. This JIRA is a good start for implementing for volume 
> commands.
> Plan to add the unit test to test following command and its available options:
> * infoVolume
> * updateVolume
> * listVolume
> * createVolume



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Updated] (HDFS-12118) Ozone: Ozone shell: Add more testing for volume shell commands

2017-07-17 Thread Yiqun Lin (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-12118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Yiqun Lin updated HDFS-12118:
-
Attachment: HDFS-12118-HDFS-7240.004.patch

Attach the new patch to add user checking.


> Ozone: Ozone shell: Add more testing for volume shell commands
> --
>
> Key: HDFS-12118
> URL: https://issues.apache.org/jira/browse/HDFS-12118
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>  Components: ozone, tools
>Affects Versions: HDFS-7240
>Reporter: Yiqun Lin
>Assignee: Yiqun Lin
> Attachments: HDFS-12118-HDFS-7240.001.patch, 
> HDFS-12118-HDFS-7240.002.patch, HDFS-12118-HDFS-7240.003.patch, 
> HDFS-12118-HDFS-7240.004.patch
>
>
> Currently there are missing enough testings to cover all the ozone command. 
> Now we have to test this in a manual way to see if commands run okay as 
> expected. There will be lots of test cases we should add for all the volume, 
> bucket and key commands. In order to easy reviewed, I'd like to separate this 
> work to three subtasks. This JIRA is a good start for implementing for volume 
> commands.
> Plan to add the unit test to test following command and its available options:
> * infoVolume
> * updateVolume
> * listVolume
> * createVolume



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Updated] (HDFS-12118) Ozone: Ozone shell: Add more testing for volume shell commands

2017-07-13 Thread Yiqun Lin (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-12118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Yiqun Lin updated HDFS-12118:
-
Attachment: HDFS-12118-HDFS-7240.003.patch

Thanks [~vagarychen] for the review. Your comment makes sense to me. 
Attach the updated patch. I just check the content of the list in a directly 
way and have added additional content check in other places. During testing 
listVolume, I found one another bug that return volume list is not in a correct 
order. In my unit test, I create 10 volumes from test-vol0, test-vol2, .. 
test-vol18 for user1. And then I call the list with -length=2, it should be 
return volumes [test-vol0, test-vol10], but current logic it will return 
[test-vol0, test-vol2]. I haven't looked into this, but the bucket and key 
commands can return expected order value. [~cheersyang], can you help  take a 
look on this as I see you implemented listVolume in KSM?
Because of this, I just check the return list size and not check the return 
volume name when testing -length option.

> Ozone: Ozone shell: Add more testing for volume shell commands
> --
>
> Key: HDFS-12118
> URL: https://issues.apache.org/jira/browse/HDFS-12118
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>  Components: ozone, tools
>Affects Versions: HDFS-7240
>Reporter: Yiqun Lin
>Assignee: Yiqun Lin
> Attachments: HDFS-12118-HDFS-7240.001.patch, 
> HDFS-12118-HDFS-7240.002.patch, HDFS-12118-HDFS-7240.003.patch
>
>
> Currently there are missing enough testings to cover all the ozone command. 
> Now we have to test this in a manual way to see if commands run okay as 
> expected. There will be lots of test cases we should add for all the volume, 
> bucket and key commands. In order to easy reviewed, I'd like to separate this 
> work to three subtasks. This JIRA is a good start for implementing for volume 
> commands.
> Plan to add the unit test to test following command and its available options:
> * infoVolume
> * updateVolume
> * listVolume
> * createVolume



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Updated] (HDFS-12118) Ozone: Ozone shell: Add more testing for volume shell commands

2017-07-12 Thread Yiqun Lin (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-12118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Yiqun Lin updated HDFS-12118:
-
Attachment: HDFS-12118-HDFS-7240.002.patch

Thanks [~vagarychen] for the review!
All the comments make sense to me. Attach the updated patch.
Please take the review.


> Ozone: Ozone shell: Add more testing for volume shell commands
> --
>
> Key: HDFS-12118
> URL: https://issues.apache.org/jira/browse/HDFS-12118
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>  Components: ozone, tools
>Affects Versions: HDFS-7240
>Reporter: Yiqun Lin
>Assignee: Yiqun Lin
> Attachments: HDFS-12118-HDFS-7240.001.patch, 
> HDFS-12118-HDFS-7240.002.patch
>
>
> Currently there are missing enough testings to cover all the ozone command. 
> Now we have to test this in a manual way to see if commands run okay as 
> expected. There will be lots of test cases we should add for all the volume, 
> bucket and key commands. In order to easy reviewed, I'd like to separate this 
> work to three subtasks. This JIRA is a good start for implementing for volume 
> commands.
> Plan to add the unit test to test following command and its available options:
> * infoVolume
> * updateVolume
> * listVolume
> * createVolume



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Updated] (HDFS-12118) Ozone: Ozone shell: Add more testing for volume shell commands

2017-07-11 Thread Yiqun Lin (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-12118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Yiqun Lin updated HDFS-12118:
-
Description: 
Currently there are missing enough testings to cover all the ozone command. Now 
we have to test this in a manual way to see if commands run okay as expected. 
There will be lots of test cases we should add for all the volume, bucket and 
key commands. In order to easy reviewed, I'd like to separate this work to 
three subtasks. This JIRA is a good start for implementing for volume commands.
Plan to add the unit test to test following command and its available options:

* infoVolume
* updateVolume
* listVolume
* createVolume


  was:
Currently there are missing enough testing to cover all the ozone command. Now 
we have to test this in a manual way to see if commands run okay as expected. 
There will be lots of test cases we should add for all the volume, bucket and 
key commands. In order to easy reviewed, I'd like to separate this work to 
three subtasks. This JIRA is a good start for implementing for volume commands.
Plan to add the unit test to test following command and its available options:

* infoVolume
* updateVolume
* listVolume
* createVolume



> Ozone: Ozone shell: Add more testing for volume shell commands
> --
>
> Key: HDFS-12118
> URL: https://issues.apache.org/jira/browse/HDFS-12118
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>  Components: ozone, tools
>Affects Versions: HDFS-7240
>Reporter: Yiqun Lin
>Assignee: Yiqun Lin
> Attachments: HDFS-12118-HDFS-7240.001.patch
>
>
> Currently there are missing enough testings to cover all the ozone command. 
> Now we have to test this in a manual way to see if commands run okay as 
> expected. There will be lots of test cases we should add for all the volume, 
> bucket and key commands. In order to easy reviewed, I'd like to separate this 
> work to three subtasks. This JIRA is a good start for implementing for volume 
> commands.
> Plan to add the unit test to test following command and its available options:
> * infoVolume
> * updateVolume
> * listVolume
> * createVolume



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Updated] (HDFS-12118) Ozone: Ozone shell: Add more testing for volume shell commands

2017-07-11 Thread Yiqun Lin (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-12118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Yiqun Lin updated HDFS-12118:
-
Status: Patch Available  (was: Open)

> Ozone: Ozone shell: Add more testing for volume shell commands
> --
>
> Key: HDFS-12118
> URL: https://issues.apache.org/jira/browse/HDFS-12118
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>  Components: ozone, tools
>Affects Versions: HDFS-7240
>Reporter: Yiqun Lin
>Assignee: Yiqun Lin
> Attachments: HDFS-12118-HDFS-7240.001.patch
>
>
> Currently there are missing enough testing to cover all the ozone command. 
> Now we have to test this in a manual way to see if commands run okay as 
> expected. There will be lots of test cases we should add for all the volume, 
> bucket and key commands. In order to easy reviewed, I'd like to separate this 
> work to three subtasks. This JIRA is a good start for implementing for volume 
> commands.
> Plan to add the unit test to test following command and its available options:
> * infoVolume
> * updateVolume
> * listVolume
> * createVolume



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Updated] (HDFS-12118) Ozone: Ozone shell: Add more testing for volume shell commands

2017-07-11 Thread Yiqun Lin (JIRA)

 [ 
https://issues.apache.org/jira/browse/HDFS-12118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Yiqun Lin updated HDFS-12118:
-
Attachment: HDFS-12118-HDFS-7240.001.patch

> Ozone: Ozone shell: Add more testing for volume shell commands
> --
>
> Key: HDFS-12118
> URL: https://issues.apache.org/jira/browse/HDFS-12118
> Project: Hadoop HDFS
>  Issue Type: Sub-task
>  Components: ozone, tools
>Affects Versions: HDFS-7240
>Reporter: Yiqun Lin
>Assignee: Yiqun Lin
> Attachments: HDFS-12118-HDFS-7240.001.patch
>
>
> Currently there are missing enough testing to cover all the ozone command. 
> Now we have to test this in a manual way to see if commands run okay as 
> expected. There will be lots of test cases we should add for all the volume, 
> bucket and key commands. In order to easy reviewed, I'd like to separate this 
> work to three subtasks. This JIRA is a good start for implementing for volume 
> commands.
> Plan to add the unit test to test following command and its available options:
> * infoVolume
> * updateVolume
> * listVolume
> * createVolume



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org