[hwloc-devel] === CREATE FAILURE (trunk) ===

2010-03-27 Thread MPI Team

ERROR: Command returned a non-zero exist status (trunk):
   make distcheck

Start time: Sat Mar 27 21:01:04 EDT 2010
End time:   Sat Mar 27 21:01:48 EDT 2010

===
[... previous lines snipped ...]
Generating docs for file openfabrics-verbs.h...
Generating class documentation...
Generating annotated compound index...
Generating hierarchical class index...
Generating member index...
Generating docs for compound hwloc_obj...
Generating docs for compound hwloc_obj_attr_u...
Generating docs for nested compound hwloc_obj_attr_u::hwloc_cache_attr_s...
Generating docs for nested compound hwloc_obj_attr_u::hwloc_machine_attr_s...
Generating docs for nested compound hwloc_obj_attr_u::hwloc_misc_attr_s...
Generating docs for compound hwloc_obj_memory_s...
Generating docs for nested compound 
hwloc_obj_memory_s::hwloc_obj_memory_page_type_s...
Generating docs for compound hwloc_topology_support...
Generating page documentation...
Generating group documentation...
Generating namespace index...
Generating group index...
Generating example index...
Generating file member index...
Generating namespace member index...
Generating page index...
Generating graph info page...
sed -i \
-e 's/__hwloc_restrict/restrict/g' \
-e 's/\\_\\-\\_\\-hwloc\\_\\-restrict/restrict/g' \
-e 's/__hwloc_attribute_unused//g' \
-e 's/\\_\\-\\_\\-hwloc\\_\\-attribute\\_\\-unused//g' \
-e 's/__hwloc_attribute_malloc//g' \
-e 's/\\_\\-\\_\\-hwloc\\_\\-attribute\\_\\-malloc//g' \
-e 's/__hwloc_attribute_const//g' \
-e 's/\\_\\-\\_\\-hwloc\\_\\-attribute\\_\\-const//g' \
-e 's/__hwloc_attribute_pure//g' \
-e 's/\\_\\-\\_\\-hwloc\\_\\-attribute\\_\\-pure//g' \
-e 's/__hwloc_attribute_deprecated//g' \
-e 's/\\_\\-\\_\\-hwloc\\_\\-attribute\\_\\-deprecated//g' \
-e 's/HWLOC_DECLSPEC//g' \
-e 's/HWLOC\\_\\-DECLSPEC//g' \
-e 's/__inline/inline/g' \
-e 's/\\_\\-\\_\\-inline/inline/g' \
doxygen-doc/html/*.html doxygen-doc/latex/*.tex doxygen-doc/man/man3/*.3
Work-around spurious leading _ in doxygen filenames...
(cd doxygen-doc/man/man3 ; \
for i in _hwloc* ; do \
mv $i ${i#_} ; \
done)
mv: when moving multiple files, last argument must be a directory
Try `mv --help' for more information.
make[1]: *** [doxygen-doc/hwloc.tag] Error 1
make[1]: Leaving directory 
`/home/mpiteam/hwloc/nightly-tarball-build-root/trunk/create-r1860/hwloc/doc'
make: *** [distdir] Error 1
===

Your friendly daemon,
Cyrador


Re: [hwloc-devel] [hwloc-svn] svn:hwloc r1865

2010-03-27 Thread Bert Wesarg
Hi,

thanks for sharing this early.

On Sat, Mar 27, 2010 at 08:53,   wrote:
> Modified: branches/dyncpusets/src/cpuset.c
> ==
> --- branches/dyncpusets/src/cpuset.c    (original)
> +++ branches/dyncpusets/src/cpuset.c    2010-03-27 03:53:47 EDT (Sat, 27 Mar 
> 2010)
> @@ -50,10 +63,18 @@
>  struct hwloc_cpuset_s * hwloc_cpuset_alloc(void)
>  {
>   struct hwloc_cpuset_s * set;
> -  set = calloc(sizeof(*set), 1);
> +  set = malloc(sizeof(struct hwloc_cpuset_s));
>   if (!set)
>     return NULL;
>
> +  set->ulongs_count = 1;
> +  set->ulongs = calloc(sizeof(unsigned long), set->ulongs_count);
> +  if (!set->ulongs) {
> +    free(set->ulongs);

That should be free(set).

> +    return NULL;
> +  }
> +
> +  set->infinite = 0;
>  #ifdef HWLOC_DEBUG
>   set->magic = HWLOC_CPUSET_MAGIC;
>  #endif
> @@ -70,29 +91,78 @@
>   set->magic = 0;
>  #endif
>
> +  free(set->ulongs);
>   free(set);
>  }
>
> +/* realloc until it contains at least needed_count ulongs */
> +static void
> +hwloc_cpuset_realloc_by_ulongs(struct hwloc_cpuset_s * set, unsigned 
> needed_count)
> +{
> +  unsigned ulongs_count = set->ulongs_count;
> +  unsigned i;
> +
> +  HWLOC__CPUSET_CHECK(set);
> +
> +  if (needed_count <= ulongs_count)
> +    return;
> +
> +  while (ulongs_count < needed_count)
> +    ulongs_count *= 2;

You may have notices, that I don't like exponential realloc schemes.
On the other hand, I know that you plan to use a sparse implementation
in the future, so this is probably only an intermediate step. Anyway,
in this case, because one ulong should suffice for the common case, a
linear scheme with an increment of 1 would be crazy, I would use an
exponential scheme until some limit and from that on a linear scheme
(with that limit as the increment). The cache line size would be such
limit and a good one I think.

Regards,
Bert



Re: [hwloc-devel] Strange difference

2010-03-27 Thread Bert Wesarg
On Sat, Mar 27, 2010 at 01:50, Jeff Squyres  wrote:
> On Mar 26, 2010, at 5:35 PM, Brice Goglin wrote:
>
>> > Fair enough.  How about still just keeping "P" in the graphic output, 
>> > then?  But "processor" in the prettyprint?
>>
>> IIRC, somebody said "PU" (for "processing unit") could be a good
>> solution. Otherwise, I am ok with "Proc" or "Processor", with a small
>> preference for the former.
>
> I think I still am uncomfortable with "proc" because it's too much like 
> "process".  But that could be just me.
>
> PU might be suitable.
>
>> By the way, this is also what hwloc_type_string() would return. Unless
>> we keep it unchanged and just hack lstopo to use its own stringified
>> type name ?
>
> I wouldn't mind the hack (too much), but it does seem a little inelegant.  If 
> we hate everything else, let's settle on "PU".

"PU" may also be a little future safe, when GPU cores become common.

Bert

>
> --
> Jeff Squyres
> jsquy...@cisco.com
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> ___
> hwloc-devel mailing list
> hwloc-de...@open-mpi.org
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-devel
>