Re: [Intel-gfx] [PATCH 4/5] drm/dsi: rename MIPI_DCS_SET_PARTIAL_AREA to MIPI_DCS_SET_PARTIAL_ROWS

2019-10-23 Thread Jani Nikula
On Tue, 22 Oct 2019, David Lechner  wrote:
> On 10/22/19 5:09 AM, Jani Nikula wrote:
>> The DCS command has been named SET_PARTIAL_ROWS in the DCS spec since
>> v1.02, for more than a decade. Rename the enumeration to match the spec.
>> 
>> Cc: David Lechner 
>> Cc: Vandita Kulkarni 
>> Signed-off-by: Jani Nikula 
>> ---
>
> I guess all of my documents are old and say set_partial_area, but I will
> take your word for it.
>
> It could be helpful to leave a comment in the code about the renaming
> so that if people with old docs search for SET_PARTIAL_AREA, they can
> still find it.

Something like this?

MIPI_DCS_SET_PARTIAL_ROWS   = 0x30, /* aka 
MIPI_DCS_SET_PARTIAL_AREA */

It's also a possibility to define both:

MIPI_DCS_SET_PARTIAL_AREA   = 0x30, /* _ROWS since MIPI DCS 
1.02 */
MIPI_DCS_SET_PARTIAL_ROWS   = 0x30,

I don't mind either way.

BR,
Jani.


-- 
Jani Nikula, Intel Open Source Graphics Center
___
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Re: [Intel-gfx] [PATCH 4/5] drm/dsi: rename MIPI_DCS_SET_PARTIAL_AREA to MIPI_DCS_SET_PARTIAL_ROWS

2019-10-22 Thread David Lechner

On 10/22/19 5:09 AM, Jani Nikula wrote:

The DCS command has been named SET_PARTIAL_ROWS in the DCS spec since
v1.02, for more than a decade. Rename the enumeration to match the spec.

Cc: David Lechner 
Cc: Vandita Kulkarni 
Signed-off-by: Jani Nikula 
---


I guess all of my documents are old and say set_partial_area, but I will
take your word for it.

It could be helpful to leave a comment in the code about the renaming
so that if people with old docs search for SET_PARTIAL_AREA, they can
still find it.
___
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

[Intel-gfx] [PATCH 4/5] drm/dsi: rename MIPI_DCS_SET_PARTIAL_AREA to MIPI_DCS_SET_PARTIAL_ROWS

2019-10-22 Thread Jani Nikula
The DCS command has been named SET_PARTIAL_ROWS in the DCS spec since
v1.02, for more than a decade. Rename the enumeration to match the spec.

Cc: David Lechner 
Cc: Vandita Kulkarni 
Signed-off-by: Jani Nikula 
---
 drivers/gpu/drm/tiny/st7586.c | 2 +-
 include/video/mipi_display.h  | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/tiny/st7586.c b/drivers/gpu/drm/tiny/st7586.c
index 3cc21a1b30c8..060cc756194f 100644
--- a/drivers/gpu/drm/tiny/st7586.c
+++ b/drivers/gpu/drm/tiny/st7586.c
@@ -240,7 +240,7 @@ static void st7586_pipe_enable(struct 
drm_simple_display_pipe *pipe,
 
mipi_dbi_command(dbi, ST7586_SET_DISP_DUTY, 0x7f);
mipi_dbi_command(dbi, ST7586_SET_PART_DISP, 0xa0);
-   mipi_dbi_command(dbi, MIPI_DCS_SET_PARTIAL_AREA, 0x00, 0x00, 0x00, 
0x77);
+   mipi_dbi_command(dbi, MIPI_DCS_SET_PARTIAL_ROWS, 0x00, 0x00, 0x00, 
0x77);
mipi_dbi_command(dbi, MIPI_DCS_EXIT_INVERT_MODE);
 
msleep(100);
diff --git a/include/video/mipi_display.h b/include/video/mipi_display.h
index 928f8c4b6658..e3dc94fe1098 100644
--- a/include/video/mipi_display.h
+++ b/include/video/mipi_display.h
@@ -108,7 +108,7 @@ enum {
MIPI_DCS_WRITE_MEMORY_START = 0x2C,
MIPI_DCS_WRITE_LUT  = 0x2D,
MIPI_DCS_READ_MEMORY_START  = 0x2E,
-   MIPI_DCS_SET_PARTIAL_AREA   = 0x30,
+   MIPI_DCS_SET_PARTIAL_ROWS   = 0x30,
MIPI_DCS_SET_PARTIAL_COLUMNS= 0x31,
MIPI_DCS_SET_SCROLL_AREA= 0x33,
MIPI_DCS_SET_TEAR_OFF   = 0x34,
-- 
2.20.1

___
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx