Re: [Interest] Customizing the output library name in Android builds

2020-11-27 Thread Assam Boudjelthia
Hi,

What's the benefit of removing the suffix in a multi-abi build?

Best regards,
Assam

From: Interest  on behalf of Raphael Cotty 

Sent: Thursday, November 26, 2020 6:23 PM
To: interest@qt-project.org 
Subject: Re: [Interest] Customizing the output library name in Android builds

Hi,
I just gave a try with Qbs and it's possible to keep the old (Qt < 5.14) naming 
(without the arch suffix).
I just tried with the addressbook example and it works.
Qbs just needs to trick androiddeployqt a bit.
If that's a feature users can be interested in then it's possible to add it as 
an option.
Raph
___
Interest mailing list
Interest@qt-project.org
https://lists.qt-project.org/listinfo/interest


Re: [Interest] Customizing the output library name in Android builds

2020-11-26 Thread Raphael Cotty
Hi,
I just gave a try with Qbs and it's possible to keep the old (Qt < 5.14)
naming (without the arch suffix).
I just tried with the addressbook example and it works.
Qbs just needs to trick androiddeployqt a bit.
If that's a feature users can be interested in then it's possible to add it
as an option.
Raph
___
Interest mailing list
Interest@qt-project.org
https://lists.qt-project.org/listinfo/interest


[Interest] Customizing the output library name in Android builds

2020-11-23 Thread Rob Allan
We're in the process of migrating our Android builds from Qt 5.13.0 to
5.15.1. Something that has changed between these two versions is the
default naming scheme for target libraries built using qmake. In our .pro
file, we specify (for example):

TARGET = MyLibrary

In Qt 5.13.0, this produced an output library named 'libMyLibrary.so'. But
in 5.15.1, it produces  libMyLibrary_armeabi-v7a.so'. So the filename
includes the architecture type as a suffix.

I'm aware that this is an intentional new practice with Qt Android
libraries - that binaries for all architectures are built into the same
target directory, with the architecture type distinguished by a suffix
within the filename. However, for reasons that I don't really want to go
into here, this naming scheme is inconsistent with a bunch of other
libraries that we build in a different way, and I would like to make it
_not_ include the architecture suffix - I want it to output
'libMyLibrary.so' as it used to in 5.13.0.

I've rummaged through all the qmake variables but haven't found one that
allows me to control this behaviour, or that lets me set the actual
filename that is used for the output library.

Can anyone advise how to do this?

Thanks,
Rob Allan
___
Interest mailing list
Interest@qt-project.org
https://lists.qt-project.org/listinfo/interest