[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2012-02-23 Thread dhruba borthakur (Commented) (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13214435#comment-13214435
 ] 

dhruba borthakur commented on HBASE-4296:
-

The ThriftServer uses HTable.getRowOrBefore() to find a entry in the .META. 
table. This used to work with hbase-92 but returns null for hbase-94. did 
something change here?

 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Assignee: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0

 Attachments: 4296.txt


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2011-09-23 Thread stack (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13113676#comment-13113676
 ] 

stack commented on HBASE-4296:
--

We can hold off till 2600 is done.

I don't think we can call it scanMeta or do you mean scanMetaGetRowOrBefore?  
The latter we could do.

I'd think that when 2600 goes in, this method just won't make sense any more -- 
clients that find regions using this will just be broke... since the .META. 
format will have changed (endkeys rather than startkeys).  Ain't sure what to 
do about that.  It'll be at a major version transition.

 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Assignee: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0

 Attachments: 4296.txt


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2011-09-22 Thread Jonathan Gray (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13112935#comment-13112935
 ] 

Jonathan Gray commented on HBASE-4296:
--

Over in HBASE-4461 I am exposing this method to Thrift to enable building fat 
Thrift-based clients.  Rather than deprecating this, could we just notate that 
it is an expensive operation and not for normal operations?  Or even only allow 
it to work on ROOT and META?

 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Assignee: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0

 Attachments: 4296.txt


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2011-09-22 Thread stack (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13113034#comment-13113034
 ] 

stack commented on HBASE-4296:
--

@Jon We want to replace it with something more performant.  We don't have the 
alternative at the moment.  The deprecate was to frighten folks away and have 
it so this was then an internal method only.  Then in 0.94 we could swap in the 
alternative.  Can you shim this in your thrift?  I suppose you can't if you 
want to do the logic for regionserving over in your client that is on the other 
side of thrift.  And if you are building clients that come to depend on this, 
they'll have to be moved to the new method when the new method shows up.

This issue is for 0.92.  Will your fat thrift client ship against 0.92 or 0.94? 
 If 0.92, its there.  If 0.94, perhaps hbase-2600 needs to happen sooner rather 
than later? (Lars?)

 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Assignee: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0

 Attachments: 4296.txt


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2011-09-22 Thread Jonathan Gray (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13113037#comment-13113037
 ] 

Jonathan Gray commented on HBASE-4296:
--

We are already using the fat thrift client on our 0.90 branch.  I'm in the 
process of pushing this all out into open source so we can then pull it back in 
to our 0.92 based branch.  I'm happy to put this stuff into 0.92 in Apache as 
well but it's somewhat featurish :)

Was the method removed in 0.94 already?  Can we just hold off on removing it 
into 2600 happens and that way it won't matter and we can commit it anywhere.  
Following 2600 we can modify how it works and just use a normal scanner then?

 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Assignee: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0

 Attachments: 4296.txt


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2011-09-22 Thread Lars Hofhansl (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13113083#comment-13113083
 ] 

Lars Hofhansl commented on HBASE-4296:
--

I wonder if we should just rename it to scanMeta or something and force it to 
work on .Meta. only.
Then nobody would use it, unless it's used for Meta scanning, and we can then 
change the implementation. 




 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Assignee: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0

 Attachments: 4296.txt


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2011-09-07 Thread Hudson (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13100028#comment-13100028
 ] 

Hudson commented on HBASE-4296:
---

Integrated in HBase-TRUNK #2186 (See 
[https://builds.apache.org/job/HBase-TRUNK/2186/])
HBASE-4296 Deprecate HTable[Interface].getRowOrBefore(...)

stack : 
Files : 
* /hbase/trunk/CHANGES.txt
* /hbase/trunk/src/main/java/org/apache/hadoop/hbase/client/HTableInterface.java


 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Assignee: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0

 Attachments: 4296.txt


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)

2011-08-29 Thread stack (JIRA)

[ 
https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13093445#comment-13093445
 ] 

stack commented on HBASE-4296:
--

+1 Go for it.

 Deprecate HTable[Interface].getRowOrBefore(...)
 ---

 Key: HBASE-4296
 URL: https://issues.apache.org/jira/browse/HBASE-4296
 Project: HBase
  Issue Type: Bug
  Components: client
Affects Versions: 0.92.0
Reporter: Lars Hofhansl
Priority: Trivial
 Fix For: 0.92.0


 HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. 
 That method was created to allow our scanning of .META. (see HBASE-2600).
 Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be 
 performant that a user of HTable will not be aware of.
 I propose deprecating this in the public interface in 0.92 and removing it 
 from the public interface in 0.94. If we don't get to HBASE-2600 in 0.94 it 
 will still remain as internal interface for scanning meta.
 Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira