[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-23 Thread Amit Patel (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Amit Patel updated HBASE-18509:
---
Attachment: HBASE-18509.HBASE-14070.HLC.005.patch

> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch, 
> HBASE-18509.HBASE-14070.HLC.002.patch, HBASE-18509.HBASE-14070.HLC.003.patch, 
> HBASE-18509.HBASE-14070.HLC.004.patch, HBASE-18509.HBASE-14070.HLC.005.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - (done in 004.patch) --Maybe encapsulate all clocks in RS/Master into a new 
> class. Then RSServices can just have getClocks() function.--
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-22 Thread Appy (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Appy updated HBASE-18509:
-
Description: 
Track all types of cleanups here:
- (done in 001.patch) --Rename classes to more consistent naming: SystemClock, 
SystemMonotonicClock, HybridLogicalClock--
- (done in 001.patch) --Move implementations out from Clock interface. It's a 
simple interface of 6 fns but very overloaded right now with everything put 
inside it.--
- (done in 004.patch) --Maybe encapsulate all clocks in RS/Master into a new 
class. Then RSServices can just have getClocks() function.--
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\)
  - int64 now(ClockType)
  - List\ nowAll()
  }
{noformat}


  was:
Track all types of cleanups here:
- (done in 001.patch) --Rename classes to more consistent naming: SystemClock, 
SystemMonotonicClock, HybridLogicalClock--
- (done in 001.patch) --Move implementations out from Clock interface. It's a 
simple interface of 6 fns but very overloaded right now with everything put 
inside it.--
- Move to separate module/package/both
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\)
  - int64 now(ClockType)
  - List\ nowAll()
  }
{noformat}



> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch, 
> HBASE-18509.HBASE-14070.HLC.002.patch, HBASE-18509.HBASE-14070.HLC.003.patch, 
> HBASE-18509.HBASE-14070.HLC.004.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - (done in 004.patch) --Maybe encapsulate all clocks in RS/Master into a new 
> class. Then RSServices can just have getClocks() function.--
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-22 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-18509:
--
  Resolution: Fixed
Hadoop Flags: Reviewed
  Status: Resolved  (was: Patch Available)

Pushed .004 to HBASE-14070.HLC branch. Thanks [~amit.patel]

> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch, 
> HBASE-18509.HBASE-14070.HLC.002.patch, HBASE-18509.HBASE-14070.HLC.003.patch, 
> HBASE-18509.HBASE-14070.HLC.004.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - Move to separate module/package/both
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-22 Thread Amit Patel (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Amit Patel updated HBASE-18509:
---
Status: Patch Available  (was: In Progress)

> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch, 
> HBASE-18509.HBASE-14070.HLC.002.patch, HBASE-18509.HBASE-14070.HLC.003.patch, 
> HBASE-18509.HBASE-14070.HLC.004.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - Move to separate module/package/both
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-22 Thread Amit Patel (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Amit Patel updated HBASE-18509:
---
Attachment: HBASE-18509.HBASE-14070.HLC.004.patch

> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch, 
> HBASE-18509.HBASE-14070.HLC.002.patch, HBASE-18509.HBASE-14070.HLC.003.patch, 
> HBASE-18509.HBASE-14070.HLC.004.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - Move to separate module/package/both
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-22 Thread Amit Patel (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Amit Patel updated HBASE-18509:
---
Attachment: HBASE-18509.HBASE-14070.HLC.003.patch

> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch, 
> HBASE-18509.HBASE-14070.HLC.002.patch, HBASE-18509.HBASE-14070.HLC.003.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - Move to separate module/package/both
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-22 Thread Amit Patel (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Amit Patel updated HBASE-18509:
---
Attachment: HBASE-18509.HBASE-14070.HLC.002.patch

> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch, 
> HBASE-18509.HBASE-14070.HLC.002.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - Move to separate module/package/both
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-15 Thread Appy (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Appy updated HBASE-18509:
-
Description: 
Track all types of cleanups here:
- (done in 001.patch) --Rename classes to more consistent naming: SystemClock, 
SystemMonotonicClock, HybridLogicalClock--
- (done in 001.patch) --Move implementations out from Clock interface. It's a 
simple interface of 6 fns but very overloaded right now with everything put 
inside it.--
- Move to separate module/package/both
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\)
  - int64 now(ClockType)
  - List\ nowAll()
  }
{noformat}


  was:
Track all types of cleanups here:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, 
HybridLogicalClock
- Move implementations out from Clock interface. It's a simple interface of 6 
fns but very overloaded right now with everything put inside it.
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\)
  - int64 now(ClockType)
  - List\ nowAll()
  }
{noformat}



> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch
>
>
> Track all types of cleanups here:
> - (done in 001.patch) --Rename classes to more consistent naming: 
> SystemClock, SystemMonotonicClock, HybridLogicalClock--
> - (done in 001.patch) --Move implementations out from Clock interface. It's a 
> simple interface of 6 fns but very overloaded right now with everything put 
> inside it.--
> - Move to separate module/package/both
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-15 Thread Appy (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Appy updated HBASE-18509:
-
Description: 
Track all types of cleanups here:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, 
HybridLogicalClock
- Move implementations out from Clock interface. It's a simple interface of 6 
fns but very overloaded right now with everything put inside it.
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\)
  - int64 now(ClockType)
  - List\ nowAll()
  }
{noformat}


  was:
Track all types of cleanups here:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, 
HLClock
- Move implementations out from Clock interface. It's a simple interface of 6 
fns but very overloaded right now with everything put inside it.
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\)
  - int64 now(ClockType)
  - List\ nowAll()
  }
{noformat}



> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch
>
>
> Track all types of cleanups here:
> - Rename classes to more consistent naming: SystemClock, 
> SystemMonotonicClock, HybridLogicalClock
> - Move implementations out from Clock interface. It's a simple interface of 6 
> fns but very overloaded right now with everything put inside it.
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-15 Thread Amit Patel (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Amit Patel updated HBASE-18509:
---
Attachment: HBASE-18509.HBASE-14070.HLC.001.patch

> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>Assignee: Amit Patel
> Attachments: HBASE-18509.HBASE-14070.HLC.001.patch
>
>
> Track all types of cleanups here:
> - Rename classes to more consistent naming: SystemClock, 
> SystemMonotonicClock, HLClock
> - Move implementations out from Clock interface. It's a simple interface of 6 
> fns but very overloaded right now with everything put inside it.
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-18509) [HLC] Finishing cleanups

2017-08-08 Thread Appy (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Appy updated HBASE-18509:
-
Description: 
Track all types of cleanups here:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, 
HLClock
- Move implementations out from Clock interface. It's a simple interface of 6 
fns but very overloaded right now with everything put inside it.
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\)
  - int64 now(ClockType)
  - List\ nowAll()
  }
{noformat}


  was:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, 
HLClock
- Move implementations out from Clock interface. It's a simple interface of 6 
fns but very overloaded right now with everything put inside it.


> [HLC] Finishing cleanups
> 
>
> Key: HBASE-18509
> URL: https://issues.apache.org/jira/browse/HBASE-18509
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Appy
>
> Track all types of cleanups here:
> - Rename classes to more consistent naming: SystemClock, 
> SystemMonotonicClock, HLClock
> - Move implementations out from Clock interface. It's a simple interface of 6 
> fns but very overloaded right now with everything put inside it.
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\)
>   - int64 now(ClockType)
>   - List\ nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)