[jira] Created: (JDO-678) Ability to set properties on PersistenceManager

2011-03-04 Thread Andy Jefferson (JIRA)
Ability to set properties on PersistenceManager
---

 Key: JDO-678
 URL: https://issues.apache.org/jira/browse/JDO-678
 Project: JDO
  Issue Type: Improvement
  Components: api, specification, tck
Reporter: Andy Jefferson


It would be desirable to be able to set properties on the PersistenceManager, 
so as to be able to configure/change behaviour for a PM. Currently the PM is 
generated with particular configuration (from the PMF) and allows specific 
options to be set. But what about vendor extensions ? Having a general 
setProperty/getProperty/getSupportedProperties would be useful, and could also 
encompass the existing detachAllOnCommit, IgnoreCache, etc settings.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] Commented: (JDO-677) Ability to mark a class as read-only

2011-03-04 Thread Craig L Russell (JIRA)

[ 
https://issues.apache.org/jira/browse/JDO-677?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13002743#comment-13002743
 ] 

Craig L Russell commented on JDO-677:
-

So where would an error be identified? At the time the user modifies a 
persistent field? Or defer checking until flush (or commit)?

Portable behavior would probably mean defer checking.

Silently ignoring an update is probably not the right behavior.

 Ability to mark a class as read-only
 

 Key: JDO-677
 URL: https://issues.apache.org/jira/browse/JDO-677
 Project: JDO
  Issue Type: New Feature
  Components: api, specification, tck
Reporter: Andy Jefferson

 While JDO already allows a datastore to be marked as read-only 
 (javax.jdo.option.ReadOnly), it would be desirable to extend this down to 
 class-level. To achieve this we could add an (boolean) attribute read-only 
 at class level to metadata. The same behaviour defined in the spec as for 
 datastore-level would apply at class-level when a class is marked with this 
 attribute as true

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira




Minutes: JDO TCK Conference Call Friday, Mar 4, 9 am Pacific Time

2011-03-04 Thread Craig L Russell

Attendees: Michelle Caisse, Michael Bouschen, Craig Russell

Agenda:

1. Maven 2 upgrade - using setting.xml or profiles.xml for iut profile 
https://issues.apache.org/jira/browse/JDO-647

Apparently maven doesn't want to encourage items in the settings.xml  
to affect the build, but we do. Specifically, we want to have the  
user's settings.xml to provide settings to run the iut. Any suggestions?


2. Typesafe ... query capability for JDOQL - ready for check-in?. 
https://issues.apache.org/jira/browse/JDO-652

Some questions: the factory for query instances: should it be PM or  
PMF? Hint: do you really need to have the PM available in order to  
build a query? The PM represents your current connection to the  
database; the PMF represents the object model and mapping.


Also, the name sounds too inside. Matthew made a similar comment.  
I'd like to look at the name: TypesafeQuery.


Is there a bug in the blog?
ListObject[] results =  
em.createQuery(criteria).getSingleResult(); // should return Object[]?

ListInteger result =
tq.filter(cand.name.eq(MP3  
Extra)).executeResultUnique(Integer.class, cand.value.max()); //  
should return Integer?

Method name for returning projection might not be obvious.

Started looking at it in detail with an eye to including in 3.1. Not  
done yet.


3. Ability to mark a class as read-only - 
https://issues.apache.org/jira/browse/JDO-677

Seems like a good idea. Anyone else have comments?

Where would an error be identified? At the time the user modifies a  
persistent field? Or defer checking until flush (or commit)?


Portable behavior would probably mean defer checking.

Silently ignoring an update is probably not the right behavior.

4. Other issues

JDO-678 Set properties on PersistenceManager

Seems like a good idea. Patch?

Action Items from weeks past:
[Feb 25 2011] AI Michael, Craig, other volunteers: Look at  
Typesafe ... query capability for JDOQL https://issues.apache.org/jira/browse/JDO-652


Craig L Russell
Architect, Oracle
http://db.apache.org/jdo
408 276-5638 mailto:craig.russ...@oracle.com
P.S. A good JDO? O, Gasp!