[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2019-02-24 Thread fl...@itnews-bg.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Steve Todorov commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 I really don't know why is this marked as "fixed". I've opened another ticket about the same issue - https://issues.jenkins-ci.org/browse/JENKINS-56259  It would be really great if there was a parameter for the `input` step. You cannot wrap this in a `timeout` when you are using it at a `stage(){ input {} }` level in a declarative pipeline.   
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian Jira (v7.11.2#711002-sha1:fdc329d)  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2019-02-24 Thread fl...@itnews-bg.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Steve Todorov edited a comment on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 I really don't know why is this marked as "fixed /won't fix ". I've opened another ticket about the same issue - https://issues.jenkins-ci.org/browse/JENKINS-56259 It would be really great if there was a parameter for the `input` step. You cannot wrap this in a `timeout` when you are using it at a `stage()\{ input {} }` level in a declarative pipeline.   
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian Jira (v7.11.2#711002-sha1:fdc329d)  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-12-30 Thread kalininvsevo...@gmail.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Vsevolod Kalinin commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 While in progress the [quite ugly] workaround is 

 

long startTime = System.currentTimeMillis()
try {
timeout(time: timeoutInSeconds, unit: 'SECONDS') {
input 'Test'
}
} catch (err) {
long timePassed = System.currentTimeMillis() - startTime
if (timePassed >= timeoutInSeconds * 1000) {
echo 'Timed out'
} else {
throw err
}
}
 

  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-11-09 Thread jgl...@cloudbees.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Jesse Glick commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 

Both return org.jenkinsci.plugins.workflow.support.steps.input.Rejection@53ed4813 for timeout and abort.
 Seems like a bug in InputStepExecution.stop; should pass its Throwable on to onFailure rather than having doAbort construct a new FlowInterruptedException. (IOW, factor this code into a new method and revert the impersonate call from the fix of JENKINS-38380.) Could be fixed in conjunction with providing a sandbox-safe accessor for FlowInterruptedException.getCauses and defining an integration test.  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-09-26 Thread jgl...@cloudbees.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Jesse Glick commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 Jason Miller perhaps you are seeing JENKINS-38380. Do not discuss it here please.  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-29 Thread jgl...@cloudbees.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Jesse Glick updated an issue  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
 Jenkins /  JENKINS-36235  
 
 
  Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
Change By: 
 Jesse Glick  
 
 
Component/s: 
 pipeline-input-step-plugin  
 
 
Component/s: 
 pipeline  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-25 Thread jrkoi...@nucleon.nl (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Joost edited a comment on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 The [documentation|https://jenkins.io/doc/pipeline/steps/workflow-basic-steps/#code-timeout-code-enforce-time-limit] doesn't say what the default unit is.  Try this  This is working for me :{code:java} node { timeout(time:  5  10 , unit: 'SECONDS') {  input "waiting..."} } {code}  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-25 Thread jrkoi...@nucleon.nl (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Joost edited a comment on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 The [ link  documentation|https://jenkins.io/doc/pipeline/steps/workflow-basic-steps/#code-timeout-code-enforce-time-limit] doesn't say what the default unit is. Try this:{code:java}timeout(time: 5, unit: 'SECONDS') {  input "waiting..."}{code}  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-25 Thread jrkoi...@nucleon.nl (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Joost commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 The link documentation doesn't say what the default unit is. Try this: 

 

timeout(time: 5, unit: 'SECONDS') {
  input "waiting..."
}
 

  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-24 Thread jason.mil...@readytalk.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Jason Miller commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 Joost: Does this still work for you? I'm unable to get it working on my instance, using 2.7.2 and the latest pipeline plugins: 

 

timeout(5) {
  input "waiting..."
}
 

 The timeout block doesn't seem to work - it just hangs on the input step indefinitely until it's either approved or aborted, just as if it weren't in a timeout block at all. If I remove the input step, the timeout works as expected, so it seems like timeout isn't being allowed to abort the input step correctly.  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-16 Thread jrkoi...@nucleon.nl (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Joost commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 Wrapping a timeout block around the input step works for me. Thanks!  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-15 Thread ha...@codexdigital.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Harry Mallon commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 Jesse Glick: err.causes returns a similar output to err.getCauses(). Both return org.jenkinsci.plugins.workflow.support.steps.input.Rejection@53ed4813 for timeout and abort. I have never seen an Exceeded Timeout cause.  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-15 Thread jgl...@cloudbees.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Jesse Glick commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 Do not plan to accept the original RFE; should wrap with the timeout step. What Harry Mallon was looking for is err.causes, which may be ExceededTimeout, Rejection, or something else like UserInterruption. Currently this is not accessible from a sandboxed script, which is a problem.  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-08 Thread alv...@gmail.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Dan Alvizu updated an issue  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
 Jenkins /  JENKINS-36235  
 
 
  Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
Change By: 
 Dan Alvizu  
 
 
Component/s: 
 workflow-plugin  
 
 
Component/s: 
 build-pipeline-plugin  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-issues+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-08-08 Thread ha...@codexdigital.com (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Harry Mallon commented on  JENKINS-36235  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
  Re: Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
 I have been trying to emulate the 'continue' mode in pipeline for a while. This is useful to us as I want to use a multibranch pipeline and want it to provide both user-started release builds and user or auto started testing builds. The best way to emulate this seems to be to give a user choice and fall through to default options (testing) on timeout. What follows is my current attempt and it doesn't work as I cannot tell the difference between a timeout and user pressed Abort. 

 
try {
timeout(1) {
input message: 'Do you want to release this build?',
  parameters: [[$class: 'BooleanParameterDefinition',
defaultValue: false,
description: 'Ticking this box will do a release',
name: 'Release']]
}
} catch (err) {
def hi = err.getCauses()
echo "Exception thrown:\n ${hi}"

echo err.getLocalizedMessage()
echo err.getCause()
echo err.toString()
echo err.getClass().getName()
}
 

 What I am saying is this seems to be a major missing part of pipeline for me, and is blocking me moving from the old style builds.  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This message was sent by Atlassian JIRA (v7.1.7#71011-sha1:2526d7c)  
 
 

 
   
 

  
 

  
 

   





-- 
You received this 

[JIRA] (JENKINS-36235) Add optional 'timeout' parameter to 'input' step

2016-06-27 Thread jrkoi...@nucleon.nl (JIRA)
Title: Message Title


 
 
 
 

 
 
 

 
   
 Joost created an issue  
 

  
 
 
 
 

 
 
  
 
 
 
 

 
 Jenkins /  JENKINS-36235  
 
 
  Add optional 'timeout' parameter to 'input' step   
 

  
 
 
 
 

 
Issue Type: 
  New Feature  
 
 
Assignee: 
 Unassigned  
 
 
Components: 
 build-pipeline-plugin  
 
 
Created: 
 2016/Jun/27 6:29 AM  
 
 
Priority: 
  Minor  
 
 
Reporter: 
 Joost  
 

  
 
 
 
 

 
 An optional 'timeout' parameter for the 'input' pipeline step would be very nice. In case of no response within specified amount of time, the build would then fail. Or maybe even make that selectable: fail or continue.  
 

  
 
 
 
 

 
 
 

 
 
 Add Comment  
 

  
 

  
 
 
 
  
 

  
 
 
 
 

 
 This