Re: Velcoity Portlet Action

2004-04-19 Thread Raphaël Luta
Jason Shindler wrote:

I'm creating a VelocityAction portlet and running into some trouble. I
can only get the "doUpdate" action to work. If I rename it to "addNote"
or "doInsert," it no longer works - ignoring the action's method. Do the
action names have to be configured somewhere?
 
The name of the methods are important since the underlying Turbine
framework will match form inputs named "eventSubmit_update" to the
method name "doUpdate".
So if you change the method name, you also need to update the
form templates to activiate the correct methods.
Check out the Turbine documentation:
http://nagoya.apache.org/wiki/apachewiki.cgi?JakartaTurbine2ActionEvents
--
Raphaël Luta - [EMAIL PROTECTED]
-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]


RE: Velcoity Portlet Action

2004-04-19 Thread Jason Shindler
Ah! Wonderful! Disregard my last post as it was sent seconds before this
response was posted! :)
Jason

-Original Message-
From: Stuart Belden [mailto:[EMAIL PROTECTED] 
Sent: Monday, April 19, 2004 3:54 PM
To: [EMAIL PROTECTED]
Subject: Re: Velcoity Portlet Action

velocity action methods have strict naming standards:
http://jakarta.apache.org/velocity/user-guide.html
http://jakarta.apache.org/velocity/developer-guide.html

things like this work:
doSomething
doSomethingelsenow
doGohometomorrow

the following DO NOT work
doSomethingElse
goAway
doHelloWorld

Also make sure your RunData and Context arguments are in the proper
order.  The method signature must match exactly also.

The http parameter must be named eventSubmit_do[methodname] exactly in
order for it to be  called.

>>> [EMAIL PROTECTED] 04/19/04 12:06PM >>>
I'm creating a VelocityAction portlet and running into some trouble. I
can only get the "doUpdate" action to work. If I rename it to "addNote"
or "doInsert," it no longer works - ignoring the action's method. Do the
action names have to be configured somewhere?
 
Thanks,
Jason Shindler
 



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]


-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



RE: Velcoity Portlet Action

2004-04-19 Thread Jason Shindler
Does anybody have a more reliable answer to this? I'm setting up a
rather extensive portlet and I can't afford to rename and re-register my
portlet every time this happens...
Jason

-Original Message-
From: Robert Gombotz [mailto:[EMAIL PROTECTED] 
Sent: Monday, April 19, 2004 1:32 PM
To: Jetspeed Users List
Subject: Re: Velcoity Portlet Action

well, I have had that problem quite often before. I haven't found a real
solution for it.
However, many of my methods started working at some point. most of the
times
I just copied an existing action, registered the portlet under a second
different name and tested it. after i had seen it work, i renamed the
method
names.
I definitely have a doSave() method working in one of my portlets.
Could it have something to do with the action class being in a cache and
therefor not working if you change the method call in the
velocity-template?

my only advice is to play around a bit, rename methods a couple times
and at
some point they'll work.
would be nice though to find out the real cause of this strange
behaviour.


rob




- Original Message - 
From: "Jason Shindler" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Monday, April 19, 2004 7:06 PM
Subject: Velcoity Portlet Action


I'm creating a VelocityAction portlet and running into some trouble. I
can only get the "doUpdate" action to work. If I rename it to "addNote"
or "doInsert," it no longer works - ignoring the action's method. Do the
action names have to be configured somewhere?

Thanks,
Jason Shindler




-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]


-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: Velcoity Portlet Action

2004-04-19 Thread Stuart Belden
velocity action methods have strict naming standards:
http://jakarta.apache.org/velocity/user-guide.html
http://jakarta.apache.org/velocity/developer-guide.html

things like this work:
doSomething
doSomethingelsenow
doGohometomorrow

the following DO NOT work
doSomethingElse
goAway
doHelloWorld

Also make sure your RunData and Context arguments are in the proper order.  The method 
signature must match exactly also.

The http parameter must be named eventSubmit_do[methodname] exactly in order for it to 
be  called.

>>> [EMAIL PROTECTED] 04/19/04 12:06PM >>>
I'm creating a VelocityAction portlet and running into some trouble. I
can only get the "doUpdate" action to work. If I rename it to "addNote"
or "doInsert," it no longer works - ignoring the action's method. Do the
action names have to be configured somewhere?
 
Thanks,
Jason Shindler
 



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: Velcoity Portlet Action

2004-04-19 Thread Robert Gombotz
well, I have had that problem quite often before. I haven't found a real
solution for it.
However, many of my methods started working at some point. most of the times
I just copied an existing action, registered the portlet under a second
different name and tested it. after i had seen it work, i renamed the method
names.
I definitely have a doSave() method working in one of my portlets.
Could it have something to do with the action class being in a cache and
therefor not working if you change the method call in the velocity-template?

my only advice is to play around a bit, rename methods a couple times and at
some point they'll work.
would be nice though to find out the real cause of this strange behaviour.


rob




- Original Message - 
From: "Jason Shindler" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Monday, April 19, 2004 7:06 PM
Subject: Velcoity Portlet Action


I'm creating a VelocityAction portlet and running into some trouble. I
can only get the "doUpdate" action to work. If I rename it to "addNote"
or "doInsert," it no longer works - ignoring the action's method. Do the
action names have to be configured somewhere?

Thanks,
Jason Shindler




-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Velcoity Portlet Action

2004-04-19 Thread Jason Shindler
I'm creating a VelocityAction portlet and running into some trouble. I
can only get the "doUpdate" action to work. If I rename it to "addNote"
or "doInsert," it no longer works - ignoring the action's method. Do the
action names have to be configured somewhere?
 
Thanks,
Jason Shindler