D26484: Add KIO::DelayPopup flag and DropJob::menuPopup()

2020-01-12 Thread Tranter Madi
trmdi updated this revision to Diff 73337.
trmdi added a comment.


  - Move the flag to DropJob header, rename

REPOSITORY
  R241 KIO

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D26484?vs=73273=73337

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D26484

AFFECTED FILES
  src/widgets/dropjob.cpp
  src/widgets/dropjob.h

To: trmdi, #frameworks, davidedmundson, elvisangelaccio, mart, dfaure
Cc: ngraham, broulik, anthonyfieroni, kde-frameworks-devel, LeGast00n, GB_2, 
michaelh, bruns


D26484: Add KIO::DelayPopup flag and DropJob::menuPopup()

2020-01-11 Thread David Faure
dfaure requested changes to this revision.
dfaure added a comment.
This revision now requires changes to proceed.


  I agree with the approach. Just naming needs to be improved.
  
  I'd call the method "showMenu" or "showPopup".
  DelayPopup hints at a builtin timer, better call it something like 
DontShowPopup (even though some people don't like negative flags). 
ManualShowPopup? ExplicitShowPopup?
  And it shouldn't be in the job_base.h enum, which can be used by all jobs.
  Better add something to DropJob specifically.
  
  The new method also needs docu including @since.
  
  Thanks!

INLINE COMMENTS

> dropjob.cpp:416
> +
> +void DropJob::menuPopup(const QPoint , QAction *atAction) {
> +Q_D(DropJob);

This '{' goes on its own line.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D26484

To: trmdi, #frameworks, davidedmundson, elvisangelaccio, mart, dfaure
Cc: ngraham, broulik, anthonyfieroni, kde-frameworks-devel, LeGast00n, GB_2, 
michaelh, bruns


D26484: Add KIO::DelayPopup flag and DropJob::menuPopup()

2020-01-11 Thread Tranter Madi
trmdi marked 5 inline comments as done.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D26484

To: trmdi, #frameworks, davidedmundson, elvisangelaccio, mart, dfaure
Cc: ngraham, broulik, anthonyfieroni, kde-frameworks-devel, LeGast00n, GB_2, 
michaelh, bruns


D26484: Add KIO::DelayPopup flag and DropJob::menuPopup()

2020-01-11 Thread Tranter Madi
trmdi retitled this revision from "Popup menu again to reposition it" to "Add 
KIO::DelayPopup flag and DropJob::menuPopup()".
trmdi edited the summary of this revision.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D26484

To: trmdi, #frameworks, davidedmundson, elvisangelaccio, mart, dfaure
Cc: ngraham, broulik, anthonyfieroni, kde-frameworks-devel, LeGast00n, GB_2, 
michaelh, bruns