D29528: [OpenUrlJob] Improve comments/docs

2020-05-08 Thread Ahmad Samir
This revision was automatically updated to reflect the committed changes.
Closed by commit R241:1b9b239eb262: [OpenUrlJob] Improve comments/docs 
(authored by ahmadsamir).

REPOSITORY
  R241 KIO

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D29528?vs=82286=82304

REVISION DETAIL
  https://phabricator.kde.org/D29528

AFFECTED FILES
  src/gui/openurljob.cpp
  src/gui/openurljob.h
  src/gui/openurljobhandlerinterface.h
  src/widgets/kdesktopfileactions.cpp
  src/widgets/kopenwithdialog.cpp
  src/widgets/krun.cpp
  src/widgets/widgetsopenurljobhandler.h

To: ahmadsamir, #frameworks, dfaure
Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns


D29528: [OpenUrlJob] Improve comments/docs

2020-05-08 Thread David Faure
dfaure accepted this revision.
This revision is now accepted and ready to land.

REPOSITORY
  R241 KIO

BRANCH
  l-late (branched from master)

REVISION DETAIL
  https://phabricator.kde.org/D29528

To: ahmadsamir, #frameworks, dfaure
Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns


D29528: [OpenUrlJob] Improve comments/docs

2020-05-08 Thread Ahmad Samir
ahmadsamir updated this revision to Diff 82286.
ahmadsamir marked an inline comment as done.
ahmadsamir added a comment.


  Address comments

REPOSITORY
  R241 KIO

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D29528?vs=82260=82286

BRANCH
  l-late (branched from master)

REVISION DETAIL
  https://phabricator.kde.org/D29528

AFFECTED FILES
  src/gui/openurljob.cpp
  src/gui/openurljob.h
  src/gui/openurljobhandlerinterface.h
  src/widgets/kdesktopfileactions.cpp
  src/widgets/kopenwithdialog.cpp
  src/widgets/krun.cpp
  src/widgets/widgetsopenurljobhandler.h

To: ahmadsamir, #frameworks, dfaure
Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns


D29528: [OpenUrlJob] Improve comments/docs

2020-05-08 Thread Ahmad Samir
ahmadsamir marked 2 inline comments as done.
ahmadsamir added inline comments.

INLINE COMMENTS

> dfaure wrote in openurljob.cpp:590
> That one was on purpose. I find this version less readable, mixing a test and 
> an actual action (with error handling).

Fair point.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D29528

To: ahmadsamir, #frameworks, dfaure
Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns


D29528: [OpenUrlJob] Improve comments/docs

2020-05-08 Thread David Faure
dfaure added a comment.


  Thanks!

INLINE COMMENTS

> openurljob.cpp:393
> +if (mime.isValid() && mimeName != m_mimeTypeName) {
> +m_mimeTypeName =mimeName;
>  }

missing space after '='

> openurljob.cpp:590
> +const QMimeType mimeType = db.mimeTypeForName(m_mimeTypeName);
> +if (isExecutableMime(mimeType) && handleExecutables(mimeType)) {
> +return;

That one was on purpose. I find this version less readable, mixing a test and 
an actual action (with error handling).

> openurljob.h:114
>   * Starts the job.
> - * You must call this, after having done all the setters.
> + * You must call this, after having called all the needed setters.
>   * This is a GUI job, never use exec(), it would block user interaction.

I think I used the sentence in the two LauncherJobs, feel free to make the same 
change here.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D29528

To: ahmadsamir, #frameworks, dfaure
Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns


D29528: [OpenUrlJob] Improve comments/docs

2020-05-08 Thread Ahmad Samir
ahmadsamir created this revision.
ahmadsamir added reviewers: Frameworks, dfaure.
Herald added a project: Frameworks.
ahmadsamir requested review of this revision.

REPOSITORY
  R241 KIO

BRANCH
  l-late (branched from master)

REVISION DETAIL
  https://phabricator.kde.org/D29528

AFFECTED FILES
  src/gui/openurljob.cpp
  src/gui/openurljob.h
  src/gui/openurljobhandlerinterface.h
  src/widgets/kdesktopfileactions.cpp
  src/widgets/kopenwithdialog.cpp
  src/widgets/krun.cpp
  src/widgets/widgetsopenurljobhandler.h

To: ahmadsamir, #frameworks, dfaure
Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns