Re: Review Request 125418: Add method to revert knotifyconfigwidget to default notifications

2015-10-03 Thread David Edmundson


> On Sept. 27, 2015, 8:21 a.m., Sune Vuorela wrote:
> > src/knotifyconfigwidget.h, line 73
> > 
> >
> > This function name for a setter looks weird to me.
> > setDefaults()
> > reset()
> > restoreDefaults()
> > 
> > would be better names in my opinion. 
> > 
> > defaults() doesn't look like an action, so it must be a getter.
> 
> David Edmundson wrote:
> I half agree, It would be better with of verb in there.
> On the other hand matching KCModule API is a good thing too as then 
> things are consistent.
> 
> I'll wait for a third opinion and blindly go with whatever that says.
> 
> David Faure wrote:
> KConfig uses revertToDefault(key).
> 
> You could use revertToDefaults() here.

Done


- David


---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125418/#review86002
---


On Sept. 27, 2015, 12:42 a.m., David Edmundson wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/125418/
> ---
> 
> (Updated Sept. 27, 2015, 12:42 a.m.)
> 
> 
> Review request for KDE Frameworks.
> 
> 
> Repository: knotifyconfig
> 
> 
> Description
> ---
> 
> Add method to revert knotifyconfigwidget to defaults
> 
> 
> Diffs
> -
> 
>   src/knotifyconfigwidget.h dd336bc996008809678a6f44cbefe4bf0761908d 
>   src/knotifyconfigwidget.cpp 72c826de3d4c6984b3daac351e5a9a5a6a5bb1eb 
>   src/knotifyeventlist.h 110e3932fb94528a72cec1da911c734c174e1ba8 
>   src/knotifyeventlist.cpp dd6b6e9d5557fde0b46d980e4078921dd978f13f 
> 
> Diff: https://git.reviewboard.kde.org/r/125418/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> David Edmundson
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 125418: Add method to revert knotifyconfigwidget to default notifications

2015-10-03 Thread David Faure


> On Sept. 27, 2015, 8:21 a.m., Sune Vuorela wrote:
> > src/knotifyconfigwidget.h, line 73
> > 
> >
> > This function name for a setter looks weird to me.
> > setDefaults()
> > reset()
> > restoreDefaults()
> > 
> > would be better names in my opinion. 
> > 
> > defaults() doesn't look like an action, so it must be a getter.
> 
> David Edmundson wrote:
> I half agree, It would be better with of verb in there.
> On the other hand matching KCModule API is a good thing too as then 
> things are consistent.
> 
> I'll wait for a third opinion and blindly go with whatever that says.

KConfig uses revertToDefault(key).

You could use revertToDefaults() here.


- David


---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125418/#review86002
---


On Sept. 27, 2015, 12:42 a.m., David Edmundson wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/125418/
> ---
> 
> (Updated Sept. 27, 2015, 12:42 a.m.)
> 
> 
> Review request for KDE Frameworks.
> 
> 
> Repository: knotifyconfig
> 
> 
> Description
> ---
> 
> Add method to revert knotifyconfigwidget to defaults
> 
> 
> Diffs
> -
> 
>   src/knotifyconfigwidget.h dd336bc996008809678a6f44cbefe4bf0761908d 
>   src/knotifyconfigwidget.cpp 72c826de3d4c6984b3daac351e5a9a5a6a5bb1eb 
>   src/knotifyeventlist.h 110e3932fb94528a72cec1da911c734c174e1ba8 
>   src/knotifyeventlist.cpp dd6b6e9d5557fde0b46d980e4078921dd978f13f 
> 
> Diff: https://git.reviewboard.kde.org/r/125418/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> David Edmundson
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 125418: Add method to revert knotifyconfigwidget to default notifications

2015-09-27 Thread David Edmundson


> On Sept. 27, 2015, 8:21 a.m., Sune Vuorela wrote:
> > src/knotifyconfigwidget.h, line 73
> > 
> >
> > This function name for a setter looks weird to me.
> > setDefaults()
> > reset()
> > restoreDefaults()
> > 
> > would be better names in my opinion. 
> > 
> > defaults() doesn't look like an action, so it must be a getter.

I half agree, It would be better with of verb in there.
On the other hand matching KCModule API is a good thing too as then things are 
consistent.

I'll wait for a third opinion and blindly go with whatever that says.


- David


---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125418/#review86002
---


On Sept. 27, 2015, 12:42 a.m., David Edmundson wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/125418/
> ---
> 
> (Updated Sept. 27, 2015, 12:42 a.m.)
> 
> 
> Review request for KDE Frameworks.
> 
> 
> Repository: knotifyconfig
> 
> 
> Description
> ---
> 
> Add method to revert knotifyconfigwidget to defaults
> 
> 
> Diffs
> -
> 
>   src/knotifyconfigwidget.h dd336bc996008809678a6f44cbefe4bf0761908d 
>   src/knotifyconfigwidget.cpp 72c826de3d4c6984b3daac351e5a9a5a6a5bb1eb 
>   src/knotifyeventlist.h 110e3932fb94528a72cec1da911c734c174e1ba8 
>   src/knotifyeventlist.cpp dd6b6e9d5557fde0b46d980e4078921dd978f13f 
> 
> Diff: https://git.reviewboard.kde.org/r/125418/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> David Edmundson
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 125418: Add method to revert knotifyconfigwidget to default notifications

2015-09-27 Thread Sune Vuorela

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125418/#review86002
---



src/knotifyconfigwidget.h (line 73)


This function name for a setter looks weird to me.
setDefaults()
reset()
restoreDefaults()

would be better names in my opinion. 

defaults() doesn't look like an action, so it must be a getter.


- Sune Vuorela


On Sept. 27, 2015, 12:42 a.m., David Edmundson wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/125418/
> ---
> 
> (Updated Sept. 27, 2015, 12:42 a.m.)
> 
> 
> Review request for KDE Frameworks.
> 
> 
> Repository: knotifyconfig
> 
> 
> Description
> ---
> 
> Add method to revert knotifyconfigwidget to defaults
> 
> 
> Diffs
> -
> 
>   src/knotifyconfigwidget.h dd336bc996008809678a6f44cbefe4bf0761908d 
>   src/knotifyconfigwidget.cpp 72c826de3d4c6984b3daac351e5a9a5a6a5bb1eb 
>   src/knotifyeventlist.h 110e3932fb94528a72cec1da911c734c174e1ba8 
>   src/knotifyeventlist.cpp dd6b6e9d5557fde0b46d980e4078921dd978f13f 
> 
> Diff: https://git.reviewboard.kde.org/r/125418/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> David Edmundson
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 125418: Add method to revert knotifyconfigwidget to default notifications

2015-09-26 Thread David Edmundson

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125418/
---

(Updated Sept. 26, 2015, 11:29 p.m.)


Review request for KDE Frameworks.


Summary (updated)
-

Add method to revert knotifyconfigwidget to default notifications


Repository: knotifyconfig


Description (updated)
---

Add method to revert knotifyconfigwidget to defaults


Diffs
-

  src/knotifyconfigwidget.h dd336bc996008809678a6f44cbefe4bf0761908d 
  src/knotifyconfigwidget.cpp 72c826de3d4c6984b3daac351e5a9a5a6a5bb1eb 
  src/knotifyeventlist.h 110e3932fb94528a72cec1da911c734c174e1ba8 
  src/knotifyeventlist.cpp dd6b6e9d5557fde0b46d980e4078921dd978f13f 

Diff: https://git.reviewboard.kde.org/r/125418/diff/


Testing
---


Thanks,

David Edmundson

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 125418: Add method to revert knotifyconfigwidget to default notifications

2015-09-26 Thread Martin Klapetek

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125418/#review85999
---

Ship it!


Ship It!

- Martin Klapetek


On Sept. 27, 2015, 1:29 a.m., David Edmundson wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/125418/
> ---
> 
> (Updated Sept. 27, 2015, 1:29 a.m.)
> 
> 
> Review request for KDE Frameworks.
> 
> 
> Repository: knotifyconfig
> 
> 
> Description
> ---
> 
> Add method to revert knotifyconfigwidget to defaults
> 
> 
> Diffs
> -
> 
>   src/knotifyconfigwidget.h dd336bc996008809678a6f44cbefe4bf0761908d 
>   src/knotifyconfigwidget.cpp 72c826de3d4c6984b3daac351e5a9a5a6a5bb1eb 
>   src/knotifyeventlist.h 110e3932fb94528a72cec1da911c734c174e1ba8 
>   src/knotifyeventlist.cpp dd6b6e9d5557fde0b46d980e4078921dd978f13f 
> 
> Diff: https://git.reviewboard.kde.org/r/125418/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> David Edmundson
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 125418: Add method to revert knotifyconfigwidget to default notifications

2015-09-26 Thread David Edmundson

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125418/
---

(Updated Sept. 27, 2015, 12:42 a.m.)


Status
--

This change has been marked as submitted.


Review request for KDE Frameworks.


Changes
---

Submitted with commit c46b85072f2cabfaabc957a7f214f0cf4f8a2ba5 by David 
Edmundson to branch master.


Repository: knotifyconfig


Description
---

Add method to revert knotifyconfigwidget to defaults


Diffs
-

  src/knotifyconfigwidget.h dd336bc996008809678a6f44cbefe4bf0761908d 
  src/knotifyconfigwidget.cpp 72c826de3d4c6984b3daac351e5a9a5a6a5bb1eb 
  src/knotifyeventlist.h 110e3932fb94528a72cec1da911c734c174e1ba8 
  src/knotifyeventlist.cpp dd6b6e9d5557fde0b46d980e4078921dd978f13f 

Diff: https://git.reviewboard.kde.org/r/125418/diff/


Testing
---


Thanks,

David Edmundson

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel