[PATCH 25/27] Fix trace.h

2009-10-30 Thread Alexander Graf
It looks like the variable pc is defined. At least the current code always
failed on me stating that pc is already defined somewhere else.

Let's use _pc instead, because that doesn't collide.

Is this the right approach? Does it break on 440 too? If not, why not?

Signed-off-by: Alexander Graf ag...@suse.de
---
 arch/powerpc/kvm/trace.h |6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
index 67f219d..a8e8400 100644
--- a/arch/powerpc/kvm/trace.h
+++ b/arch/powerpc/kvm/trace.h
@@ -12,8 +12,8 @@
  * Tracepoint for guest mode entry.
  */
 TRACE_EVENT(kvm_ppc_instr,
-   TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
-   TP_ARGS(inst, pc, emulate),
+   TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
+   TP_ARGS(inst, _pc, emulate),
 
TP_STRUCT__entry(
__field(unsigned int,   inst)
@@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
TP_fast_assign(
__entry-inst   = inst;
-   __entry-pc = pc;
+   __entry-pc = _pc;
__entry-emulate= emulate;
),
 
-- 
1.6.0.2

--
To unsubscribe from this list: send the line unsubscribe kvm in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 25/27] Fix trace.h

2009-10-30 Thread Alexander Graf
It looks like the variable pc is defined. At least the current code always
failed on me stating that pc is already defined somewhere else.

Let's use _pc instead, because that doesn't collide.

Is this the right approach? Does it break on 440 too? If not, why not?

Signed-off-by: Alexander Graf ag...@suse.de
---
 arch/powerpc/kvm/trace.h |6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
index 67f219d..a8e8400 100644
--- a/arch/powerpc/kvm/trace.h
+++ b/arch/powerpc/kvm/trace.h
@@ -12,8 +12,8 @@
  * Tracepoint for guest mode entry.
  */
 TRACE_EVENT(kvm_ppc_instr,
-   TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
-   TP_ARGS(inst, pc, emulate),
+   TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
+   TP_ARGS(inst, _pc, emulate),
 
TP_STRUCT__entry(
__field(unsigned int,   inst)
@@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
TP_fast_assign(
__entry-inst   = inst;
-   __entry-pc = pc;
+   __entry-pc = _pc;
__entry-emulate= emulate;
),
 
-- 
1.6.0.2

--
To unsubscribe from this list: send the line unsubscribe kvm-ppc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 25/27] Fix trace.h

2009-10-21 Thread Alexander Graf
It looks like the variable pc is defined. At least the current code always
failed on me stating that pc is already defined somewhere else.

Let's use _pc instead, because that doesn't collide.

Is this the right approach? Does it break on 440 too? If not, why not?

Signed-off-by: Alexander Graf ag...@suse.de
---
 arch/powerpc/kvm/trace.h |6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
index 67f219d..a8e8400 100644
--- a/arch/powerpc/kvm/trace.h
+++ b/arch/powerpc/kvm/trace.h
@@ -12,8 +12,8 @@
  * Tracepoint for guest mode entry.
  */
 TRACE_EVENT(kvm_ppc_instr,
-   TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
-   TP_ARGS(inst, pc, emulate),
+   TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
+   TP_ARGS(inst, _pc, emulate),
 
TP_STRUCT__entry(
__field(unsigned int,   inst)
@@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
TP_fast_assign(
__entry-inst   = inst;
-   __entry-pc = pc;
+   __entry-pc = _pc;
__entry-emulate= emulate;
),
 
-- 
1.6.0.2

--
To unsubscribe from this list: send the line unsubscribe kvm in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 25/27] Fix trace.h

2009-10-10 Thread Benjamin Herrenschmidt
On Fri, 2009-10-09 at 14:42 -0700, Hollis Blanchard wrote:
 After much digging, I managed to actually enable CONFIG_TRACEPOINTS.
 However, I still don't get any build errors from this code. Maybe you
 could paste the full gcc output? 

Another option is to be a bit more ppc-ish and call it IAR instead of
PC :-)

Cheers,
Ben.

--
To unsubscribe from this list: send the line unsubscribe kvm-ppc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 25/27] Fix trace.h

2009-10-09 Thread Hollis Blanchard
On Tue, 2009-09-29 at 10:18 +0200, Alexander Graf wrote:
 It looks like the variable pc is defined. At least the current code always
 failed on me stating that pc is already defined somewhere else.
 
 Let's use _pc instead, because that doesn't collide.
 
 Is this the right approach? Does it break on 440 too? If not, why not?
 
 Signed-off-by: Alexander Graf ag...@suse.de
 ---
  arch/powerpc/kvm/trace.h |6 +++---
  1 files changed, 3 insertions(+), 3 deletions(-)
 
 diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
 index 67f219d..a8e8400 100644
 --- a/arch/powerpc/kvm/trace.h
 +++ b/arch/powerpc/kvm/trace.h
 @@ -12,8 +12,8 @@
   * Tracepoint for guest mode entry.
   */
  TRACE_EVENT(kvm_ppc_instr,
 - TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
 - TP_ARGS(inst, pc, emulate),
 + TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
 + TP_ARGS(inst, _pc, emulate),
 
   TP_STRUCT__entry(
   __field(unsigned int,   inst)
 @@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
   TP_fast_assign(
   __entry-inst   = inst;
 - __entry-pc = pc;
 + __entry-pc = _pc;
   __entry-emulate= emulate;
   ),
 

After much digging, I managed to actually enable CONFIG_TRACEPOINTS.
However, I still don't get any build errors from this code. Maybe you
could paste the full gcc output?

-- 
Hollis Blanchard
IBM Linux Technology Center

--
To unsubscribe from this list: send the line unsubscribe kvm-ppc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 25/27] Fix trace.h

2009-09-29 Thread Alexander Graf
It looks like the variable pc is defined. At least the current code always
failed on me stating that pc is already defined somewhere else.

Let's use _pc instead, because that doesn't collide.

Is this the right approach? Does it break on 440 too? If not, why not?

Signed-off-by: Alexander Graf ag...@suse.de
---
 arch/powerpc/kvm/trace.h |6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/kvm/trace.h b/arch/powerpc/kvm/trace.h
index 67f219d..a8e8400 100644
--- a/arch/powerpc/kvm/trace.h
+++ b/arch/powerpc/kvm/trace.h
@@ -12,8 +12,8 @@
  * Tracepoint for guest mode entry.
  */
 TRACE_EVENT(kvm_ppc_instr,
-   TP_PROTO(unsigned int inst, unsigned long pc, unsigned int emulate),
-   TP_ARGS(inst, pc, emulate),
+   TP_PROTO(unsigned int inst, unsigned long _pc, unsigned int emulate),
+   TP_ARGS(inst, _pc, emulate),
 
TP_STRUCT__entry(
__field(unsigned int,   inst)
@@ -23,7 +23,7 @@ TRACE_EVENT(kvm_ppc_instr,
 
TP_fast_assign(
__entry-inst   = inst;
-   __entry-pc = pc;
+   __entry-pc = _pc;
__entry-emulate= emulate;
),
 
-- 
1.6.0.2

--
To unsubscribe from this list: send the line unsubscribe kvm-ppc in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html