Re: [libvirt] [PATCH 00/15] Add more vHBA related tests and module-arize the code

2017-02-16 Thread John Ferlan
ping*2?

These really aren't that difficult - there's test adjustments, code
motion, function renames, and new tests.

Tks -

John

On 02/07/2017 07:49 AM, John Ferlan wrote:
> 
> ping?
> 
> tks -
> 
> John
> 
> On 01/25/2017 03:27 PM, John Ferlan wrote:
>> Don't be scared off by the quantity of patches...
>>
>> There's quite a bit of code motion and function renaming going on before
>> being able to more easily add tests that will ensure that from a nodedev
>> perspective creation and deletion of the vHBA will work properly and it's
>> possible to test the various ways to create a vHBA (nothing provide, a
>> parent by name provided, a parent by wwnn/wwpn provided, and a parent
>> by fabric_wwn provided).
>>
>> I did run this through the coverity checking code with no errors...
>>
>> John Ferlan (15):
>>   tests: Alter test_driver HBA name/data to be closer to reality
>>   test: Add new NPIV capable HBA and a vHBA
>>   test: Add helper to create vHBA for testNodeDeviceCreateXML
>>   tests: Create a more realistic vHBA
>>   test: Fix fchosttest resource leak
>>   util: Create a new virvhba module and move/rename API's
>>   util: Move/rename virStoragePoolGetVhbaSCSIHostParent to virvhba
>>   util: Reduce complexity of virVHBAGetParent
>>   util: Move scsi_host specific functions from virutil
>>   tests: Add new fchosttest tests for management of a vHBA
>>   nodedev: Keep the node device lock longer in nodeDeviceDestroy
>>   nodedev: Rework virNodeDeviceGetParentHost
>>   tests: Add createVHBAByNodeDevice-no-parent to fchosttest
>>   tests: Add createVHBAByNodeDevice-parent-wwn to fchosttest
>>   tests: Add createVHBAByNodeDevice-parent-fabric-wwn to fchosttest
>>
>>  po/POTFILES.in|   2 +
>>  src/Makefile.am   |   2 +
>>  src/conf/node_device_conf.c   |  76 +++-
>>  src/conf/node_device_conf.h   |  19 +-
>>  src/conf/storage_conf.c   | 100 ++---
>>  src/conf/storage_conf.h   |   5 -
>>  src/libvirt_private.syms  |  32 +-
>>  src/node_device/node_device_driver.c  |  92 ++--
>>  src/node_device/node_device_linux_sysfs.c |  24 +-
>>  src/storage/storage_backend_scsi.c|  68 +--
>>  src/test/test_driver.c| 178 ++--
>>  src/util/virscsi.c|   4 +
>>  src/util/virscsihost.c| 297 
>>  src/util/virscsihost.h|  40 ++
>>  src/util/virutil.c| 724 
>> --
>>  src/util/virutil.h|  47 --
>>  src/util/virvhba.c| 591 
>>  src/util/virvhba.h|  59 +++
>>  tests/fchosttest.c| 183 ++--
>>  tests/objecteventtest.c   |   6 +-
>>  tests/scsihosttest.c  |  16 +-
>>  tests/virrandommock.c |   9 +
>>  22 files changed, 1463 insertions(+),  deletions(-)
>>  create mode 100644 src/util/virscsihost.c
>>  create mode 100644 src/util/virscsihost.h
>>  create mode 100644 src/util/virvhba.c
>>  create mode 100644 src/util/virvhba.h
>>
> 
> --
> libvir-list mailing list
> libvir-list@redhat.com
> https://www.redhat.com/mailman/listinfo/libvir-list
> 

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


Re: [libvirt] [PATCH 00/15] Add more vHBA related tests and module-arize the code

2017-02-07 Thread John Ferlan

ping?

tks -

John

On 01/25/2017 03:27 PM, John Ferlan wrote:
> Don't be scared off by the quantity of patches...
> 
> There's quite a bit of code motion and function renaming going on before
> being able to more easily add tests that will ensure that from a nodedev
> perspective creation and deletion of the vHBA will work properly and it's
> possible to test the various ways to create a vHBA (nothing provide, a
> parent by name provided, a parent by wwnn/wwpn provided, and a parent
> by fabric_wwn provided).
> 
> I did run this through the coverity checking code with no errors...
> 
> John Ferlan (15):
>   tests: Alter test_driver HBA name/data to be closer to reality
>   test: Add new NPIV capable HBA and a vHBA
>   test: Add helper to create vHBA for testNodeDeviceCreateXML
>   tests: Create a more realistic vHBA
>   test: Fix fchosttest resource leak
>   util: Create a new virvhba module and move/rename API's
>   util: Move/rename virStoragePoolGetVhbaSCSIHostParent to virvhba
>   util: Reduce complexity of virVHBAGetParent
>   util: Move scsi_host specific functions from virutil
>   tests: Add new fchosttest tests for management of a vHBA
>   nodedev: Keep the node device lock longer in nodeDeviceDestroy
>   nodedev: Rework virNodeDeviceGetParentHost
>   tests: Add createVHBAByNodeDevice-no-parent to fchosttest
>   tests: Add createVHBAByNodeDevice-parent-wwn to fchosttest
>   tests: Add createVHBAByNodeDevice-parent-fabric-wwn to fchosttest
> 
>  po/POTFILES.in|   2 +
>  src/Makefile.am   |   2 +
>  src/conf/node_device_conf.c   |  76 +++-
>  src/conf/node_device_conf.h   |  19 +-
>  src/conf/storage_conf.c   | 100 ++---
>  src/conf/storage_conf.h   |   5 -
>  src/libvirt_private.syms  |  32 +-
>  src/node_device/node_device_driver.c  |  92 ++--
>  src/node_device/node_device_linux_sysfs.c |  24 +-
>  src/storage/storage_backend_scsi.c|  68 +--
>  src/test/test_driver.c| 178 ++--
>  src/util/virscsi.c|   4 +
>  src/util/virscsihost.c| 297 
>  src/util/virscsihost.h|  40 ++
>  src/util/virutil.c| 724 
> --
>  src/util/virutil.h|  47 --
>  src/util/virvhba.c| 591 
>  src/util/virvhba.h|  59 +++
>  tests/fchosttest.c| 183 ++--
>  tests/objecteventtest.c   |   6 +-
>  tests/scsihosttest.c  |  16 +-
>  tests/virrandommock.c |   9 +
>  22 files changed, 1463 insertions(+),  deletions(-)
>  create mode 100644 src/util/virscsihost.c
>  create mode 100644 src/util/virscsihost.h
>  create mode 100644 src/util/virvhba.c
>  create mode 100644 src/util/virvhba.h
> 

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list


[libvirt] [PATCH 00/15] Add more vHBA related tests and module-arize the code

2017-01-25 Thread John Ferlan
Don't be scared off by the quantity of patches...

There's quite a bit of code motion and function renaming going on before
being able to more easily add tests that will ensure that from a nodedev
perspective creation and deletion of the vHBA will work properly and it's
possible to test the various ways to create a vHBA (nothing provide, a
parent by name provided, a parent by wwnn/wwpn provided, and a parent
by fabric_wwn provided).

I did run this through the coverity checking code with no errors...

John Ferlan (15):
  tests: Alter test_driver HBA name/data to be closer to reality
  test: Add new NPIV capable HBA and a vHBA
  test: Add helper to create vHBA for testNodeDeviceCreateXML
  tests: Create a more realistic vHBA
  test: Fix fchosttest resource leak
  util: Create a new virvhba module and move/rename API's
  util: Move/rename virStoragePoolGetVhbaSCSIHostParent to virvhba
  util: Reduce complexity of virVHBAGetParent
  util: Move scsi_host specific functions from virutil
  tests: Add new fchosttest tests for management of a vHBA
  nodedev: Keep the node device lock longer in nodeDeviceDestroy
  nodedev: Rework virNodeDeviceGetParentHost
  tests: Add createVHBAByNodeDevice-no-parent to fchosttest
  tests: Add createVHBAByNodeDevice-parent-wwn to fchosttest
  tests: Add createVHBAByNodeDevice-parent-fabric-wwn to fchosttest

 po/POTFILES.in|   2 +
 src/Makefile.am   |   2 +
 src/conf/node_device_conf.c   |  76 +++-
 src/conf/node_device_conf.h   |  19 +-
 src/conf/storage_conf.c   | 100 ++---
 src/conf/storage_conf.h   |   5 -
 src/libvirt_private.syms  |  32 +-
 src/node_device/node_device_driver.c  |  92 ++--
 src/node_device/node_device_linux_sysfs.c |  24 +-
 src/storage/storage_backend_scsi.c|  68 +--
 src/test/test_driver.c| 178 ++--
 src/util/virscsi.c|   4 +
 src/util/virscsihost.c| 297 
 src/util/virscsihost.h|  40 ++
 src/util/virutil.c| 724 --
 src/util/virutil.h|  47 --
 src/util/virvhba.c| 591 
 src/util/virvhba.h|  59 +++
 tests/fchosttest.c| 183 ++--
 tests/objecteventtest.c   |   6 +-
 tests/scsihosttest.c  |  16 +-
 tests/virrandommock.c |   9 +
 22 files changed, 1463 insertions(+),  deletions(-)
 create mode 100644 src/util/virscsihost.c
 create mode 100644 src/util/virscsihost.h
 create mode 100644 src/util/virvhba.c
 create mode 100644 src/util/virvhba.h

-- 
2.7.4

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list