Re: [libvirt PATCHv2 00/16] refactor qemuAgentGetInterfaces

2020-10-07 Thread Neal Gompa
On Wed, Oct 7, 2020 at 8:35 AM Ján Tomko  wrote:
>
> v2:
>  * add new patch separating error checking in qemuAgentGetInterfaceOneAddress
>  * split out naddrs++ on a separate line
>  * added documentation for qemuAgentGetInterfaceAddresses
>  * added qemuAgentGetAllInterfaceAddresses
>
> Ján Tomko (16):
>   qemu: agent: remove redundant checks
>   qemu: agent: split out qemuAgentGetInterfaceOneAddress
>   qemu: agent: remove impossible errors
>   qemu: agent: reduce scope of addrs_count
>   qemu: agent: expand addrs upfront
>   qemu: agent: use g_auto for ifname
>   qemu: agent: use virHashNew
>   qemu: agent: simplify access to ifaces_ret
>   qemu: agent: split out qemuAgentGetInterfaceAddresses
>   qemu: agent: use GetArray to remove a check
>   qemu: agent: use g_auto in qemuAgentGetInterfaces
>   qemu: agent: remove cleanup in qemuAgentGetInterfaces
>   qemuAgentGetInterfaceAddresses: turn ifname into char*
>   qemu: agent: rename tmp_iface to iface_obj
>   qemuAgentGetInterfaceOneAddress: check for errors early
>   qemu: agent: split out qemuAgentGetAllInterfaceAddresses
>
>  src/qemu/qemu_agent.c | 355 +-
>  1 file changed, 180 insertions(+), 175 deletions(-)
>
> --
> 2.26.2
>

Series LGTM.

Reviewed-by: Neal Gompa 

-- 
真実はいつも一つ!/ Always, there's only one truth!




Re: [libvirt PATCHv2 00/16] refactor qemuAgentGetInterfaces

2020-10-07 Thread Jonathon Jongsma
On Wed,  7 Oct 2020 14:35:21 +0200
Ján Tomko  wrote:

> v2:
>  * add new patch separating error checking in
> qemuAgentGetInterfaceOneAddress
>  * split out naddrs++ on a separate line
>  * added documentation for qemuAgentGetInterfaceAddresses
>  * added qemuAgentGetAllInterfaceAddresses
> 
> Ján Tomko (16):
>   qemu: agent: remove redundant checks
>   qemu: agent: split out qemuAgentGetInterfaceOneAddress
>   qemu: agent: remove impossible errors
>   qemu: agent: reduce scope of addrs_count
>   qemu: agent: expand addrs upfront
>   qemu: agent: use g_auto for ifname
>   qemu: agent: use virHashNew
>   qemu: agent: simplify access to ifaces_ret
>   qemu: agent: split out qemuAgentGetInterfaceAddresses
>   qemu: agent: use GetArray to remove a check
>   qemu: agent: use g_auto in qemuAgentGetInterfaces
>   qemu: agent: remove cleanup in qemuAgentGetInterfaces
>   qemuAgentGetInterfaceAddresses: turn ifname into char*
>   qemu: agent: rename tmp_iface to iface_obj
>   qemuAgentGetInterfaceOneAddress: check for errors early
>   qemu: agent: split out qemuAgentGetAllInterfaceAddresses
> 
>  src/qemu/qemu_agent.c | 355
> +- 1 file changed, 180
> insertions(+), 175 deletions(-)
> 


Looks good to me.

Reviewed-by: Jonathon Jongsma 



[libvirt PATCHv2 00/16] refactor qemuAgentGetInterfaces

2020-10-07 Thread Ján Tomko
v2:
 * add new patch separating error checking in qemuAgentGetInterfaceOneAddress
 * split out naddrs++ on a separate line
 * added documentation for qemuAgentGetInterfaceAddresses
 * added qemuAgentGetAllInterfaceAddresses

Ján Tomko (16):
  qemu: agent: remove redundant checks
  qemu: agent: split out qemuAgentGetInterfaceOneAddress
  qemu: agent: remove impossible errors
  qemu: agent: reduce scope of addrs_count
  qemu: agent: expand addrs upfront
  qemu: agent: use g_auto for ifname
  qemu: agent: use virHashNew
  qemu: agent: simplify access to ifaces_ret
  qemu: agent: split out qemuAgentGetInterfaceAddresses
  qemu: agent: use GetArray to remove a check
  qemu: agent: use g_auto in qemuAgentGetInterfaces
  qemu: agent: remove cleanup in qemuAgentGetInterfaces
  qemuAgentGetInterfaceAddresses: turn ifname into char*
  qemu: agent: rename tmp_iface to iface_obj
  qemuAgentGetInterfaceOneAddress: check for errors early
  qemu: agent: split out qemuAgentGetAllInterfaceAddresses

 src/qemu/qemu_agent.c | 355 +-
 1 file changed, 180 insertions(+), 175 deletions(-)

-- 
2.26.2