I was looking at Actor.scala, which contains SimpleActor, SimplestActor, 
TypedActor, GenericActor, and ForwardableActor.
Some people will say, once you know what something does, who cares what it's 
called? But names can really make a difference in learning curve, memorization, 
and code readability.
Other than ForwardableActor, do these names reflect what they do?
My suggestions:
Change  SimpleActor  to  Messageable (it only defines an abstract ! method; 
arguably more general than an actor)
SimplestActor  to  AnyMessageable (it's SimpleActor with Any for T)
TypedActor  to  RespondingActor etc. (what it adds is !? and !! methods)
GenericActor  to  AnyRespondingActor (or could it be replaced by 
'RespondingActor with AnyMessageable'?)
ForwardableActor  to  ForwardingActor (it doesn't get forwarded, it forwards 
messages)
Thoughts?

Thanks.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Lift" group.
To post to this group, send email to liftweb@googlegroups.com
To unsubscribe from this group, send email to 
liftweb+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/liftweb?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to