Re: [PATCH 0/6] sysfs-part2 Add seed device representation on the sysfs

2015-08-06 Thread David Sterba
On Thu, Aug 06, 2015 at 05:51:16AM +0800, Anand Jain wrote:
...
   these can go in.
 
 Btrfs: sysfs: support seed devices in the sysfs layout
 
  Sorry for late reply, the patches look good. I'm going to prepare a
  branch for pull into 4.3. Thanks.
 
 I suggested if this can wait.
 on the 2nd thought, I am preparing to conduct a survey to know most 
 preferred sysfs layout for btrfs.
   mainly between
   one, less invasive overlays on the existing layout (current method).
   the other, separates FS and Volume attributes (old method).
 
   sorry that I am going back a bit, but i think its worth as these API 
 are forever.

Understood.
--
To unsubscribe from this list: send the line unsubscribe linux-btrfs in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 0/6] sysfs-part2 Add seed device representation on the sysfs

2015-08-05 Thread David Sterba
On Wed, Jul 08, 2015 at 03:32:48PM +0800, Anand Jain wrote:
 This patch adds the support to show seed device on the btrfs sysfs.
 This is a revamped version of the previously single patch 6/6, and plus
 incorporates David suggestion to add seed fsid under the 'seed' kobject.
 
 Since this adds new patches and to bring in seed kobject it needed
 quite a lot of revamp I am resetting the patch set version to 1.
 
 Anand Jain (6):
   Btrfs: rename btrfs_sysfs_add_one to btrfs_sysfs_add_mounted
   Btrfs: rename btrfs_sysfs_remove_one to btrfs_sysfs_remove_mounted
   Btrfs: rename btrfs_kobj_add_device to btrfs_sysfs_add_device_link
   Btrfs: rename btrfs_kobj_rm_device to btrfs_sysfs_rm_device_link
   Btrfs: rename super_kobj to fsid_kobj
   Btrfs: sysfs: support seed devices in the sysfs layout

Sorry for late reply, the patches look good. I'm going to prepare a
branch for pull into 4.3. Thanks.
--
To unsubscribe from this list: send the line unsubscribe linux-btrfs in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 0/6] sysfs-part2 Add seed device representation on the sysfs

2015-08-05 Thread Anand Jain


Hi David,

 Thanks. more below.

On 08/06/2015 01:29 AM, David Sterba wrote:

On Wed, Jul 08, 2015 at 03:32:48PM +0800, Anand Jain wrote:

This patch adds the support to show seed device on the btrfs sysfs.
This is a revamped version of the previously single patch 6/6, and plus
incorporates David suggestion to add seed fsid under the 'seed' kobject.

Since this adds new patches and to bring in seed kobject it needed
quite a lot of revamp I am resetting the patch set version to 1.

Anand Jain (6):
   Btrfs: rename btrfs_sysfs_add_one to btrfs_sysfs_add_mounted
   Btrfs: rename btrfs_sysfs_remove_one to btrfs_sysfs_remove_mounted
   Btrfs: rename btrfs_kobj_add_device to btrfs_sysfs_add_device_link
   Btrfs: rename btrfs_kobj_rm_device to btrfs_sysfs_rm_device_link
   Btrfs: rename super_kobj to fsid_kobj


 these can go in.


   Btrfs: sysfs: support seed devices in the sysfs layout


Sorry for late reply, the patches look good. I'm going to prepare a
branch for pull into 4.3. Thanks.


I suggested if this can wait.
on the 2nd thought, I am preparing to conduct a survey to know most 
preferred sysfs layout for btrfs.

 mainly between
 one, less invasive overlays on the existing layout (current method).
 the other, separates FS and Volume attributes (old method).

 sorry that I am going back a bit, but i think its worth as these API 
are forever.


thanks, Anand
--
To unsubscribe from this list: send the line unsubscribe linux-btrfs in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 0/6] sysfs-part2 Add seed device representation on the sysfs

2015-07-08 Thread Anand Jain
This patch adds the support to show seed device on the btrfs sysfs.
This is a revamped version of the previously single patch 6/6, and plus
incorporates David suggestion to add seed fsid under the 'seed' kobject.

Since this adds new patches and to bring in seed kobject it needed
quite a lot of revamp I am resetting the patch set version to 1.

Anand Jain (6):
  Btrfs: rename btrfs_sysfs_add_one to btrfs_sysfs_add_mounted
  Btrfs: rename btrfs_sysfs_remove_one to btrfs_sysfs_remove_mounted
  Btrfs: rename btrfs_kobj_add_device to btrfs_sysfs_add_device_link
  Btrfs: rename btrfs_kobj_rm_device to btrfs_sysfs_rm_device_link
  Btrfs: rename super_kobj to fsid_kobj
  Btrfs: sysfs: support seed devices in the sysfs layout

 fs/btrfs/ctree.h   |   4 +-
 fs/btrfs/dev-replace.c |   7 +-
 fs/btrfs/disk-io.c |  12 ++--
 fs/btrfs/sysfs.c   | 190 +++--
 fs/btrfs/sysfs.h   |  16 +++--
 fs/btrfs/volumes.c |  26 +++
 fs/btrfs/volumes.h |   3 +-
 7 files changed, 188 insertions(+), 70 deletions(-)

-- 
2.4.1

--
To unsubscribe from this list: send the line unsubscribe linux-btrfs in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html