Re: [PATCH] i2c: designware: Add support for AMD Seattle I2C

2016-01-03 Thread Suravee Suthikulpanit

Hi Wolfram,

On 01/03/2016 12:45 PM, Wolfram Sang wrote:

On Wed, Dec 16, 2015 at 06:49:59PM -0600, Suravee Suthikulanit wrote:

Mika,

On 12/16/2015 8:54 AM, Mika Westerberg wrote:

On Wed, Dec 16, 2015 at 08:29:38AM -0600, Suravee Suthikulpanit wrote:



On 12/16/2015 03:16 AM, Mika Westerberg wrote:

On Tue, Dec 15, 2015 at 08:14:34PM -0600, Suravee Suthikulpanit wrote:

Hi Mika,

On 12/15/15 15:55, Suravee Suthikulpanit wrote:

Add device HID AMDI0510 to match the I2C controlers on AMD Seattle platform

Signed-off-by: Suravee Suthikulpanit
---
  drivers/i2c/busses/i2c-designware-platdrv.c | 1 +
  1 file changed, 1 insertion(+)

diff --git a/drivers/i2c/busses/i2c-designware-platdrv.c 
b/drivers/i2c/busses/i2c-designware-platdrv.c
index 57f623b..a027154 100644
--- a/drivers/i2c/busses/i2c-designware-platdrv.c
+++ b/drivers/i2c/busses/i2c-designware-platdrv.c
@@ -117,6 +117,7 @@ static const struct acpi_device_id dw_i2c_acpi_match[] = {
{ "80860F41", 0 },
{ "808622C1", 0 },
{ "AMD0010", 0 },
+   { "AMDI0510", 0 },
{ }


Since this driver seems to be used by several SOCs, and we have been adding
the HID from various SOC vendors. Do you think it would be better to assign
a CID so that each SOC vendor can specify in their ACPI DSDT and we can
match them here?


Sure _CID would work here.


Do you know if Synopsys has already provided a CID that we can use for this?

No.


If not, who do you think should provide this?

Why can't you make _CID for AMD part only? For Intel we are going to get
new IDs for every major SoC release no matter what.


Actually, after discussed with the team. We have decided to go with the
AMDI0510 at this point, and we will reuse this as CID in future SOC if it
contains compatible I2C controller.


So, can I take the patch as is?



Yes, please pull this as is.

Thank you,
Suravee
--
To unsubscribe from this list: send the line "unsubscribe linux-i2c" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v2 0/2] i2c:dw: Add APM X-Gene ACPI I2C device support

2016-01-03 Thread Loc Ho
Hi,

On Sat, Jan 2, 2016 at 4:54 PM, Rafael J. Wysocki  wrote:
> On Thursday, December 10, 2015 02:19:15 PM Loc Ho wrote:
>> Add APM X-Gene ACPI I2C device support. These patches follow
>> the same implementation as AMD I2C driver - changes in ACPI APD
>> and Designware I2C drivers.
>>
>> v2:
>> * Spilt the acpi_apd change with defines for AMD and X-Gene I2C's
>>
>> Signed-off-by: Loc Ho 
>> ---
>> Loc Ho (2):
>>   acpi:apd: Add APM X-Gene ACPI I2C device support
>>   i2c:dw: Add APM X-Gene ACPI I2C device support
>
> Both patches applied, thanks!
>

Thanks...

-Loc
--
To unsubscribe from this list: send the line "unsubscribe linux-i2c" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 2/2] dts: MT2701: add i2c dts info for MT2701

2016-01-03 Thread Liguo Zhang
Add i2c dtsi node for MT2701.

Signed-off-by: Liguo Zhang 
---
 arch/arm/boot/dts/mt2701.dtsi | 42 ++
 1 file changed, 42 insertions(+)

diff --git a/arch/arm/boot/dts/mt2701.dtsi b/arch/arm/boot/dts/mt2701.dtsi
index bd88ae9..bb34770 100644
--- a/arch/arm/boot/dts/mt2701.dtsi
+++ b/arch/arm/boot/dts/mt2701.dtsi
@@ -159,6 +159,48 @@
  <0 0x10216000 0 0x2000>;
};
 
+   i2c0: i2c@11007000 {
+   compatible = "mediatek,mt2701-i2c",
+"mediatek,mt6577-i2c";
+   reg = <0 0x11007000 0 0x70>,
+ <0 0x11000200 0 0x80>;
+   interrupts = ;
+   clock-div = <16>;
+   clocks = < CLK_PERI_I2C0>, < CLK_PERI_AP_DMA>;
+   clock-names = "main", "dma";
+   #address-cells = <1>;
+   #size-cells = <0>;
+   status = "disabled";
+   };
+
+   i2c1: i2c@11008000 {
+   compatible = "mediatek,mt2701-i2c",
+"mediatek,mt6577-i2c";
+   reg = <0 0x11008000 0 0x70>,
+ <0 0x11000280 0 0x80>;
+   interrupts = ;
+   clock-div = <16>;
+   clocks = < CLK_PERI_I2C1>, < CLK_PERI_AP_DMA>;
+   clock-names = "main", "dma";
+   #address-cells = <1>;
+   #size-cells = <0>;
+   status = "disabled";
+   };
+
+   i2c2: i2c@11009000 {
+   compatible = "mediatek,mt2701-i2c",
+"mediatek,mt6577-i2c";
+   reg = <0 0x11009000 0 0x70>,
+ <0 0x11000300 0 0x80>;
+   interrupts = ;
+   clock-div = <16>;
+   clocks = < CLK_PERI_I2C2>, < CLK_PERI_AP_DMA>;
+   clock-names = "main", "dma";
+   #address-cells = <1>;
+   #size-cells = <0>;
+   status = "disabled";
+   };
+
uart0: serial@11002000 {
compatible = "mediatek,mt2701-uart",
 "mediatek,mt6577-uart";
-- 
1.8.1.1.dirty

--
To unsubscribe from this list: send the line "unsubscribe linux-i2c" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 1/2] Document: i2c: Add a dt binding for mediatek MT2701 soc

2016-01-03 Thread Liguo Zhang
Add a dt binding for the MT2701 soc.

Signed-off-by: Liguo Zhang 
---
 Documentation/devicetree/bindings/i2c/i2c-mt6577.txt | 11 ++-
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/Documentation/devicetree/bindings/i2c/i2c-mt6577.txt 
b/Documentation/devicetree/bindings/i2c/i2c-mt6577.txt
index 0ce6fa3..ef22ecf 100644
--- a/Documentation/devicetree/bindings/i2c/i2c-mt6577.txt
+++ b/Documentation/devicetree/bindings/i2c/i2c-mt6577.txt
@@ -4,11 +4,12 @@ The Mediatek's I2C controller is used to interface with I2C 
devices.
 
 Required properties:
   - compatible: value should be either of the following.
-  (a) "mediatek,mt6577-i2c", for i2c compatible with mt6577 i2c.
-  (b) "mediatek,mt6589-i2c", for i2c compatible with mt6589 i2c.
-  (c) "mediatek,mt8127-i2c", for i2c compatible with mt8127 i2c.
-  (d) "mediatek,mt8135-i2c", for i2c compatible with mt8135 i2c.
-  (e) "mediatek,mt8173-i2c", for i2c compatible with mt8173 i2c.
+   "mediatek,mt2701-i2c", for i2c compatible with mt2701 i2c.
+   "mediatek,mt6577-i2c", for i2c compatible with mt6577 i2c.
+   "mediatek,mt6589-i2c", for i2c compatible with mt6589 i2c.
+   "mediatek,mt8127-i2c", for i2c compatible with mt8127 i2c.
+   "mediatek,mt8135-i2c", for i2c compatible with mt8135 i2c.
+   "mediatek,mt8173-i2c", for i2c compatible with mt8173 i2c.
   - reg: physical base address of the controller and dma base, length of memory
 mapped region.
   - interrupts: interrupt number to the cpu.
-- 
1.8.1.1.dirty

--
To unsubscribe from this list: send the line "unsubscribe linux-i2c" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [Patch V10] i2c: imx: add runtime pm support to improve the performance

2016-01-03 Thread Wolfram Sang
On Fri, Dec 11, 2015 at 10:24:09AM +0800, Gao Pan wrote:
> In our former i2c driver, i2c clk is enabled and disabled in
> xfer function, which contributes to power saving. However,
> the clk enable process brings a busy wait delay until the core
> is stable. As a result, the performance is sacrificed.
> 
> To weigh the power consumption and i2c bus performance, runtime
> pm is the good solution for it. The clk is enabled when a i2c
> transfer starts, and disabled after a specifically defined delay.
> 
> If CONFIG_PM is disabled the net result of this patch is that the
> clock is never disabled.
> 
> Without the patch the test case (many eeprom reads) executes with approx:
> real 1m7.735s
> user 0m0.488s
> sys 0m20.040s
> 
> With the patch the same test case (many eeprom reads) executes with approx:
> real 0m54.241s
> user 0m0.440s
> sys 0m5.920s
> 
> Signed-off-by: Fugang Duan 
> Signed-off-by: Gao Pan 
> Acked-by: Uwe Kleine-König 

Applied to for-next, thanks! Also much thanks to Uwe and Heiner for the
reviews of all these versions!



signature.asc
Description: Digital signature


Re: [Patch V1] i2c: imx: improve code readability

2016-01-03 Thread Wolfram Sang
On Mon, Nov 02, 2015 at 05:05:30PM +0800, Gao Pan wrote:
> Replace of_get_named_gpio_flags with of_get_named_gpio because
> the latter has less parameters, which improves code readability.
> 
> Signed-off-by: Fugang Duan 
> Signed-off-by: Gao Pan 

Applied to for-next, thanks!



signature.asc
Description: Digital signature


Re: [PATCH 1/2] i2c: imx: Improve message log when DMA is not used

2016-01-03 Thread Wolfram Sang
On Sun, Nov 01, 2015 at 02:22:51PM -0200, Fabio Estevam wrote:
> From: Fabio Estevam 
> 
> When DMA cannot be used, it is better to state that the I2C controller
> will operate in PIO mode.
> 
> Signed-off-by: Fabio Estevam 

Applied to for-next, thanks!



signature.asc
Description: Digital signature


Re: [PATCH v3] i2c: mediatek: fix i2c multi transfer issue in high speed mode

2016-01-03 Thread Wolfram Sang
On Tue, Dec 15, 2015 at 03:22:26PM +0800, Liguo Zhang wrote:
> For mt8173 platform with auto restart support, when doing i2c multi
> transfer in high speed, we should ignore the first restart irq after
> the master code, otherwise the first transfer will be discarded.
> 
> Signed-off-by: Liguo Zhang 
> Reviewed-by: Eddie Huang 

Applied to for-next, thanks!



signature.asc
Description: Digital signature


Re: [PATCH] i2c: designware: Add support for AMD Seattle I2C

2016-01-03 Thread Wolfram Sang
On Wed, Dec 16, 2015 at 06:49:59PM -0600, Suravee Suthikulanit wrote:
> Mika,
> 
> On 12/16/2015 8:54 AM, Mika Westerberg wrote:
> >On Wed, Dec 16, 2015 at 08:29:38AM -0600, Suravee Suthikulpanit wrote:
> >>>
> >>>
> >>>On 12/16/2015 03:16 AM, Mika Westerberg wrote:
>  >On Tue, Dec 15, 2015 at 08:14:34PM -0600, Suravee Suthikulpanit wrote:
> > >>Hi Mika,
> > >>
> > >>On 12/15/15 15:55, Suravee Suthikulpanit wrote:
> >> >>>Add device HID AMDI0510 to match the I2C controlers on AMD Seattle 
> >> >>>platform
> >> >>>
> >> >>>Signed-off-by: Suravee Suthikulpanit
> >> >>>---
> >> >>>  drivers/i2c/busses/i2c-designware-platdrv.c | 1 +
> >> >>>  1 file changed, 1 insertion(+)
> >> >>>
> >> >>>diff --git a/drivers/i2c/busses/i2c-designware-platdrv.c 
> >> >>>b/drivers/i2c/busses/i2c-designware-platdrv.c
> >> >>>index 57f623b..a027154 100644
> >> >>>--- a/drivers/i2c/busses/i2c-designware-platdrv.c
> >> >>>+++ b/drivers/i2c/busses/i2c-designware-platdrv.c
> >> >>>@@ -117,6 +117,7 @@ static const struct acpi_device_id 
> >> >>>dw_i2c_acpi_match[] = {
> >> >>>{ "80860F41", 0 },
> >> >>>{ "808622C1", 0 },
> >> >>>{ "AMD0010", 0 },
> >> >>>+   { "AMDI0510", 0 },
> >> >>>{ }
> > >>
> > >>Since this driver seems to be used by several SOCs, and we have been 
> > >>adding
> > >>the HID from various SOC vendors. Do you think it would be better to 
> > >>assign
> > >>a CID so that each SOC vendor can specify in their ACPI DSDT and we 
> > >>can
> > >>match them here?
>  >
>  >Sure _CID would work here.
> >>>
> >>>Do you know if Synopsys has already provided a CID that we can use for 
> >>>this?
> >No.
> >
> >>>If not, who do you think should provide this?
> >Why can't you make _CID for AMD part only? For Intel we are going to get
> >new IDs for every major SoC release no matter what.
> >
> Actually, after discussed with the team. We have decided to go with the
> AMDI0510 at this point, and we will reuse this as CID in future SOC if it
> contains compatible I2C controller.

So, can I take the patch as is?



signature.asc
Description: Digital signature


Re: [V1, 1/2] i2c: brcmstb: Adding support for CM and DSL SoCs

2016-01-03 Thread Wolfram Sang
On Wed, Dec 16, 2015 at 03:49:09PM -0500, Kamal Dasu wrote:
> Broadcoms DSL, CM (cable modem)and STB I2C core implementation have
> 8 data in/out registers that can transfer 8 bytes or 32 bytes max.
> Cable and DSL "Peripheral" i2c cores use single byte per data
> register and the STB can use 4 byte per data register transfer.
> Adding support to take care of this difference. Accordingly added
> the compatible string for SoCs using the "Peripheral" I2C block.
> 
> Signed-off-by: Kamal Dasu 

Squashed both patches and applied to for-next, thanks!



signature.asc
Description: Digital signature


Re: [PATCH 04/10] i2c: st: use to_platform_device()

2016-01-03 Thread Wolfram Sang
On Sun, Dec 27, 2015 at 09:15:42PM +0800, Geliang Tang wrote:
> Use to_platform_device() instead of open-coding it.
> 
> Signed-off-by: Geliang Tang 

Applied to for-next, thanks!



signature.asc
Description: Digital signature


Re: [PATCH 3/9] i2c: designware: use to_pci_dev()

2016-01-03 Thread Wolfram Sang
On Sun, Dec 27, 2015 at 06:45:59PM +0800, Geliang Tang wrote:
> Use to_pci_dev() instead of open-coding it.
> 
> Signed-off-by: Geliang Tang 

Applied to for-next, thanks!



signature.asc
Description: Digital signature