Re: [GIT PULL] xfs: new features for 5.3

2019-07-13 Thread Linus Torvalds
On Fri, Jul 12, 2019 at 9:07 PM Darrick J. Wong  wrote:
>
> Doh, it turns out I was merging against the same HEAD as my last two
> pull requests because I forgot to re-pull.  Sorry about that.  It's been
> too long of a week. :/

Heh, no problem, I was just surprised when my merge result didn't
match expectations.

As mentioned, it wasn't like the conflict was complicated, only unexpected.

 Linus


Re: [GIT PULL] xfs: new features for 5.3

2019-07-12 Thread Darrick J. Wong
On Fri, Jul 12, 2019 at 05:27:15PM -0700, Linus Torvalds wrote:
> On Fri, Jul 12, 2019 at 11:02 AM Darrick J. Wong  wrote:
> >
> > The branch merges cleanly against this morning's HEAD and survived an
> > overnight run of xfstests.  The merge was completely straightforward, so
> > please let me know if you run into anything weird.
> 
> Hmm. I don't know what you merged against, but it got a (fairly
> trivial) conflict for me due to
> 
>   79d08f89bb1b ("block: fix .bi_size overflow")
> 
> from the block merge (from Tuesday) touching a line next to one changed by
> 
>   a24737359667 ("xfs: simplify xfs_chain_bio")
> 
> from this pull.
> 
> So it wasn't an entirely clean merge for me.
> 
> Was it a complex merge conflict? No. I'm just confused by the "merges
> cleanly against this morning's HEAD", which makes me wonder what you
> tried to merge against..

Doh, it turns out I was merging against the same HEAD as my last two
pull requests because I forgot to re-pull.  Sorry about that.  It's been
too long of a week. :/

--D

> Linus


Re: [GIT PULL] xfs: new features for 5.3

2019-07-12 Thread pr-tracker-bot
The pull request you sent on Fri, 12 Jul 2019 11:02:05 -0700:

> git://git.kernel.org/pub/scm/fs/xfs/xfs-linux.git tags/xfs-5.3-merge-12

has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/4ce9d181ebe53abbca5f450b8a2984b8c3a38f26

Thank you!

-- 
Deet-doot-dot, I am a bot.
https://korg.wiki.kernel.org/userdoc/prtracker


Re: [GIT PULL] xfs: new features for 5.3

2019-07-12 Thread Linus Torvalds
On Fri, Jul 12, 2019 at 11:02 AM Darrick J. Wong  wrote:
>
> The branch merges cleanly against this morning's HEAD and survived an
> overnight run of xfstests.  The merge was completely straightforward, so
> please let me know if you run into anything weird.

Hmm. I don't know what you merged against, but it got a (fairly
trivial) conflict for me due to

  79d08f89bb1b ("block: fix .bi_size overflow")

from the block merge (from Tuesday) touching a line next to one changed by

  a24737359667 ("xfs: simplify xfs_chain_bio")

from this pull.

So it wasn't an entirely clean merge for me.

Was it a complex merge conflict? No. I'm just confused by the "merges
cleanly against this morning's HEAD", which makes me wonder what you
tried to merge against..

Linus


[GIT PULL] xfs: new features for 5.3

2019-07-12 Thread Darrick J. Wong
Hi Linus,

Here's all the new code for the 5.3 merge window.  In this release there
are a significant amounts of consolidations and cleanups in the log
code; restructuring of the log to issue struct bios directly; new
bulkstat ioctls to return v5 fs inode information (and fix all the
padding problems of the old ioctl); the beginnings of multithreaded
inode walks (e.g. quotacheck); and a reduction in memory usage in the
online scrub code leading to reduced runtimes.

The branch merges cleanly against this morning's HEAD and survived an
overnight run of xfstests.  The merge was completely straightforward, so
please let me know if you run into anything weird.

--D

The following changes since commit d1fdb6d8f6a4109a4263176c84b899076a5f8008:

  Linux 5.2-rc4 (2019-06-08 20:24:46 -0700)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/fs/xfs/xfs-linux.git tags/xfs-5.3-merge-12

for you to fetch changes up to 488ca3d8d088ec4658c87aaec6a91e98acccdd54:

  xfs: chain bios the right way around in xfs_rw_bdev (2019-07-10 10:04:16 
-0700)


New stuff for 5.3:
- Refactor inode geometry calculation into a single structure instead of
  open-coding pieces everywhere.
- Add online repair to build options.
- Remove unnecessary function call flags and functions.
- Claim maintainership of various loose xfs documentation and header
  files.
- Use struct bio directly for log buffer IOs instead of struct xfs_buf.
- Reduce log item boilerplate code requirements.
- Merge log item code spread across too many files.
- Further distinguish between log item commits and cancellations.
- Various small cleanups to the ag small allocator.
- Support cgroup-aware writeback
- libxfs refactoring for mkfs cleanup
- Remove unneeded #includes
- Fix a memory allocation miscalculation in the new log bio code
- Fix bisection problems
- Fix a crash in ioend processing caused by tripping over freeing of
  preallocated transactions
- Split out a generic inode walk mechanism from the bulkstat code, hook
  up all the internal users to use the walking code, then clean up
  bulkstat to serve only the bulkstat ioctls.
- Add a multithreaded iwalk implementation to speed up quotacheck on
  fast storage with many CPUs.
- Remove unnecessary return values in logging teardown functions.
- Supplement the bstat and inogrp structures with new bulkstat and
  inumbers structures that have all the fields we need for v5
  filesystem features and none of the padding problems of their
  predecessors.
- Wire up new ioctls that use the new structures with a much simpler
  bulk_ireq structure at the head instead of the pointerhappy mess we
  had before.
- Enable userspace to constrain bulkstat returns to a single AG or a
  single special inode so that we can phase out a lot of geometry
  guesswork in userspace.
- Reduce memory consumption and zeroing overhead in extended attribute
  scrub code.
- Fix some behavioral regressions in the new bulkstat backend code.
- Fix some behavioral regressions in the new log bio code.


Amir Goldstein (7):
  vfs: introduce generic_file_rw_checks()
  vfs: remove redundant checks from generic_remap_checks()
  vfs: add missing checks to copy_file_range
  vfs: introduce file_modified() helper
  xfs: use file_modified() helper
  vfs: allow copy_file_range to copy across devices
  fuse: copy_file_range needs to strip setuid bits and update timestamps

Brian Foster (4):
  xfs: clean up small allocation helper
  xfs: move small allocation helper
  xfs: skip small alloc cntbt logic on NULL cursor
  xfs: always update params on small allocation

Christoph Hellwig (54):
  xfs: merge xfs_buf_zero and xfs_buf_iomove
  xfs: remove the debug-only q_transp field from struct xfs_dquot
  xfs: remove the no-op spinlock_destroy stub
  xfs: remove the never used _XBF_COMPOUND flag
  xfs: renumber XBF_WRITE_FAIL
  xfs: make mem_to_page available outside of xfs_buf.c
  xfs: remove the l_iclog_size_log field from struct xlog
  xfs: cleanup xlog_get_iclog_buffer_size
  xfs: reformat xlog_get_lowest_lsn
  xfs: remove XLOG_STATE_IOABORT
  xfs: don't use REQ_PREFLUSH for split log writes
  xfs: factor out log buffer writing from xlog_sync
  xfs: factor out splitting of an iclog from xlog_sync
  xfs: factor out iclog size calculation from xlog_sync
  xfs: update both stat counters together in xlog_sync
  xfs: remove the syncing argument from xlog_verify_iclog
  xfs: make use of the l_targ field in struct xlog
  xfs: use bios directly to write log buffers
  xfs: move the log ioend workqueue to struct xlog
  xfs: return an offset instead of a pointer from xlog_align
  xfs: use bios directly to read and write the log recovery buffers
  xfs: stop using bp naming for log recovery buffers