Re: [PATCH][next] block: bio: Use struct_size() in kmalloc()

2020-06-20 Thread Jens Axboe
On 6/19/20 6:49 PM, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.

Applied, thanks.

-- 
Jens Axboe



[PATCH][next] block: bio: Use struct_size() in kmalloc()

2020-06-19 Thread Gustavo A. R. Silva
Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes.

This code was detected with the help of Coccinelle and, audited and
fixed manually.

Addresses-KSPP-ID: https://github.com/KSPP/linux/issues/83
Signed-off-by: Gustavo A. R. Silva 
---
 block/bio.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/block/bio.c b/block/bio.c
index a7366c02c9b5..fb5533416fa6 100644
--- a/block/bio.c
+++ b/block/bio.c
@@ -444,9 +444,7 @@ struct bio *bio_alloc_bioset(gfp_t gfp_mask, unsigned int 
nr_iovecs,
if (nr_iovecs > UIO_MAXIOV)
return NULL;
 
-   p = kmalloc(sizeof(struct bio) +
-   nr_iovecs * sizeof(struct bio_vec),
-   gfp_mask);
+   p = kmalloc(struct_size(bio, bi_inline_vecs, nr_iovecs), 
gfp_mask);
front_pad = 0;
inline_vecs = nr_iovecs;
} else {
-- 
2.27.0