Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Sasha Levin
On 11/12/2012 10:23 AM, Russell King - ARM Linux wrote:
> On Mon, Nov 12, 2012 at 04:12:29PM +0100, Maarten Lankhorst wrote:
>> Op 08-11-12 21:23, Sasha Levin schreef:
>>> @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
>>> combiner_nr, unsigned int i
>>> else
>>> max_nr = EXYNOS4_MAX_COMBINER_NR;
>>>  
>>> -   if (combiner_nr >= max_nr)
>>> -   BUG();
>>> -   if (irq_set_handler_data(irq, _data[combiner_nr]) != 0)
>>> -   BUG();
>>> +   BUG_ON(combiner_nr >= max_nr);
>>> +   BUG_ON(irq_set_handler_data(irq, _data[combiner_nr]) != 0);
>>
>> Is it really a good idea to put functions that perform work in a BUG_ON?
>> I don't know, but for some reason it just feels wrong. I'd expect code to
>> compile fine if BUG_ON was a noop, so doing verification calls only, not
>> actual work..
> 
> Well, it is currently defined as:
> 
> include/asm-generic/bug.h:#define BUG_ON(condition) do { if 
> (unlikely(condition)) BUG(); } while(0)
> include/asm-generic/bug.h:#define BUG_ON(condition) do { if (condition) ; } 
> while(0)
> 
> but as these can be overridden, I don't think relying on those
> implementations is a good idea; to do so would be fragile.  Eg, what if
> the BUG_ON() implementation becomes just:
> 
> #define BUG_ON(x)
> 
> then the function call itself vanishes.  So, only put the actual bug test
> inside a BUG_ON(), not the functional part which must always be executed.

Even if we ignore that modifying the side-effects is wrong, there's already
more than enough code in the kernel (both in kernel/ / mm/, and in arch/) to
cause breakage if for some reason the expression is not evaluated.

If some arch decides to not evaluate the expression there it's going to be
inherently broken.


Thanks,
Sasha


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Sasha Levin
On 11/12/2012 10:12 AM, Maarten Lankhorst wrote:
> Op 08-11-12 21:23, Sasha Levin schreef:
>> Just use BUG_ON() instead of constructions such as:
>>
>>  if (...)
>>  BUG()
>>
>> A simplified version of the semantic patch that makes this transformation
>> is as follows: (http://coccinelle.lip6.fr/)
>>
>> // 
>> @@
>> expression e;
>> @@
>> - if (e) BUG();
>> + BUG_ON(e);
>> // 
>>
>> Signed-off-by: Sasha Levin 
>> ---
>>  arch/arm/mach-exynos/common.c |6 ++
>>  1 file changed, 2 insertions(+), 4 deletions(-)
>>
>> diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c
>> index 4e577f6..6a55a5a 100644
>> --- a/arch/arm/mach-exynos/common.c
>> +++ b/arch/arm/mach-exynos/common.c
>> @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
>> combiner_nr, unsigned int i
>>  else
>>  max_nr = EXYNOS4_MAX_COMBINER_NR;
>>  
>> -if (combiner_nr >= max_nr)
>> -BUG();
>> -if (irq_set_handler_data(irq, _data[combiner_nr]) != 0)
>> -BUG();
>> +BUG_ON(combiner_nr >= max_nr);
>> +BUG_ON(irq_set_handler_data(irq, _data[combiner_nr]) != 0);
> Is it really a good idea to put functions that perform work in a BUG_ON?
> I don't know, but for some reason it just feels wrong. I'd expect code to
> compile fine if BUG_ON was a noop, so doing verification calls only, not
> actual work..

You can't modify the side-effects of a macro based on kernel configuration. If
we're evaluating the expression when BUG_ON() is enabled, you must also evaluate
the expression when BUG_ON() is not enabled (HAVE_ARCH_BUG_ON is not set).

The only reason I'd not include function calls in a BUG_ON() call is due to
readability considerations. In this case it looked okay to me, but if someone
thinks that getting the function call into the BUG_ON() complicated things I'm
fine with skipping that.


Thanks,
Sasha
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Russell King - ARM Linux
On Mon, Nov 12, 2012 at 04:12:29PM +0100, Maarten Lankhorst wrote:
> Op 08-11-12 21:23, Sasha Levin schreef:
> > @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
> > combiner_nr, unsigned int i
> > else
> > max_nr = EXYNOS4_MAX_COMBINER_NR;
> >  
> > -   if (combiner_nr >= max_nr)
> > -   BUG();
> > -   if (irq_set_handler_data(irq, _data[combiner_nr]) != 0)
> > -   BUG();
> > +   BUG_ON(combiner_nr >= max_nr);
> > +   BUG_ON(irq_set_handler_data(irq, _data[combiner_nr]) != 0);
>
> Is it really a good idea to put functions that perform work in a BUG_ON?
> I don't know, but for some reason it just feels wrong. I'd expect code to
> compile fine if BUG_ON was a noop, so doing verification calls only, not
> actual work..

Well, it is currently defined as:

include/asm-generic/bug.h:#define BUG_ON(condition) do { if 
(unlikely(condition)) BUG(); } while(0)
include/asm-generic/bug.h:#define BUG_ON(condition) do { if (condition) ; } 
while(0)

but as these can be overridden, I don't think relying on those
implementations is a good idea; to do so would be fragile.  Eg, what if
the BUG_ON() implementation becomes just:

#define BUG_ON(x)

then the function call itself vanishes.  So, only put the actual bug test
inside a BUG_ON(), not the functional part which must always be executed.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Maarten Lankhorst
Op 08-11-12 21:23, Sasha Levin schreef:
> Just use BUG_ON() instead of constructions such as:
>
>   if (...)
>   BUG()
>
> A simplified version of the semantic patch that makes this transformation
> is as follows: (http://coccinelle.lip6.fr/)
>
> // 
> @@
> expression e;
> @@
> - if (e) BUG();
> + BUG_ON(e);
> // 
>
> Signed-off-by: Sasha Levin 
> ---
>  arch/arm/mach-exynos/common.c |6 ++
>  1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c
> index 4e577f6..6a55a5a 100644
> --- a/arch/arm/mach-exynos/common.c
> +++ b/arch/arm/mach-exynos/common.c
> @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
> combiner_nr, unsigned int i
>   else
>   max_nr = EXYNOS4_MAX_COMBINER_NR;
>  
> - if (combiner_nr >= max_nr)
> - BUG();
> - if (irq_set_handler_data(irq, _data[combiner_nr]) != 0)
> - BUG();
> + BUG_ON(combiner_nr >= max_nr);
> + BUG_ON(irq_set_handler_data(irq, _data[combiner_nr]) != 0);
Is it really a good idea to put functions that perform work in a BUG_ON?
I don't know, but for some reason it just feels wrong. I'd expect code to
compile fine if BUG_ON was a noop, so doing verification calls only, not
actual work..

~Maarten
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Maarten Lankhorst
Op 08-11-12 21:23, Sasha Levin schreef:
 Just use BUG_ON() instead of constructions such as:

   if (...)
   BUG()

 A simplified version of the semantic patch that makes this transformation
 is as follows: (http://coccinelle.lip6.fr/)

 // smpl
 @@
 expression e;
 @@
 - if (e) BUG();
 + BUG_ON(e);
 // /smpl

 Signed-off-by: Sasha Levin sasha.le...@oracle.com
 ---
  arch/arm/mach-exynos/common.c |6 ++
  1 file changed, 2 insertions(+), 4 deletions(-)

 diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c
 index 4e577f6..6a55a5a 100644
 --- a/arch/arm/mach-exynos/common.c
 +++ b/arch/arm/mach-exynos/common.c
 @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
 combiner_nr, unsigned int i
   else
   max_nr = EXYNOS4_MAX_COMBINER_NR;
  
 - if (combiner_nr = max_nr)
 - BUG();
 - if (irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0)
 - BUG();
 + BUG_ON(combiner_nr = max_nr);
 + BUG_ON(irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0);
Is it really a good idea to put functions that perform work in a BUG_ON?
I don't know, but for some reason it just feels wrong. I'd expect code to
compile fine if BUG_ON was a noop, so doing verification calls only, not
actual work..

~Maarten
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Russell King - ARM Linux
On Mon, Nov 12, 2012 at 04:12:29PM +0100, Maarten Lankhorst wrote:
 Op 08-11-12 21:23, Sasha Levin schreef:
  @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
  combiner_nr, unsigned int i
  else
  max_nr = EXYNOS4_MAX_COMBINER_NR;
   
  -   if (combiner_nr = max_nr)
  -   BUG();
  -   if (irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0)
  -   BUG();
  +   BUG_ON(combiner_nr = max_nr);
  +   BUG_ON(irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0);

 Is it really a good idea to put functions that perform work in a BUG_ON?
 I don't know, but for some reason it just feels wrong. I'd expect code to
 compile fine if BUG_ON was a noop, so doing verification calls only, not
 actual work..

Well, it is currently defined as:

include/asm-generic/bug.h:#define BUG_ON(condition) do { if 
(unlikely(condition)) BUG(); } while(0)
include/asm-generic/bug.h:#define BUG_ON(condition) do { if (condition) ; } 
while(0)

but as these can be overridden, I don't think relying on those
implementations is a good idea; to do so would be fragile.  Eg, what if
the BUG_ON() implementation becomes just:

#define BUG_ON(x)

then the function call itself vanishes.  So, only put the actual bug test
inside a BUG_ON(), not the functional part which must always be executed.
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Sasha Levin
On 11/12/2012 10:12 AM, Maarten Lankhorst wrote:
 Op 08-11-12 21:23, Sasha Levin schreef:
 Just use BUG_ON() instead of constructions such as:

  if (...)
  BUG()

 A simplified version of the semantic patch that makes this transformation
 is as follows: (http://coccinelle.lip6.fr/)

 // smpl
 @@
 expression e;
 @@
 - if (e) BUG();
 + BUG_ON(e);
 // /smpl

 Signed-off-by: Sasha Levin sasha.le...@oracle.com
 ---
  arch/arm/mach-exynos/common.c |6 ++
  1 file changed, 2 insertions(+), 4 deletions(-)

 diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c
 index 4e577f6..6a55a5a 100644
 --- a/arch/arm/mach-exynos/common.c
 +++ b/arch/arm/mach-exynos/common.c
 @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
 combiner_nr, unsigned int i
  else
  max_nr = EXYNOS4_MAX_COMBINER_NR;
  
 -if (combiner_nr = max_nr)
 -BUG();
 -if (irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0)
 -BUG();
 +BUG_ON(combiner_nr = max_nr);
 +BUG_ON(irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0);
 Is it really a good idea to put functions that perform work in a BUG_ON?
 I don't know, but for some reason it just feels wrong. I'd expect code to
 compile fine if BUG_ON was a noop, so doing verification calls only, not
 actual work..

You can't modify the side-effects of a macro based on kernel configuration. If
we're evaluating the expression when BUG_ON() is enabled, you must also evaluate
the expression when BUG_ON() is not enabled (HAVE_ARCH_BUG_ON is not set).

The only reason I'd not include function calls in a BUG_ON() call is due to
readability considerations. In this case it looked okay to me, but if someone
thinks that getting the function call into the BUG_ON() complicated things I'm
fine with skipping that.


Thanks,
Sasha
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-12 Thread Sasha Levin
On 11/12/2012 10:23 AM, Russell King - ARM Linux wrote:
 On Mon, Nov 12, 2012 at 04:12:29PM +0100, Maarten Lankhorst wrote:
 Op 08-11-12 21:23, Sasha Levin schreef:
 @@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
 combiner_nr, unsigned int i
 else
 max_nr = EXYNOS4_MAX_COMBINER_NR;
  
 -   if (combiner_nr = max_nr)
 -   BUG();
 -   if (irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0)
 -   BUG();
 +   BUG_ON(combiner_nr = max_nr);
 +   BUG_ON(irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0);

 Is it really a good idea to put functions that perform work in a BUG_ON?
 I don't know, but for some reason it just feels wrong. I'd expect code to
 compile fine if BUG_ON was a noop, so doing verification calls only, not
 actual work..
 
 Well, it is currently defined as:
 
 include/asm-generic/bug.h:#define BUG_ON(condition) do { if 
 (unlikely(condition)) BUG(); } while(0)
 include/asm-generic/bug.h:#define BUG_ON(condition) do { if (condition) ; } 
 while(0)
 
 but as these can be overridden, I don't think relying on those
 implementations is a good idea; to do so would be fragile.  Eg, what if
 the BUG_ON() implementation becomes just:
 
 #define BUG_ON(x)
 
 then the function call itself vanishes.  So, only put the actual bug test
 inside a BUG_ON(), not the functional part which must always be executed.

Even if we ignore that modifying the side-effects is wrong, there's already
more than enough code in the kernel (both in kernel/ / mm/, and in arch/) to
cause breakage if for some reason the expression is not evaluated.

If some arch decides to not evaluate the expression there it's going to be
inherently broken.


Thanks,
Sasha


--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-08 Thread Sasha Levin
Just use BUG_ON() instead of constructions such as:

if (...)
BUG()

A simplified version of the semantic patch that makes this transformation
is as follows: (http://coccinelle.lip6.fr/)

// 
@@
expression e;
@@
- if (e) BUG();
+ BUG_ON(e);
// 

Signed-off-by: Sasha Levin 
---
 arch/arm/mach-exynos/common.c |6 ++
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c
index 4e577f6..6a55a5a 100644
--- a/arch/arm/mach-exynos/common.c
+++ b/arch/arm/mach-exynos/common.c
@@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
combiner_nr, unsigned int i
else
max_nr = EXYNOS4_MAX_COMBINER_NR;
 
-   if (combiner_nr >= max_nr)
-   BUG();
-   if (irq_set_handler_data(irq, _data[combiner_nr]) != 0)
-   BUG();
+   BUG_ON(combiner_nr >= max_nr);
+   BUG_ON(irq_set_handler_data(irq, _data[combiner_nr]) != 0);
irq_set_chained_handler(irq, combiner_handle_cascade_irq);
 }
 
-- 
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] ARM: EXYNOS: use BUG_ON where possible

2012-11-08 Thread Sasha Levin
Just use BUG_ON() instead of constructions such as:

if (...)
BUG()

A simplified version of the semantic patch that makes this transformation
is as follows: (http://coccinelle.lip6.fr/)

// smpl
@@
expression e;
@@
- if (e) BUG();
+ BUG_ON(e);
// /smpl

Signed-off-by: Sasha Levin sasha.le...@oracle.com
---
 arch/arm/mach-exynos/common.c |6 ++
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/arch/arm/mach-exynos/common.c b/arch/arm/mach-exynos/common.c
index 4e577f6..6a55a5a 100644
--- a/arch/arm/mach-exynos/common.c
+++ b/arch/arm/mach-exynos/common.c
@@ -465,10 +465,8 @@ static void __init combiner_cascade_irq(unsigned int 
combiner_nr, unsigned int i
else
max_nr = EXYNOS4_MAX_COMBINER_NR;
 
-   if (combiner_nr = max_nr)
-   BUG();
-   if (irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0)
-   BUG();
+   BUG_ON(combiner_nr = max_nr);
+   BUG_ON(irq_set_handler_data(irq, combiner_data[combiner_nr]) != 0);
irq_set_chained_handler(irq, combiner_handle_cascade_irq);
 }
 
-- 
1.7.10.4

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/