Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2019-01-28 Thread Gustavo A. R. Silva



On 1/28/19 11:26 PM, Amit Kucheria wrote:
> On Mon, Dec 24, 2018 at 11:52 AM Gustavo A. R. Silva
>  wrote:
>>
>> One of the more common cases of allocation size calculations is finding
>> the size of a structure that has a zero-sized array at the end, along
>> with memory for some number of elements for that array. For example:
>>
>> struct foo {
>> int stuff;
>> void *entry[];
>> };
>>
>> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>>
>> Instead of leaving these open-coded and prone to type mistakes, we can
>> now use the new struct_size() helper:
>>
>> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>>
>> This issue was detected with the help of Coccinelle.
>>
>> Signed-off-by: Gustavo A. R. Silva 
> 
> Reviewed-by: Amit Kucheria 
> 

Thanks, Amit.

--
Gustavo

>> ---
>>  drivers/soc/qcom/rpmh.c | 3 +--
>>  1 file changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
>> index c7beb6841289..12c057a0b325 100644
>> --- a/drivers/soc/qcom/rpmh.c
>> +++ b/drivers/soc/qcom/rpmh.c
>> @@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
>> rpmh_state state,
>> if (!count)
>> return -EINVAL;
>>
>> -   req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
>> - GFP_ATOMIC);
>> +   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
>> if (!req)
>> return -ENOMEM;
>> req->count = count;
>> --
>> 2.17.0
>>


Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2019-01-28 Thread Amit Kucheria
On Mon, Dec 24, 2018 at 11:52 AM Gustavo A. R. Silva
 wrote:
>
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>
> This issue was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva 

Reviewed-by: Amit Kucheria 

> ---
>  drivers/soc/qcom/rpmh.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
> index c7beb6841289..12c057a0b325 100644
> --- a/drivers/soc/qcom/rpmh.c
> +++ b/drivers/soc/qcom/rpmh.c
> @@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
> rpmh_state state,
> if (!count)
> return -EINVAL;
>
> -   req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
> - GFP_ATOMIC);
> +   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
> if (!req)
> return -ENOMEM;
> req->count = count;
> --
> 2.17.0
>


Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2019-01-28 Thread Gustavo A. R. Silva
Hi all,

Friendly ping:

Who can take this?

Thanks
--
Gustavo

On 1/9/19 11:38 AM, Gustavo A. R. Silva wrote:
> Hi,
> 
> Friendly ping:
> 
> Who can ack or review this patch, please?
> 
> Thanks
> -- 
> Gustavo
> 
> 
> On 12/24/18 12:22 AM, Gustavo A. R. Silva wrote:
>> One of the more common cases of allocation size calculations is finding
>> the size of a structure that has a zero-sized array at the end, along
>> with memory for some number of elements for that array. For example:
>>
>> struct foo {
>>  int stuff;
>>  void *entry[];
>> };
>>
>> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>>
>> Instead of leaving these open-coded and prone to type mistakes, we can
>> now use the new struct_size() helper:
>>
>> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>>
>> This issue was detected with the help of Coccinelle.
>>
>> Signed-off-by: Gustavo A. R. Silva 
>> ---
>>   drivers/soc/qcom/rpmh.c | 3 +--
>>   1 file changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
>> index c7beb6841289..12c057a0b325 100644
>> --- a/drivers/soc/qcom/rpmh.c
>> +++ b/drivers/soc/qcom/rpmh.c
>> @@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
>> rpmh_state state,
>>   if (!count)
>>   return -EINVAL;
>>   -    req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
>> -  GFP_ATOMIC);
>> +    req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
>>   if (!req)
>>   return -ENOMEM;
>>   req->count = count;
>>


Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2019-01-09 Thread Gustavo A. R. Silva

Hi,

Friendly ping:

Who can ack or review this patch, please?

Thanks
--
Gustavo


On 12/24/18 12:22 AM, Gustavo A. R. Silva wrote:

One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
 int stuff;
 void *entry[];
};

instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva 
---
  drivers/soc/qcom/rpmh.c | 3 +--
  1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
index c7beb6841289..12c057a0b325 100644
--- a/drivers/soc/qcom/rpmh.c
+++ b/drivers/soc/qcom/rpmh.c
@@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
rpmh_state state,
if (!count)
return -EINVAL;
  
-	req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),

- GFP_ATOMIC);
+   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
if (!req)
return -ENOMEM;
req->count = count;



[PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2018-12-23 Thread Gustavo A. R. Silva
One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
int stuff;
void *entry[];
};

instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva 
---
 drivers/soc/qcom/rpmh.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
index c7beb6841289..12c057a0b325 100644
--- a/drivers/soc/qcom/rpmh.c
+++ b/drivers/soc/qcom/rpmh.c
@@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
rpmh_state state,
if (!count)
return -EINVAL;
 
-   req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
- GFP_ATOMIC);
+   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
if (!req)
return -ENOMEM;
req->count = count;
-- 
2.17.0



Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2018-09-03 Thread Bjorn Andersson
On Thu 23 Aug 18:17 PDT 2018, Gustavo A. R. Silva wrote:

> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
> 
> struct foo {
>   int stuff;
> void *entry[];
> };
> 
> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_ATOMIC);
> 
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
> 
> instance = kzalloc(struct_size(instance, entry, count), GFP_ATOMIC);
> 
> This issue was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva 

Reviewed-by: Bjorn Andersson 

Regards,
Bjorn

> ---
>  drivers/soc/qcom/rpmh.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
> index c7beb68..12c057a 100644
> --- a/drivers/soc/qcom/rpmh.c
> +++ b/drivers/soc/qcom/rpmh.c
> @@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
> rpmh_state state,
>   if (!count)
>   return -EINVAL;
>  
> - req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
> -   GFP_ATOMIC);
> + req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
>   if (!req)
>   return -ENOMEM;
>   req->count = count;
> -- 
> 2.7.4
> 


Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2018-09-03 Thread Bjorn Andersson
On Thu 23 Aug 18:17 PDT 2018, Gustavo A. R. Silva wrote:

> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
> 
> struct foo {
>   int stuff;
> void *entry[];
> };
> 
> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_ATOMIC);
> 
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
> 
> instance = kzalloc(struct_size(instance, entry, count), GFP_ATOMIC);
> 
> This issue was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva 

Reviewed-by: Bjorn Andersson 

Regards,
Bjorn

> ---
>  drivers/soc/qcom/rpmh.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
> index c7beb68..12c057a 100644
> --- a/drivers/soc/qcom/rpmh.c
> +++ b/drivers/soc/qcom/rpmh.c
> @@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
> rpmh_state state,
>   if (!count)
>   return -EINVAL;
>  
> - req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
> -   GFP_ATOMIC);
> + req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
>   if (!req)
>   return -ENOMEM;
>   req->count = count;
> -- 
> 2.7.4
> 


Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2018-08-23 Thread Kees Cook
On Thu, Aug 23, 2018 at 6:17 PM, Gustavo A. R. Silva
 wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_ATOMIC);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = kzalloc(struct_size(instance, entry, count), GFP_ATOMIC);
>
> This issue was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva 

Reviewed-by: Kees Cook 

-Kees

> ---
>  drivers/soc/qcom/rpmh.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
> index c7beb68..12c057a 100644
> --- a/drivers/soc/qcom/rpmh.c
> +++ b/drivers/soc/qcom/rpmh.c
> @@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
> rpmh_state state,
> if (!count)
> return -EINVAL;
>
> -   req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
> - GFP_ATOMIC);
> +   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
> if (!req)
> return -ENOMEM;
> req->count = count;
> --
> 2.7.4
>



-- 
Kees Cook
Pixel Security


Re: [PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2018-08-23 Thread Kees Cook
On Thu, Aug 23, 2018 at 6:17 PM, Gustavo A. R. Silva
 wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_ATOMIC);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = kzalloc(struct_size(instance, entry, count), GFP_ATOMIC);
>
> This issue was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva 

Reviewed-by: Kees Cook 

-Kees

> ---
>  drivers/soc/qcom/rpmh.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
> index c7beb68..12c057a 100644
> --- a/drivers/soc/qcom/rpmh.c
> +++ b/drivers/soc/qcom/rpmh.c
> @@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
> rpmh_state state,
> if (!count)
> return -EINVAL;
>
> -   req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
> - GFP_ATOMIC);
> +   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
> if (!req)
> return -ENOMEM;
> req->count = count;
> --
> 2.7.4
>



-- 
Kees Cook
Pixel Security


[PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2018-08-23 Thread Gustavo A. R. Silva
One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
int stuff;
void *entry[];
};

instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_ATOMIC);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = kzalloc(struct_size(instance, entry, count), GFP_ATOMIC);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva 
---
 drivers/soc/qcom/rpmh.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
index c7beb68..12c057a 100644
--- a/drivers/soc/qcom/rpmh.c
+++ b/drivers/soc/qcom/rpmh.c
@@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
rpmh_state state,
if (!count)
return -EINVAL;
 
-   req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
- GFP_ATOMIC);
+   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
if (!req)
return -ENOMEM;
req->count = count;
-- 
2.7.4



[PATCH] drivers: qcom: rpmh: use struct_size() in kzalloc()

2018-08-23 Thread Gustavo A. R. Silva
One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
int stuff;
void *entry[];
};

instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_ATOMIC);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = kzalloc(struct_size(instance, entry, count), GFP_ATOMIC);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva 
---
 drivers/soc/qcom/rpmh.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/soc/qcom/rpmh.c b/drivers/soc/qcom/rpmh.c
index c7beb68..12c057a 100644
--- a/drivers/soc/qcom/rpmh.c
+++ b/drivers/soc/qcom/rpmh.c
@@ -362,8 +362,7 @@ int rpmh_write_batch(const struct device *dev, enum 
rpmh_state state,
if (!count)
return -EINVAL;
 
-   req = kzalloc(sizeof(*req) + count * sizeof(req->rpm_msgs[0]),
- GFP_ATOMIC);
+   req = kzalloc(struct_size(req, rpm_msgs, count), GFP_ATOMIC);
if (!req)
return -ENOMEM;
req->count = count;
-- 
2.7.4