Re: [PATCH] fscache: replace open-coded pr_warn_once() with actual call

2020-07-06 Thread David Howells
Jason A. Donenfeld  wrote:

> There's no reason to open code this here, so instead replace it with
> pr_warn_once, which amounts to exactly the same thing.

Note that this file is set to be entirely deleted here:


https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/linux-fs.git/log/?h=fscache-iter

David



[PATCH] fscache: replace open-coded pr_warn_once() with actual call

2020-07-05 Thread Jason A. Donenfeld
There's no reason to open code this here, so instead replace it with
pr_warn_once, which amounts to exactly the same thing.

Signed-off-by: Jason A. Donenfeld 
---
 fs/fscache/page.c | 11 +++
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/fs/fscache/page.c b/fs/fscache/page.c
index 26af6fdf1538..dc8dce79fa8d 100644
--- a/fs/fscache/page.c
+++ b/fs/fscache/page.c
@@ -1173,14 +1173,9 @@ void fscache_mark_page_cached(struct fscache_retrieval 
*op, struct page *page)
trace_fscache_page(cookie, page, fscache_page_cached);
 
_debug("- mark %p{%lx}", page, page->index);
-   if (TestSetPageFsCache(page)) {
-   static bool once_only;
-   if (!once_only) {
-   once_only = true;
-   pr_warn("Cookie type %s marked page %lx multiple 
times\n",
-   cookie->def->name, page->index);
-   }
-   }
+   if (TestSetPageFsCache(page))
+   pr_warn_once("Cookie type %s marked page %lx multiple times\n",
+cookie->def->name, page->index);
 
if (cookie->def->mark_page_cached)
cookie->def->mark_page_cached(cookie->netfs_data,
-- 
2.27.0