Re: [PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-12 Thread Chen Gang
On 7/12/16 12:20, Michael Ellerman wrote:
> Chen Gang  writes:
> 
>> On 7/11/16 07:47, Dave Hansen wrote:
>>> On 07/09/2016 09:29 AM, cheng...@emindsoft.com.cn wrote:
 -static inline int arch_validate_prot(unsigned long prot)
 +static inline bool arch_validate_prot(unsigned long prot)
  {
if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
 -  return 0;
 -  if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
 -  return 0;
 -  return 1;
 +  return false;
 +  return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
  }
  #define arch_validate_prot(prot) arch_validate_prot(prot)
>>>
>>> Please don't do things like this.  They're not obviously correct and
>>> also have no obvious benefit.  You also don't mention why you bothered
>>> to alter the logical structure of these checks.
>>>
>>
>> For all cases, bool is equal or a little better than int, and they are
>> equal in our case (2 final outputs are same). So for me, it may belong
>> to trivial patch, which can be skipped by the normal patch maintainers.
>>
>> As a 'trivial' patch:
>>
>>  - For a pure Boolean function, bool return value is more readable than
>>int.
> 
> Agreed.
> 
> Please send a patch that does that and only that.
> 

OK, thanks.

After check the assembly output, for some cases, merging 3 lines to 1
line may be a little more readable, but compiler will generate a little
bad output code.

I shall send patch v2 for it within this weekend.

Thanks.
-- 
Chen Gang (陈刚)

Managing Natural Environments is the Duty of Human Beings.


Re: [PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-12 Thread Chen Gang
On 7/12/16 12:20, Michael Ellerman wrote:
> Chen Gang  writes:
> 
>> On 7/11/16 07:47, Dave Hansen wrote:
>>> On 07/09/2016 09:29 AM, cheng...@emindsoft.com.cn wrote:
 -static inline int arch_validate_prot(unsigned long prot)
 +static inline bool arch_validate_prot(unsigned long prot)
  {
if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
 -  return 0;
 -  if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
 -  return 0;
 -  return 1;
 +  return false;
 +  return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
  }
  #define arch_validate_prot(prot) arch_validate_prot(prot)
>>>
>>> Please don't do things like this.  They're not obviously correct and
>>> also have no obvious benefit.  You also don't mention why you bothered
>>> to alter the logical structure of these checks.
>>>
>>
>> For all cases, bool is equal or a little better than int, and they are
>> equal in our case (2 final outputs are same). So for me, it may belong
>> to trivial patch, which can be skipped by the normal patch maintainers.
>>
>> As a 'trivial' patch:
>>
>>  - For a pure Boolean function, bool return value is more readable than
>>int.
> 
> Agreed.
> 
> Please send a patch that does that and only that.
> 

OK, thanks.

After check the assembly output, for some cases, merging 3 lines to 1
line may be a little more readable, but compiler will generate a little
bad output code.

I shall send patch v2 for it within this weekend.

Thanks.
-- 
Chen Gang (陈刚)

Managing Natural Environments is the Duty of Human Beings.


Re: [PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-11 Thread Chen Gang

On 7/11/16 07:47, Dave Hansen wrote:
> On 07/09/2016 09:29 AM, cheng...@emindsoft.com.cn wrote:
>> -static inline int arch_validate_prot(unsigned long prot)
>> +static inline bool arch_validate_prot(unsigned long prot)
>>  {
>>  if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
>> -return 0;
>> -if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
>> -return 0;
>> -return 1;
>> +return false;
>> +return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
>>  }
>>  #define arch_validate_prot(prot) arch_validate_prot(prot)
> 
> Please don't do things like this.  They're not obviously correct and
> also have no obvious benefit.  You also don't mention why you bothered
> to alter the logical structure of these checks.
> 

For all cases, bool is equal or a little better than int, and they are
equal in our case (2 final outputs are same). So for me, it may belong
to trivial patch, which can be skipped by the normal patch maintainers.

As a 'trivial' patch:

 - For a pure Boolean function, bool return value is more readable than
   int.

 - If one statement can express the same expression, and is as simple as
   the original 'if' statement, one statement is better than 3 original
   statements.

 - In our case:

if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
return 0;
return 1;

   equal to:

return !((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO));

   equal to:

return !(prot & PROT_SAO) || !!cpu_has_feature(CPU_FTR_SAO);

   then:

return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);

Thanks
-- 
Chen Gang (陈刚)

Managing Natural Environments is the Duty of Human Beings.


Re: [PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-11 Thread Chen Gang

On 7/11/16 07:47, Dave Hansen wrote:
> On 07/09/2016 09:29 AM, cheng...@emindsoft.com.cn wrote:
>> -static inline int arch_validate_prot(unsigned long prot)
>> +static inline bool arch_validate_prot(unsigned long prot)
>>  {
>>  if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
>> -return 0;
>> -if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
>> -return 0;
>> -return 1;
>> +return false;
>> +return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
>>  }
>>  #define arch_validate_prot(prot) arch_validate_prot(prot)
> 
> Please don't do things like this.  They're not obviously correct and
> also have no obvious benefit.  You also don't mention why you bothered
> to alter the logical structure of these checks.
> 

For all cases, bool is equal or a little better than int, and they are
equal in our case (2 final outputs are same). So for me, it may belong
to trivial patch, which can be skipped by the normal patch maintainers.

As a 'trivial' patch:

 - For a pure Boolean function, bool return value is more readable than
   int.

 - If one statement can express the same expression, and is as simple as
   the original 'if' statement, one statement is better than 3 original
   statements.

 - In our case:

if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
return 0;
return 1;

   equal to:

return !((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO));

   equal to:

return !(prot & PROT_SAO) || !!cpu_has_feature(CPU_FTR_SAO);

   then:

return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);

Thanks
-- 
Chen Gang (陈刚)

Managing Natural Environments is the Duty of Human Beings.


Re: [PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-10 Thread Dave Hansen
On 07/09/2016 09:29 AM, cheng...@emindsoft.com.cn wrote:
> -static inline int arch_validate_prot(unsigned long prot)
> +static inline bool arch_validate_prot(unsigned long prot)
>  {
>   if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
> - return 0;
> - if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
> - return 0;
> - return 1;
> + return false;
> + return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
>  }
>  #define arch_validate_prot(prot) arch_validate_prot(prot)

Please don't do things like this.  They're not obviously correct and
also have no obvious benefit.  You also don't mention why you bothered
to alter the logical structure of these checks.


Re: [PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-10 Thread Dave Hansen
On 07/09/2016 09:29 AM, cheng...@emindsoft.com.cn wrote:
> -static inline int arch_validate_prot(unsigned long prot)
> +static inline bool arch_validate_prot(unsigned long prot)
>  {
>   if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
> - return 0;
> - if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
> - return 0;
> - return 1;
> + return false;
> + return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
>  }
>  #define arch_validate_prot(prot) arch_validate_prot(prot)

Please don't do things like this.  They're not obviously correct and
also have no obvious benefit.  You also don't mention why you bothered
to alter the logical structure of these checks.


[PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-09 Thread chengang
From: Chen Gang 

For pure bool function's return value, bool is a little better more or
less than int.

And return boolean result directly. Since 'if' statement is also for
boolean checking, and return boolean result, too.

Signed-off-by: Chen Gang 
---
 arch/powerpc/include/asm/mman.h | 8 +++-
 include/linux/mman.h| 2 +-
 2 files changed, 4 insertions(+), 6 deletions(-)

diff --git a/arch/powerpc/include/asm/mman.h b/arch/powerpc/include/asm/mman.h
index 2563c43..62e1f47 100644
--- a/arch/powerpc/include/asm/mman.h
+++ b/arch/powerpc/include/asm/mman.h
@@ -31,13 +31,11 @@ static inline pgprot_t arch_vm_get_page_prot(unsigned long 
vm_flags)
 }
 #define arch_vm_get_page_prot(vm_flags) arch_vm_get_page_prot(vm_flags)
 
-static inline int arch_validate_prot(unsigned long prot)
+static inline bool arch_validate_prot(unsigned long prot)
 {
if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
-   return 0;
-   if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
-   return 0;
-   return 1;
+   return false;
+   return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
 }
 #define arch_validate_prot(prot) arch_validate_prot(prot)
 
diff --git a/include/linux/mman.h b/include/linux/mman.h
index 33e17f6..634c4c5 100644
--- a/include/linux/mman.h
+++ b/include/linux/mman.h
@@ -49,7 +49,7 @@ static inline void vm_unacct_memory(long pages)
  *
  * Returns true if the prot flags are valid
  */
-static inline int arch_validate_prot(unsigned long prot)
+static inline bool arch_validate_prot(unsigned long prot)
 {
return (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM)) == 0;
 }
-- 
1.9.3



[PATCH] include: mman: Use bool instead of int for the return value of arch_validate_prot

2016-07-09 Thread chengang
From: Chen Gang 

For pure bool function's return value, bool is a little better more or
less than int.

And return boolean result directly. Since 'if' statement is also for
boolean checking, and return boolean result, too.

Signed-off-by: Chen Gang 
---
 arch/powerpc/include/asm/mman.h | 8 +++-
 include/linux/mman.h| 2 +-
 2 files changed, 4 insertions(+), 6 deletions(-)

diff --git a/arch/powerpc/include/asm/mman.h b/arch/powerpc/include/asm/mman.h
index 2563c43..62e1f47 100644
--- a/arch/powerpc/include/asm/mman.h
+++ b/arch/powerpc/include/asm/mman.h
@@ -31,13 +31,11 @@ static inline pgprot_t arch_vm_get_page_prot(unsigned long 
vm_flags)
 }
 #define arch_vm_get_page_prot(vm_flags) arch_vm_get_page_prot(vm_flags)
 
-static inline int arch_validate_prot(unsigned long prot)
+static inline bool arch_validate_prot(unsigned long prot)
 {
if (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM | PROT_SAO))
-   return 0;
-   if ((prot & PROT_SAO) && !cpu_has_feature(CPU_FTR_SAO))
-   return 0;
-   return 1;
+   return false;
+   return (prot & PROT_SAO) == 0 || cpu_has_feature(CPU_FTR_SAO);
 }
 #define arch_validate_prot(prot) arch_validate_prot(prot)
 
diff --git a/include/linux/mman.h b/include/linux/mman.h
index 33e17f6..634c4c5 100644
--- a/include/linux/mman.h
+++ b/include/linux/mman.h
@@ -49,7 +49,7 @@ static inline void vm_unacct_memory(long pages)
  *
  * Returns true if the prot flags are valid
  */
-static inline int arch_validate_prot(unsigned long prot)
+static inline bool arch_validate_prot(unsigned long prot)
 {
return (prot & ~(PROT_READ | PROT_WRITE | PROT_EXEC | PROT_SEM)) == 0;
 }
-- 
1.9.3