Re: [PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type

2015-10-13 Thread Lee Jones
On Fri, 09 Oct 2015, Axel Lin wrote:

> Rename get_device_type() to da9062_get_device_type().
> This function is only used in this file so make it static.
> 
> Signed-off-by: Axel Lin 
> ---
>  drivers/mfd/da9062-core.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied, thanks.

> diff --git a/drivers/mfd/da9062-core.c b/drivers/mfd/da9062-core.c
> index f80d947..a9ad024 100644
> --- a/drivers/mfd/da9062-core.c
> +++ b/drivers/mfd/da9062-core.c
> @@ -198,7 +198,7 @@ static int da9062_clear_fault_log(struct da9062 *chip)
>   return ret;
>  }
>  
> -int get_device_type(struct da9062 *chip)
> +static int da9062_get_device_type(struct da9062 *chip)
>  {
>   int device_id, variant_id, variant_mrc;
>   int ret;
> @@ -466,7 +466,7 @@ static int da9062_i2c_probe(struct i2c_client *i2c,
>   if (ret < 0)
>   dev_warn(chip->dev, "Cannot clear fault log\n");
>  
> - ret = get_device_type(chip);
> + ret = da9062_get_device_type(chip);
>   if (ret)
>   return ret;
>  

-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type

2015-10-13 Thread Lee Jones
On Fri, 09 Oct 2015, Axel Lin wrote:

> Rename get_device_type() to da9062_get_device_type().
> This function is only used in this file so make it static.
> 
> Signed-off-by: Axel Lin 
> ---
>  drivers/mfd/da9062-core.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied, thanks.

> diff --git a/drivers/mfd/da9062-core.c b/drivers/mfd/da9062-core.c
> index f80d947..a9ad024 100644
> --- a/drivers/mfd/da9062-core.c
> +++ b/drivers/mfd/da9062-core.c
> @@ -198,7 +198,7 @@ static int da9062_clear_fault_log(struct da9062 *chip)
>   return ret;
>  }
>  
> -int get_device_type(struct da9062 *chip)
> +static int da9062_get_device_type(struct da9062 *chip)
>  {
>   int device_id, variant_id, variant_mrc;
>   int ret;
> @@ -466,7 +466,7 @@ static int da9062_i2c_probe(struct i2c_client *i2c,
>   if (ret < 0)
>   dev_warn(chip->dev, "Cannot clear fault log\n");
>  
> - ret = get_device_type(chip);
> + ret = da9062_get_device_type(chip);
>   if (ret)
>   return ret;
>  

-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type

2015-10-09 Thread Axel Lin
Rename get_device_type() to da9062_get_device_type().
This function is only used in this file so make it static.

Signed-off-by: Axel Lin 
---
 drivers/mfd/da9062-core.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/mfd/da9062-core.c b/drivers/mfd/da9062-core.c
index f80d947..a9ad024 100644
--- a/drivers/mfd/da9062-core.c
+++ b/drivers/mfd/da9062-core.c
@@ -198,7 +198,7 @@ static int da9062_clear_fault_log(struct da9062 *chip)
return ret;
 }
 
-int get_device_type(struct da9062 *chip)
+static int da9062_get_device_type(struct da9062 *chip)
 {
int device_id, variant_id, variant_mrc;
int ret;
@@ -466,7 +466,7 @@ static int da9062_i2c_probe(struct i2c_client *i2c,
if (ret < 0)
dev_warn(chip->dev, "Cannot clear fault log\n");
 
-   ret = get_device_type(chip);
+   ret = da9062_get_device_type(chip);
if (ret)
return ret;
 
-- 
2.1.4



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] mfd: da9062-core: Rename get_device_type to da9062_get_device_type

2015-10-09 Thread Axel Lin
Rename get_device_type() to da9062_get_device_type().
This function is only used in this file so make it static.

Signed-off-by: Axel Lin 
---
 drivers/mfd/da9062-core.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/mfd/da9062-core.c b/drivers/mfd/da9062-core.c
index f80d947..a9ad024 100644
--- a/drivers/mfd/da9062-core.c
+++ b/drivers/mfd/da9062-core.c
@@ -198,7 +198,7 @@ static int da9062_clear_fault_log(struct da9062 *chip)
return ret;
 }
 
-int get_device_type(struct da9062 *chip)
+static int da9062_get_device_type(struct da9062 *chip)
 {
int device_id, variant_id, variant_mrc;
int ret;
@@ -466,7 +466,7 @@ static int da9062_i2c_probe(struct i2c_client *i2c,
if (ret < 0)
dev_warn(chip->dev, "Cannot clear fault log\n");
 
-   ret = get_device_type(chip);
+   ret = da9062_get_device_type(chip);
if (ret)
return ret;
 
-- 
2.1.4



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/