[PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-29 Thread Giedrius Rekasius
Local variable "box" gets assigned correct value when it is initialized.
There is no need to assign the same value again. Variable declarations
were reshuffled for better readability.

Signed-off-by: Giedrius Rekasius 
---
Original patch was amended for better readability based on feedback from Walter
Harms and Thomas Gleixner.

 arch/x86/kernel/cpu/perf_event_intel_uncore.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
index 65bbbea..6fe20db 100644
--- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
+++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
@@ -3813,11 +3813,10 @@ static int uncore_pci_probe(struct pci_dev *pdev, const 
struct pci_device_id *id
 
 static void uncore_pci_remove(struct pci_dev *pdev)
 {
+   int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
struct intel_uncore_box *box = pci_get_drvdata(pdev);
struct intel_uncore_pmu *pmu;
-   int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
 
-   box = pci_get_drvdata(pdev);
if (!box) {
for (i = 0; i < UNCORE_EXTRA_PCI_DEV_MAX; i++) {
if (extra_pci_dev[phys_id][i] == pdev) {
-- 
1.9.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] perf/x86/uncore: Remove unnecessary assignment to box in uncore_pci_remove(...)

2014-05-29 Thread Giedrius Rekasius
Local variable box gets assigned correct value when it is initialized.
There is no need to assign the same value again. Variable declarations
were reshuffled for better readability.

Signed-off-by: Giedrius Rekasius giedrius.rekas...@gmail.com
---
Original patch was amended for better readability based on feedback from Walter
Harms and Thomas Gleixner.

 arch/x86/kernel/cpu/perf_event_intel_uncore.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
index 65bbbea..6fe20db 100644
--- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
+++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
@@ -3813,11 +3813,10 @@ static int uncore_pci_probe(struct pci_dev *pdev, const 
struct pci_device_id *id
 
 static void uncore_pci_remove(struct pci_dev *pdev)
 {
+   int i, cpu, phys_id = pcibus_to_physid[pdev-bus-number];
struct intel_uncore_box *box = pci_get_drvdata(pdev);
struct intel_uncore_pmu *pmu;
-   int i, cpu, phys_id = pcibus_to_physid[pdev-bus-number];
 
-   box = pci_get_drvdata(pdev);
if (!box) {
for (i = 0; i  UNCORE_EXTRA_PCI_DEV_MAX; i++) {
if (extra_pci_dev[phys_id][i] == pdev) {
-- 
1.9.3

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread Thomas Gleixner
On Wed, 28 May 2014, walter harms wrote:
> Am 28.05.2014 11:11, schrieb Giedrius Rekasius:
> > Local variable "box" gets assigned correct value when it is initialized.
> > There is no need to assign the same value again.
> > 
> > Signed-off-by: Giedrius Rekasius 
> > ---
> >  arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
> >  1 file changed, 1 deletion(-)
> > 
> > diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
> > b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> > index 65bbbea..8cbbb1b 100644
> > --- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> > +++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> > @@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
> > struct intel_uncore_pmu *pmu;
> > int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
> >  
> > -   box = pci_get_drvdata(pdev);
> > if (!box) {
> > for (i = 0; i < UNCORE_EXTRA_PCI_DEV_MAX; i++) {
> > if (extra_pci_dev[phys_id][i] == pdev) {
> 
> Just a remark,
> for readability it is better to remove the other one.

I rather have stuff reshuffled a bit more:

static void uncore_pci_remove(struct pci_dev *pdev)
{
int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
struct intel_uncore_box *box = pci_get_drvdata(pdev);
struct intel_uncore_pmu *pmu;

if (!box) {

That's less lines and entirely readable.

Thanks,

tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread Giedrius Rekasius
On Wed, May 28, 2014 at 12:16:04PM +0200, walter harms wrote:
> 
> 
> Am 28.05.2014 11:11, schrieb Giedrius Rekasius:
> > Local variable "box" gets assigned correct value when it is initialized.
> > There is no need to assign the same value again.
> > 
> > Signed-off-by: Giedrius Rekasius 
> > ---
> >  arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
> >  1 file changed, 1 deletion(-)
> > 
> > diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
> > b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> > index 65bbbea..8cbbb1b 100644
> > --- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> > +++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> > @@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
> > struct intel_uncore_pmu *pmu;
> > int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
> >  
> > -   box = pci_get_drvdata(pdev);
> > if (!box) {
> > for (i = 0; i < UNCORE_EXTRA_PCI_DEV_MAX; i++) {
> > if (extra_pci_dev[phys_id][i] == pdev) {
> 
> Just a remark,
> for readability it is better to remove the other one.

I could move the declaration itself closer to the if statement while
still keeping whole statement in one line.

On the other hand I'm not so sure if it makes any real difference to
have assignment right next to the if statement compared to a few lines
above it.

Regards,
Giedrius
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread walter harms


Am 28.05.2014 11:11, schrieb Giedrius Rekasius:
> Local variable "box" gets assigned correct value when it is initialized.
> There is no need to assign the same value again.
> 
> Signed-off-by: Giedrius Rekasius 
> ---
>  arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
>  1 file changed, 1 deletion(-)
> 
> diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
> b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> index 65bbbea..8cbbb1b 100644
> --- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> +++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
> @@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
>   struct intel_uncore_pmu *pmu;
>   int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
>  
> - box = pci_get_drvdata(pdev);
>   if (!box) {
>   for (i = 0; i < UNCORE_EXTRA_PCI_DEV_MAX; i++) {
>   if (extra_pci_dev[phys_id][i] == pdev) {

Just a remark,
for readability it is better to remove the other one.

re,
 wh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread Giedrius Rekasius
Local variable "box" gets assigned correct value when it is initialized.
There is no need to assign the same value again.

Signed-off-by: Giedrius Rekasius 
---
 arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
index 65bbbea..8cbbb1b 100644
--- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
+++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
@@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
struct intel_uncore_pmu *pmu;
int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
 
-   box = pci_get_drvdata(pdev);
if (!box) {
for (i = 0; i < UNCORE_EXTRA_PCI_DEV_MAX; i++) {
if (extra_pci_dev[phys_id][i] == pdev) {
-- 
1.9.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to box in uncore_pci_remove(...)

2014-05-28 Thread Thomas Gleixner
On Wed, 28 May 2014, walter harms wrote:
 Am 28.05.2014 11:11, schrieb Giedrius Rekasius:
  Local variable box gets assigned correct value when it is initialized.
  There is no need to assign the same value again.
  
  Signed-off-by: Giedrius Rekasius giedrius.rekas...@gmail.com
  ---
   arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
   1 file changed, 1 deletion(-)
  
  diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
  b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
  index 65bbbea..8cbbb1b 100644
  --- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
  +++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
  @@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
  struct intel_uncore_pmu *pmu;
  int i, cpu, phys_id = pcibus_to_physid[pdev-bus-number];
   
  -   box = pci_get_drvdata(pdev);
  if (!box) {
  for (i = 0; i  UNCORE_EXTRA_PCI_DEV_MAX; i++) {
  if (extra_pci_dev[phys_id][i] == pdev) {
 
 Just a remark,
 for readability it is better to remove the other one.

I rather have stuff reshuffled a bit more:

static void uncore_pci_remove(struct pci_dev *pdev)
{
int i, cpu, phys_id = pcibus_to_physid[pdev-bus-number];
struct intel_uncore_box *box = pci_get_drvdata(pdev);
struct intel_uncore_pmu *pmu;

if (!box) {

That's less lines and entirely readable.

Thanks,

tglx
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] perf/x86/uncore: Remove unnecessary assignment to box in uncore_pci_remove(...)

2014-05-28 Thread Giedrius Rekasius
Local variable box gets assigned correct value when it is initialized.
There is no need to assign the same value again.

Signed-off-by: Giedrius Rekasius giedrius.rekas...@gmail.com
---
 arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
index 65bbbea..8cbbb1b 100644
--- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
+++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
@@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
struct intel_uncore_pmu *pmu;
int i, cpu, phys_id = pcibus_to_physid[pdev-bus-number];
 
-   box = pci_get_drvdata(pdev);
if (!box) {
for (i = 0; i  UNCORE_EXTRA_PCI_DEV_MAX; i++) {
if (extra_pci_dev[phys_id][i] == pdev) {
-- 
1.9.3

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to box in uncore_pci_remove(...)

2014-05-28 Thread walter harms


Am 28.05.2014 11:11, schrieb Giedrius Rekasius:
 Local variable box gets assigned correct value when it is initialized.
 There is no need to assign the same value again.
 
 Signed-off-by: Giedrius Rekasius giedrius.rekas...@gmail.com
 ---
  arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
  1 file changed, 1 deletion(-)
 
 diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
 b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
 index 65bbbea..8cbbb1b 100644
 --- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
 +++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
 @@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
   struct intel_uncore_pmu *pmu;
   int i, cpu, phys_id = pcibus_to_physid[pdev-bus-number];
  
 - box = pci_get_drvdata(pdev);
   if (!box) {
   for (i = 0; i  UNCORE_EXTRA_PCI_DEV_MAX; i++) {
   if (extra_pci_dev[phys_id][i] == pdev) {

Just a remark,
for readability it is better to remove the other one.

re,
 wh
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to box in uncore_pci_remove(...)

2014-05-28 Thread Giedrius Rekasius
On Wed, May 28, 2014 at 12:16:04PM +0200, walter harms wrote:
 
 
 Am 28.05.2014 11:11, schrieb Giedrius Rekasius:
  Local variable box gets assigned correct value when it is initialized.
  There is no need to assign the same value again.
  
  Signed-off-by: Giedrius Rekasius giedrius.rekas...@gmail.com
  ---
   arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 -
   1 file changed, 1 deletion(-)
  
  diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c 
  b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
  index 65bbbea..8cbbb1b 100644
  --- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
  +++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
  @@ -3817,7 +3817,6 @@ static void uncore_pci_remove(struct pci_dev *pdev)
  struct intel_uncore_pmu *pmu;
  int i, cpu, phys_id = pcibus_to_physid[pdev-bus-number];
   
  -   box = pci_get_drvdata(pdev);
  if (!box) {
  for (i = 0; i  UNCORE_EXTRA_PCI_DEV_MAX; i++) {
  if (extra_pci_dev[phys_id][i] == pdev) {
 
 Just a remark,
 for readability it is better to remove the other one.

I could move the declaration itself closer to the if statement while
still keeping whole statement in one line.

On the other hand I'm not so sure if it makes any real difference to
have assignment right next to the if statement compared to a few lines
above it.

Regards,
Giedrius
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/