Re: [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h

2017-09-27 Thread David Miller
From: Corentin Labbe 
Date: Mon, 18 Sep 2017 20:10:36 +0200

> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
> 
> Signed-off-by: Corentin Labbe 

Applied.


[PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h

2017-09-18 Thread Corentin Labbe
This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
It's better that all minor number are in the same place.

Signed-off-by: Corentin Labbe 
---
 drivers/sbus/char/display7seg.c | 1 -
 include/linux/miscdevice.h  | 1 +
 2 files changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
index f32765d3cbd8..5c8ed7350a04 100644
--- a/drivers/sbus/char/display7seg.c
+++ b/drivers/sbus/char/display7seg.c
@@ -22,7 +22,6 @@
 
 #include 
 
-#define D7S_MINOR  193
 #define DRIVER_NAME"d7s"
 #define PFXDRIVER_NAME ": "
 
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
index 58751eae5f77..05c3892b3e92 100644
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -35,6 +35,7 @@
 #define HWRNG_MINOR183
 #define MICROCODE_MINOR184
 #define IRNET_MINOR187
+#define D7S_MINOR  193
 #define VFIO_MINOR 196
 #define TUN_MINOR  200
 #define CUSE_MINOR 203
-- 
2.13.5



Re: [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h

2017-01-10 Thread Greg KH
On Thu, Dec 15, 2016 at 08:47:03PM +0100, Corentin Labbe wrote:
> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
> 
> Signed-off-by: Corentin Labbe 
> ---
>  drivers/sbus/char/display7seg.c | 1 -
>  include/linux/miscdevice.h  | 1 +
>  2 files changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
> index 33fbe82..48a5df0 100644
> --- a/drivers/sbus/char/display7seg.c
> +++ b/drivers/sbus/char/display7seg.c
> @@ -22,7 +22,6 @@
>  
>  #include 
>  
> -#define D7S_MINOR193
>  #define DRIVER_NAME  "d7s"
>  #define PFX  DRIVER_NAME ": "
>  
> diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
> index 5385d95..b1ba37aef 100644
> --- a/include/linux/miscdevice.h
> +++ b/include/linux/miscdevice.h
> @@ -33,6 +33,7 @@
>  #define I2O_MINOR166
>  #define HWRNG_MINOR  183
>  #define MICROCODE_MINOR  184
> +#define D7S_MINOR193
>  #define VFIO_MINOR   196
>  #define TUN_MINOR200
>  #define CUSE_MINOR   203
> -- 

Doesn't apply to my tree :(


Re: [PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h

2016-12-16 Thread Julian Calaby
Hi Corentin,

On Fri, Dec 16, 2016 at 6:47 AM, Corentin Labbe
 wrote:
> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
>
> Signed-off-by: Corentin Labbe 
> ---
>  drivers/sbus/char/display7seg.c | 1 -
>  include/linux/miscdevice.h  | 1 +
>  2 files changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
> index 33fbe82..48a5df0 100644
> --- a/drivers/sbus/char/display7seg.c
> +++ b/drivers/sbus/char/display7seg.c
> @@ -22,7 +22,6 @@
>
>  #include 
>
> -#define D7S_MINOR  193
>  #define DRIVER_NAME"d7s"
>  #define PFXDRIVER_NAME ": "
>
> diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
> index 5385d95..b1ba37aef 100644
> --- a/include/linux/miscdevice.h
> +++ b/include/linux/miscdevice.h
> @@ -33,6 +33,7 @@
>  #define I2O_MINOR  166
>  #define HWRNG_MINOR183
>  #define MICROCODE_MINOR184
> +#define D7S_MINOR  193

I was going to say "why not change the name to something more
descriptive" however they're all very abbreviated, so maybe consider a
second patch series to describe what each of these is for?

>  #define VFIO_MINOR 196
>  #define TUN_MINOR  200
>  #define CUSE_MINOR 203

Thanks,

-- 
Julian Calaby

Email: julian.cal...@gmail.com
Profile: http://www.google.com/profiles/julian.calaby/


[PATCH] sbus: char: Move D7S_MINOR to include/linux/miscdevice.h

2016-12-15 Thread Corentin Labbe
This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
It's better that all minor number are in the same place.

Signed-off-by: Corentin Labbe 
---
 drivers/sbus/char/display7seg.c | 1 -
 include/linux/miscdevice.h  | 1 +
 2 files changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
index 33fbe82..48a5df0 100644
--- a/drivers/sbus/char/display7seg.c
+++ b/drivers/sbus/char/display7seg.c
@@ -22,7 +22,6 @@
 
 #include 
 
-#define D7S_MINOR  193
 #define DRIVER_NAME"d7s"
 #define PFXDRIVER_NAME ": "
 
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
index 5385d95..b1ba37aef 100644
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -33,6 +33,7 @@
 #define I2O_MINOR  166
 #define HWRNG_MINOR183
 #define MICROCODE_MINOR184
+#define D7S_MINOR  193
 #define VFIO_MINOR 196
 #define TUN_MINOR  200
 #define CUSE_MINOR 203
-- 
2.10.2