Re: [PATCH] x86/apic: Fix two typos in comments

2017-01-05 Thread Dou Liyang

Hi, Ingo

At 01/05/2017 04:15 PM, Ingo Molnar wrote:


* Dou Liyang  wrote:


s/inr_logical_cpuidi/nr_logical_cpuids/
s/generic_processor_info()/__generic_processor_info()/

Signed-off-by: Dou Liyang 
---
 arch/x86/kernel/apic/apic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
index 5b7e43e..c32a3ad 100644
--- a/arch/x86/kernel/apic/apic.c
+++ b/arch/x86/kernel/apic/apic.c
@@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
 /*
  * The number of allocated logical CPU IDs. Since logical CPU IDs are allocated
  * contiguously, it equals to current allocated max logical CPU ID plus 1.
- * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum of
+ * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum of


There's another typo in that sentence as well, and the wording should be 
clarified
as well while at it. Something like this would work for me:


+ * All allocated CPU IDs should be in the [0, nr_logical_cpuids) range,
+ * so the maximum of




Yes, It is. :)

Thanks,

Dou




Re: [PATCH] x86/apic: Fix two typos in comments

2017-01-05 Thread Dou Liyang

Hi, Ingo

At 01/05/2017 04:15 PM, Ingo Molnar wrote:


* Dou Liyang  wrote:


s/inr_logical_cpuidi/nr_logical_cpuids/
s/generic_processor_info()/__generic_processor_info()/

Signed-off-by: Dou Liyang 
---
 arch/x86/kernel/apic/apic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
index 5b7e43e..c32a3ad 100644
--- a/arch/x86/kernel/apic/apic.c
+++ b/arch/x86/kernel/apic/apic.c
@@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
 /*
  * The number of allocated logical CPU IDs. Since logical CPU IDs are allocated
  * contiguously, it equals to current allocated max logical CPU ID plus 1.
- * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum of
+ * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum of


There's another typo in that sentence as well, and the wording should be 
clarified
as well while at it. Something like this would work for me:


+ * All allocated CPU IDs should be in the [0, nr_logical_cpuids) range,
+ * so the maximum of




Yes, It is. :)

Thanks,

Dou




Re: [PATCH] x86/apic: Fix two typos in comments

2017-01-05 Thread Ingo Molnar

* Dou Liyang  wrote:

> s/inr_logical_cpuidi/nr_logical_cpuids/
> s/generic_processor_info()/__generic_processor_info()/
> 
> Signed-off-by: Dou Liyang 
> ---
>  arch/x86/kernel/apic/apic.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
> index 5b7e43e..c32a3ad 100644
> --- a/arch/x86/kernel/apic/apic.c
> +++ b/arch/x86/kernel/apic/apic.c
> @@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
>  /*
>   * The number of allocated logical CPU IDs. Since logical CPU IDs are 
> allocated
>   * contiguously, it equals to current allocated max logical CPU ID plus 1.
> - * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum 
> of
> + * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum 
> of

There's another typo in that sentence as well, and the wording should be 
clarified 
as well while at it. Something like this would work for me:

> + * All allocated CPU IDs should be in the [0, nr_logical_cpuids) range,
> + * so the maximum of

Thanks,

Ingo


Re: [PATCH] x86/apic: Fix two typos in comments

2017-01-05 Thread Ingo Molnar

* Dou Liyang  wrote:

> s/inr_logical_cpuidi/nr_logical_cpuids/
> s/generic_processor_info()/__generic_processor_info()/
> 
> Signed-off-by: Dou Liyang 
> ---
>  arch/x86/kernel/apic/apic.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
> index 5b7e43e..c32a3ad 100644
> --- a/arch/x86/kernel/apic/apic.c
> +++ b/arch/x86/kernel/apic/apic.c
> @@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
>  /*
>   * The number of allocated logical CPU IDs. Since logical CPU IDs are 
> allocated
>   * contiguously, it equals to current allocated max logical CPU ID plus 1.
> - * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum 
> of
> + * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum 
> of

There's another typo in that sentence as well, and the wording should be 
clarified 
as well while at it. Something like this would work for me:

> + * All allocated CPU IDs should be in the [0, nr_logical_cpuids) range,
> + * so the maximum of

Thanks,

Ingo


[PATCH] x86/apic: Fix two typos in comments

2016-12-25 Thread Dou Liyang
s/inr_logical_cpuidi/nr_logical_cpuids/
s/generic_processor_info()/__generic_processor_info()/

Signed-off-by: Dou Liyang 
---
 arch/x86/kernel/apic/apic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
index 5b7e43e..c32a3ad 100644
--- a/arch/x86/kernel/apic/apic.c
+++ b/arch/x86/kernel/apic/apic.c
@@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
 /*
  * The number of allocated logical CPU IDs. Since logical CPU IDs are allocated
  * contiguously, it equals to current allocated max logical CPU ID plus 1.
- * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum of
+ * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum of
  * nr_logical_cpuids is nr_cpu_ids.
  *
  * NOTE: Reserve 0 for BSP.
@@ -2094,7 +2094,7 @@ int __generic_processor_info(int apicid, int version, 
bool enabled)
 * Since fixing handling of boot_cpu_physical_apicid requires
 * another discussion and tests on each platform, we leave it
 * for now and here we use read_apic_id() directly in this
-* function, generic_processor_info().
+* function, __generic_processor_info().
 */
if (disabled_cpu_apicid != BAD_APICID &&
disabled_cpu_apicid != read_apic_id() &&
-- 
2.5.5





[PATCH] x86/apic: Fix two typos in comments

2016-12-25 Thread Dou Liyang
s/inr_logical_cpuidi/nr_logical_cpuids/
s/generic_processor_info()/__generic_processor_info()/

Signed-off-by: Dou Liyang 
---
 arch/x86/kernel/apic/apic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
index 5b7e43e..c32a3ad 100644
--- a/arch/x86/kernel/apic/apic.c
+++ b/arch/x86/kernel/apic/apic.c
@@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
 /*
  * The number of allocated logical CPU IDs. Since logical CPU IDs are allocated
  * contiguously, it equals to current allocated max logical CPU ID plus 1.
- * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum of
+ * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum of
  * nr_logical_cpuids is nr_cpu_ids.
  *
  * NOTE: Reserve 0 for BSP.
@@ -2094,7 +2094,7 @@ int __generic_processor_info(int apicid, int version, 
bool enabled)
 * Since fixing handling of boot_cpu_physical_apicid requires
 * another discussion and tests on each platform, we leave it
 * for now and here we use read_apic_id() directly in this
-* function, generic_processor_info().
+* function, __generic_processor_info().
 */
if (disabled_cpu_apicid != BAD_APICID &&
disabled_cpu_apicid != read_apic_id() &&
-- 
2.5.5