From: Konstantin Porotchkin <kos...@marvell.com>

The function name is used for selecting MPP functionality and
should be unique within function names of the same pin.
This patch fixes function names for MPP54 and MPP55 that
have two different functions named the same.

Signed-off-by: Konstantin Porotchkin <kos...@marvell.com>
---
 drivers/pinctrl/mvebu/pinctrl-armada-cp110.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/pinctrl/mvebu/pinctrl-armada-cp110.c 
b/drivers/pinctrl/mvebu/pinctrl-armada-cp110.c
index 17491b27e487..8ba8f3e9121f 100644
--- a/drivers/pinctrl/mvebu/pinctrl-armada-cp110.c
+++ b/drivers/pinctrl/mvebu/pinctrl-armada-cp110.c
@@ -519,13 +519,13 @@ static struct mvebu_mpp_mode armada_cp110_mpp_modes[] = {
                 MPP_FUNCTION(4,        "synce1",       "clk"),
                 MPP_FUNCTION(8,        "led",          "data"),
                 MPP_FUNCTION(10,       "sdio",         "hw_rst"),
-                MPP_FUNCTION(11,       "sdio",         "wr_protect")),
+                MPP_FUNCTION(11,       "sdio_wp",      "wr_protect")),
        MPP_MODE(55,
                 MPP_FUNCTION(0,        "gpio",         NULL),
                 MPP_FUNCTION(1,        "ge1",          "rxctl_rxdv"),
                 MPP_FUNCTION(3,        "ptp",          "pulse"),
                 MPP_FUNCTION(10,       "sdio",         "led"),
-                MPP_FUNCTION(11,       "sdio",         "card_detect")),
+                MPP_FUNCTION(11,       "sdio_cd",      "card_detect")),
        MPP_MODE(56,
                 MPP_FUNCTION(0,        "gpio",         NULL),
                 MPP_FUNCTION(4,        "tdm",          "drx"),
-- 
2.17.1

Reply via email to