Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-09-06 Thread Palmer Dabbelt

On Thu, 30 Aug 2018 09:11:11 PDT (-0700), atish.pa...@wdc.com wrote:

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to
avoid unnecessary conflict.

@Palmer: You can drop this patch.


Thanks!


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-09-06 Thread Palmer Dabbelt

On Fri, 31 Aug 2018 14:18:02 PDT (-0700), atish.pa...@wdc.com wrote:

On 8/30/18 10:54 PM, Christoph Hellwig wrote:

On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote:

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to avoid
unnecessary conflict.

@Palmer: You can drop this patch.


If Palmer is ok with it how about you include a respin of his whole
series?  There are some overlaps I think and having a single person
in charge might be helpful.



Sure. I am fine with it. Palmer ?


Ya, I have no problem with it.




Btw, I've found your series in my linux-kernel folder, but it did
not make it to linux-riscv or my personal inbox despite the CC.



Thanks for the review.
I checked my scripts. I couldn't figure out what went wrong.
Not sure if there was some issue with infradead.org at that time.

Anyways, sorry again for the mess. I will keep a watch on this next time.

Regards,
Atish


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-09-06 Thread Palmer Dabbelt

On Fri, 31 Aug 2018 14:18:02 PDT (-0700), atish.pa...@wdc.com wrote:

On 8/30/18 10:54 PM, Christoph Hellwig wrote:

On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote:

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to avoid
unnecessary conflict.

@Palmer: You can drop this patch.


If Palmer is ok with it how about you include a respin of his whole
series?  There are some overlaps I think and having a single person
in charge might be helpful.



Sure. I am fine with it. Palmer ?


Ya, I have no problem with it.




Btw, I've found your series in my linux-kernel folder, but it did
not make it to linux-riscv or my personal inbox despite the CC.



Thanks for the review.
I checked my scripts. I couldn't figure out what went wrong.
Not sure if there was some issue with infradead.org at that time.

Anyways, sorry again for the mess. I will keep a watch on this next time.

Regards,
Atish


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-09-06 Thread Palmer Dabbelt

On Thu, 30 Aug 2018 09:11:11 PDT (-0700), atish.pa...@wdc.com wrote:

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to
avoid unnecessary conflict.

@Palmer: You can drop this patch.


Thanks!


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-31 Thread Atish Patra

On 8/30/18 10:54 PM, Christoph Hellwig wrote:

On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote:

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to avoid
unnecessary conflict.

@Palmer: You can drop this patch.


If Palmer is ok with it how about you include a respin of his whole
series?  There are some overlaps I think and having a single person
in charge might be helpful.



Sure. I am fine with it. Palmer ?


Btw, I've found your series in my linux-kernel folder, but it did
not make it to linux-riscv or my personal inbox despite the CC.



Thanks for the review.
I checked my scripts. I couldn't figure out what went wrong.
Not sure if there was some issue with infradead.org at that time.

Anyways, sorry again for the mess. I will keep a watch on this next time.

Regards,
Atish


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-31 Thread Atish Patra

On 8/30/18 10:54 PM, Christoph Hellwig wrote:

On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote:

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to avoid
unnecessary conflict.

@Palmer: You can drop this patch.


If Palmer is ok with it how about you include a respin of his whole
series?  There are some overlaps I think and having a single person
in charge might be helpful.



Sure. I am fine with it. Palmer ?


Btw, I've found your series in my linux-kernel folder, but it did
not make it to linux-riscv or my personal inbox despite the CC.



Thanks for the review.
I checked my scripts. I couldn't figure out what went wrong.
Not sure if there was some issue with infradead.org at that time.

Anyways, sorry again for the mess. I will keep a watch on this next time.

Regards,
Atish


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Christoph Hellwig
On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote:
> On 8/30/18 7:41 AM, Christoph Hellwig wrote:
> > >   struct device_node *dn = NULL;
> > > - int hart, im_okay_therefore_i_am = 0;
> > > + int hart, found_boot_cpu = 0;
> > 
> > If you rename this anyway please switch to use a bool.
> > 
> 
> I can address the comment on this patch and fold it in my series to avoid
> unnecessary conflict.
> 
> @Palmer: You can drop this patch.

If Palmer is ok with it how about you include a respin of his whole
series?  There are some overlaps I think and having a single person
in charge might be helpful.

Btw, I've found your series in my linux-kernel folder, but it did
not make it to linux-riscv or my personal inbox despite the CC.


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Christoph Hellwig
On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote:
> On 8/30/18 7:41 AM, Christoph Hellwig wrote:
> > >   struct device_node *dn = NULL;
> > > - int hart, im_okay_therefore_i_am = 0;
> > > + int hart, found_boot_cpu = 0;
> > 
> > If you rename this anyway please switch to use a bool.
> > 
> 
> I can address the comment on this patch and fold it in my series to avoid
> unnecessary conflict.
> 
> @Palmer: You can drop this patch.

If Palmer is ok with it how about you include a respin of his whole
series?  There are some overlaps I think and having a single person
in charge might be helpful.

Btw, I've found your series in my linux-kernel folder, but it did
not make it to linux-riscv or my personal inbox despite the CC.


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Atish Patra

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to 
avoid unnecessary conflict.


@Palmer: You can drop this patch.

Regards,
Atish


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Atish Patra

On 8/30/18 7:41 AM, Christoph Hellwig wrote:

struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;


If you rename this anyway please switch to use a bool.



I can address the comment on this patch and fold it in my series to 
avoid unnecessary conflict.


@Palmer: You can drop this patch.

Regards,
Atish


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Christoph Hellwig
>   struct device_node *dn = NULL;
> - int hart, im_okay_therefore_i_am = 0;
> + int hart, found_boot_cpu = 0;

If you rename this anyway please switch to use a bool.


Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Christoph Hellwig
>   struct device_node *dn = NULL;
> - int hart, im_okay_therefore_i_am = 0;
> + int hart, found_boot_cpu = 0;

If you rename this anyway please switch to use a bool.


[PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-27 Thread Palmer Dabbelt
The old name was a bit odd.

Signed-off-by: Palmer Dabbelt 
---
 arch/riscv/kernel/smpboot.c | 8 
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/riscv/kernel/smpboot.c b/arch/riscv/kernel/smpboot.c
index 5f29f8562cf6..e1f6a5ad0416 100644
--- a/arch/riscv/kernel/smpboot.c
+++ b/arch/riscv/kernel/smpboot.c
@@ -50,7 +50,7 @@ void __init smp_prepare_cpus(unsigned int max_cpus)
 void __init setup_smp(void)
 {
struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;
 
while ((dn = of_find_node_by_type(dn, "cpu"))) {
hart = riscv_of_processor_hartid(dn);
@@ -58,13 +58,13 @@ void __init setup_smp(void)
set_cpu_possible(hart, true);
set_cpu_present(hart, true);
if (hart == smp_processor_id()) {
-   BUG_ON(im_okay_therefore_i_am);
-   im_okay_therefore_i_am = 1;
+   BUG_ON(found_boot_cpu);
+   found_boot_cpu = 1;
}
}
}
 
-   BUG_ON(!im_okay_therefore_i_am);
+   BUG_ON(!found_boot_cpu);
 }
 
 int __cpu_up(unsigned int cpu, struct task_struct *tidle)
-- 
2.16.4



[PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-27 Thread Palmer Dabbelt
The old name was a bit odd.

Signed-off-by: Palmer Dabbelt 
---
 arch/riscv/kernel/smpboot.c | 8 
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/riscv/kernel/smpboot.c b/arch/riscv/kernel/smpboot.c
index 5f29f8562cf6..e1f6a5ad0416 100644
--- a/arch/riscv/kernel/smpboot.c
+++ b/arch/riscv/kernel/smpboot.c
@@ -50,7 +50,7 @@ void __init smp_prepare_cpus(unsigned int max_cpus)
 void __init setup_smp(void)
 {
struct device_node *dn = NULL;
-   int hart, im_okay_therefore_i_am = 0;
+   int hart, found_boot_cpu = 0;
 
while ((dn = of_find_node_by_type(dn, "cpu"))) {
hart = riscv_of_processor_hartid(dn);
@@ -58,13 +58,13 @@ void __init setup_smp(void)
set_cpu_possible(hart, true);
set_cpu_present(hart, true);
if (hart == smp_processor_id()) {
-   BUG_ON(im_okay_therefore_i_am);
-   im_okay_therefore_i_am = 1;
+   BUG_ON(found_boot_cpu);
+   found_boot_cpu = 1;
}
}
}
 
-   BUG_ON(!im_okay_therefore_i_am);
+   BUG_ON(!found_boot_cpu);
 }
 
 int __cpu_up(unsigned int cpu, struct task_struct *tidle)
-- 
2.16.4