Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console

2017-03-15 Thread Petr Mladek
On Thu 2017-03-02 10:01:53, Steven Rostedt wrote:
> On Thu,  2 Mar 2017 16:11:33 +0300
> Aleksey Makarov  wrote:
> 
> > The variable selected_console is set in __add_preferred_console()
> > to point to the last console parameter that was added to the
> > console_cmdline array.
> > 
> > Rename it to preferred_console so that the name reflects the usage.
> 
> As I said previously, I prefer "selected_console" but since
> "__add_preferred_console()" sets it, I'm fine with this change.
> Although, I would probably have changed that function to
> "__add_selected_console()" :)

If I get it correctly, the selected_console/preferred_console
value is used to keep the console first in the console_drivers list.
IMHO, the main effect is that each line will first appear on this
console, see call_console_drivers(). But the message will still
appear also on all other enabled consoles. From this point,
the name "preferred" sounds better to me. More consoles
are selected (enabled) and only one is preferred (first).

Well, I am not a native speaker and might be wrong. Also
it is possible that I missed something.

Anyway, the change looks fine to me.

Acked-by: Petr Mladek 

Best Regards,
Petr


Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console

2017-03-02 Thread Sergey Senozhatsky
On (03/02/17 10:01), Steven Rostedt wrote:
> > The variable selected_console is set in __add_preferred_console()
> > to point to the last console parameter that was added to the
> > console_cmdline array.
> > 
> > Rename it to preferred_console so that the name reflects the usage.
> 
> As I said previously, I prefer "selected_console" but since
> "__add_preferred_console()" sets it, I'm fine with this change.
> Although, I would probably have changed that function to
> "__add_selected_console()" :)
> 
> Acked-by: Steven Rostedt (VMware) 

agree, I'd *probably* do a function rename. just 3 lines of code to
touch (afaics).

Reviewed-by: Sergey Senozhatsky 

-ss


Re: [PATCH v2 2/3] printk: rename selected_console -> preferred_console

2017-03-02 Thread Steven Rostedt
On Thu,  2 Mar 2017 16:11:33 +0300
Aleksey Makarov  wrote:

> The variable selected_console is set in __add_preferred_console()
> to point to the last console parameter that was added to the
> console_cmdline array.
> 
> Rename it to preferred_console so that the name reflects the usage.

As I said previously, I prefer "selected_console" but since
"__add_preferred_console()" sets it, I'm fine with this change.
Although, I would probably have changed that function to
"__add_selected_console()" :)

Acked-by: Steven Rostedt (VMware) 

-- Steve

> 
> Suggested-by: Peter Hurley 
> Signed-off-by: Aleksey Makarov 


[PATCH v2 2/3] printk: rename selected_console -> preferred_console

2017-03-02 Thread Aleksey Makarov
The variable selected_console is set in __add_preferred_console()
to point to the last console parameter that was added to the
console_cmdline array.

Rename it to preferred_console so that the name reflects the usage.

Suggested-by: Peter Hurley 
Signed-off-by: Aleksey Makarov 
---
 kernel/printk/printk.c | 10 +-
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/kernel/printk/printk.c b/kernel/printk/printk.c
index 3c2234f21291..ed2a9b31f214 100644
--- a/kernel/printk/printk.c
+++ b/kernel/printk/printk.c
@@ -267,7 +267,7 @@ static struct console *exclusive_console;
 
 static struct console_cmdline console_cmdline[MAX_CMDLINECONSOLES];
 
-static int selected_console = -1;
+static int preferred_console = -1;
 int console_set_on_cmdline;
 EXPORT_SYMBOL(console_set_on_cmdline);
 
@@ -1907,14 +1907,14 @@ static int __add_preferred_console(char *name, int idx, 
char *options,
 i++, c++) {
if (strcmp(c->name, name) == 0 && c->index == idx) {
if (!brl_options)
-   selected_console = i;
+   preferred_console = i;
return 0;
}
}
if (i == MAX_CMDLINECONSOLES)
return -E2BIG;
if (!brl_options)
-   selected_console = i;
+   preferred_console = i;
strlcpy(c->name, name, sizeof(c->name));
c->options = options;
braille_set_options(c, brl_options);
@@ -2433,7 +2433,7 @@ void register_console(struct console *newcon)
bcon = console_drivers;
 
if (!has_preferred || bcon || !console_drivers)
-   has_preferred = selected_console >= 0;
+   has_preferred = preferred_console >= 0;
 
/*
 *  See if we want to use this console driver. If we
@@ -2481,7 +2481,7 @@ void register_console(struct console *newcon)
}
 
newcon->flags |= CON_ENABLED;
-   if (i == selected_console) {
+   if (i == preferred_console) {
newcon->flags |= CON_CONSDEV;
has_preferred = true;
}
-- 
2.11.1