Re: [RFC, Patch 1/1] OProfile for Cell: Initial profiling support -- new patch

2006-11-16 Thread Heikki Orsila
On Wed, Nov 15, 2006 at 12:51:08PM -0600, Maynard Johnson wrote:
> +/* This function is called once for all cpus combined */
> +static void
> +cell_reg_setup(struct op_counter_config *ctr,
> +struct op_system_config *sys, int num_ctrs)
> +{
> [SNIP]
> + for (i = 0; i < num_ctrs; ++i) {
> +
> + if ((ctr[i].event >= 2100) && (ctr[i].event <= 2111))
> + pmc_cntrl[1][i].evnts = ctr[i].event + 19;
> + else if (ctr[i].event == 2203)
> + pmc_cntrl[1][i].evnts = ctr[i].event;
> + else if ((ctr[i].event >= 2200) && (ctr[i].event <= 2215))
> + pmc_cntrl[1][i].evnts = ctr[i].event + 16;
> + else
> + pmc_cntrl[1][i].evnts = ctr[i].event;
> +

I think the previous code would be more readable with a switch() 
statement. 

switch (ctr[i].event) {
case 2100 ... 2111:
pmc_cntrl[1][i] = ctr[i].event + 19;
break;
case 2200 ... 2202:
case 2204 ... 2215:
pmc_cntrl[1][i] = ctr[i].event + 16;
break;
default:
pmc_cntrl[1][i] = ctr[i].event;
}

 - Heikki
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [RFC, Patch 1/1] OProfile for Cell: Initial profiling support -- new patch

2006-11-16 Thread Heikki Orsila
On Wed, Nov 15, 2006 at 12:51:08PM -0600, Maynard Johnson wrote:
 +/* This function is called once for all cpus combined */
 +static void
 +cell_reg_setup(struct op_counter_config *ctr,
 +struct op_system_config *sys, int num_ctrs)
 +{
 [SNIP]
 + for (i = 0; i  num_ctrs; ++i) {
 +
 + if ((ctr[i].event = 2100)  (ctr[i].event = 2111))
 + pmc_cntrl[1][i].evnts = ctr[i].event + 19;
 + else if (ctr[i].event == 2203)
 + pmc_cntrl[1][i].evnts = ctr[i].event;
 + else if ((ctr[i].event = 2200)  (ctr[i].event = 2215))
 + pmc_cntrl[1][i].evnts = ctr[i].event + 16;
 + else
 + pmc_cntrl[1][i].evnts = ctr[i].event;
 +

I think the previous code would be more readable with a switch() 
statement. 

switch (ctr[i].event) {
case 2100 ... 2111:
pmc_cntrl[1][i] = ctr[i].event + 19;
break;
case 2200 ... 2202:
case 2204 ... 2215:
pmc_cntrl[1][i] = ctr[i].event + 16;
break;
default:
pmc_cntrl[1][i] = ctr[i].event;
}

 - Heikki
-
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/