RE: [PATCH] usb: dwc3: rename __dwc3_cleanup_done_trbs to __dwc3_cleanup_one_trb

2016-03-30 Thread Du, Changbin
> > @@ -1873,7 +1873,7 @@ static void dwc3_gadget_free_endpoints(struct
> dwc3 *dwc)
> >
> >  /* 
> > -- 
> > */
> >
> > -static int __dwc3_cleanup_done_trbs(struct dwc3 *dwc, struct dwc3_ep
> *dep,
> > +static int __dwc3_cleanup_one_trb(struct dwc3 *dwc, struct dwc3_ep
> *dep,
> 
> I would rather just remove that 's' from the end so the function's name
> stays as __dwc3_cleanup_done_trb() ;-)
> 
> Care to do that ?
> 
> thanks
> 
> --
> Balbi

IMO, "one_trb" is a little more clear. But both is okay for me. :) 

Thanks, 
Du, Changbin


RE: [PATCH] usb: dwc3: rename __dwc3_cleanup_done_trbs to __dwc3_cleanup_one_trb

2016-03-30 Thread Du, Changbin
> > @@ -1873,7 +1873,7 @@ static void dwc3_gadget_free_endpoints(struct
> dwc3 *dwc)
> >
> >  /* 
> > -- 
> > */
> >
> > -static int __dwc3_cleanup_done_trbs(struct dwc3 *dwc, struct dwc3_ep
> *dep,
> > +static int __dwc3_cleanup_one_trb(struct dwc3 *dwc, struct dwc3_ep
> *dep,
> 
> I would rather just remove that 's' from the end so the function's name
> stays as __dwc3_cleanup_done_trb() ;-)
> 
> Care to do that ?
> 
> thanks
> 
> --
> Balbi

IMO, "one_trb" is a little more clear. But both is okay for me. :) 

Thanks, 
Du, Changbin


Re: [PATCH] usb: dwc3: rename __dwc3_cleanup_done_trbs to __dwc3_cleanup_one_trb

2016-03-30 Thread Felipe Balbi

Hi,

changbin...@intel.com writes:
> [ text/plain ]
> From: "Du, Changbin" 
>
> Actually, the function only clean one trb. So rename the function.
>
> Signed-off-by: Du, Changbin 

okay :-)

> ---
>  drivers/usb/dwc3/gadget.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc3/gadget.c
> index 3ac170f..f84be3d 100644
> --- a/drivers/usb/dwc3/gadget.c
> +++ b/drivers/usb/dwc3/gadget.c
> @@ -1873,7 +1873,7 @@ static void dwc3_gadget_free_endpoints(struct dwc3 *dwc)
>  
>  /* 
> -- */
>  
> -static int __dwc3_cleanup_done_trbs(struct dwc3 *dwc, struct dwc3_ep *dep,
> +static int __dwc3_cleanup_one_trb(struct dwc3 *dwc, struct dwc3_ep *dep,

I would rather just remove that 's' from the end so the function's name
stays as __dwc3_cleanup_done_trb() ;-)

Care to do that ?

thanks

-- 
balbi


signature.asc
Description: PGP signature


Re: [PATCH] usb: dwc3: rename __dwc3_cleanup_done_trbs to __dwc3_cleanup_one_trb

2016-03-30 Thread Felipe Balbi

Hi,

changbin...@intel.com writes:
> [ text/plain ]
> From: "Du, Changbin" 
>
> Actually, the function only clean one trb. So rename the function.
>
> Signed-off-by: Du, Changbin 

okay :-)

> ---
>  drivers/usb/dwc3/gadget.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc3/gadget.c
> index 3ac170f..f84be3d 100644
> --- a/drivers/usb/dwc3/gadget.c
> +++ b/drivers/usb/dwc3/gadget.c
> @@ -1873,7 +1873,7 @@ static void dwc3_gadget_free_endpoints(struct dwc3 *dwc)
>  
>  /* 
> -- */
>  
> -static int __dwc3_cleanup_done_trbs(struct dwc3 *dwc, struct dwc3_ep *dep,
> +static int __dwc3_cleanup_one_trb(struct dwc3 *dwc, struct dwc3_ep *dep,

I would rather just remove that 's' from the end so the function's name
stays as __dwc3_cleanup_done_trb() ;-)

Care to do that ?

thanks

-- 
balbi


signature.asc
Description: PGP signature