Re: [PATCH 20/32] Blackfin arch: dma_memcpy borken for > 64K

2007-05-21 Thread Mike Frysinger

On 5/21/07, Pekka Enberg <[EMAIL PROTECTED]> wrote:

On 5/21/07, Bryan Wu <[EMAIL PROTECTED]> wrote:
> -void *dma_memcpy(void *dest, const void *src, size_t size)
> +void *_dma_memcpy(void *dest, const void *src, size_t size)

Minor nitpick: the established naming convention is two underscores, not one.


that should be marked as static now actually since the function isnt
for use outside of this file


> +void *dma_memcpy(void *dest, const void *src, size_t size)
> +{
> +   size_t bulk;
> +   size_t rest;
> +   void * addr;
> +
> +   bulk = (size >> 16) << 16;

I assume this is significantly faster on your architecture than:

   bulk = size & ~0xUL;

which is more readable?


actually they should get optimized to the same thing
-mike
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 20/32] Blackfin arch: dma_memcpy borken for > 64K

2007-05-21 Thread Pekka Enberg

Hi Bryan,

On 5/21/07, Bryan Wu <[EMAIL PROTECTED]> wrote:

-void *dma_memcpy(void *dest, const void *src, size_t size)
+void *_dma_memcpy(void *dest, const void *src, size_t size)


Minor nitpick: the established naming convention is two underscores, not one.


+void *dma_memcpy(void *dest, const void *src, size_t size)
+{
+   size_t bulk;
+   size_t rest;
+   void * addr;
+
+   bulk = (size >> 16) << 16;


I assume this is significantly faster on your architecture than:

  bulk = size & ~0xUL;

which is more readable?


+   rest = size - bulk;
+   if (bulk)
+   _dma_memcpy(dest, src, bulk);
+   addr = _dma_memcpy(dest+bulk, src+bulk, rest);
+   return addr;


Does this work for 128K and up? Why?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 20/32] Blackfin arch: dma_memcpy borken for 64K

2007-05-21 Thread Pekka Enberg

Hi Bryan,

On 5/21/07, Bryan Wu [EMAIL PROTECTED] wrote:

-void *dma_memcpy(void *dest, const void *src, size_t size)
+void *_dma_memcpy(void *dest, const void *src, size_t size)


Minor nitpick: the established naming convention is two underscores, not one.


+void *dma_memcpy(void *dest, const void *src, size_t size)
+{
+   size_t bulk;
+   size_t rest;
+   void * addr;
+
+   bulk = (size  16)  16;


I assume this is significantly faster on your architecture than:

  bulk = size  ~0xUL;

which is more readable?


+   rest = size - bulk;
+   if (bulk)
+   _dma_memcpy(dest, src, bulk);
+   addr = _dma_memcpy(dest+bulk, src+bulk, rest);
+   return addr;


Does this work for 128K and up? Why?
-
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH 20/32] Blackfin arch: dma_memcpy borken for 64K

2007-05-21 Thread Mike Frysinger

On 5/21/07, Pekka Enberg [EMAIL PROTECTED] wrote:

On 5/21/07, Bryan Wu [EMAIL PROTECTED] wrote:
 -void *dma_memcpy(void *dest, const void *src, size_t size)
 +void *_dma_memcpy(void *dest, const void *src, size_t size)

Minor nitpick: the established naming convention is two underscores, not one.


that should be marked as static now actually since the function isnt
for use outside of this file


 +void *dma_memcpy(void *dest, const void *src, size_t size)
 +{
 +   size_t bulk;
 +   size_t rest;
 +   void * addr;
 +
 +   bulk = (size  16)  16;

I assume this is significantly faster on your architecture than:

   bulk = size  ~0xUL;

which is more readable?


actually they should get optimized to the same thing
-mike
-
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/