Re: [PATCH RESEND 04/11] thermal: rename get_thermal_instance to thermal_instance_get

2013-04-17 Thread Eduardo Valentin

On 17-04-2013 11:09, Zhang Rui wrote:

On Mon, 2013-04-08 at 12:07 -0400, Eduardo Valentin wrote:

To follow the prefix names used by the thermal exported functions,
this patch renames get_thermal_instance to thermal_instance_get.

Signed-off-by: Eduardo Valentin 


NACK.

with the change of building all thermal governors into thermal_sys
module, get_thermal_instance becomes an internally helper function,
rather than external API.
thus I think it is okay to use the current name get_thermal_instance.
But you remind me a need a cleanup patch to remove these APIs. :)


How about keeping this patch and resending with a better description? 
Something like:

To follow the prefix names used by the thermal functions,
this patch renames get_thermal_instance to thermal_instance_get.




thanks,
rui

---
  Documentation/thermal/sysfs-api.txt |2 +-
  drivers/thermal/fair_share.c|2 +-
  drivers/thermal/thermal_sys.c   |4 ++--
  include/linux/thermal.h |2 +-
  4 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/Documentation/thermal/sysfs-api.txt 
b/Documentation/thermal/sysfs-api.txt
index 4b23190..059b3bf 100644
--- a/Documentation/thermal/sysfs-api.txt
+++ b/Documentation/thermal/sysfs-api.txt
@@ -358,7 +358,7 @@ are supposed to implement the callback. If they don't, the 
thermal
  framework calculated the trend by comparing the previous and the current
  temperature values.

-5.2:get_thermal_instance:
+5.2:thermal_instance_get:
  This function returns the thermal_instance corresponding to a given
  {thermal_zone, cooling_device, trip_point} combination. Returns NULL
  if such an instance does not exist.
diff --git a/drivers/thermal/fair_share.c b/drivers/thermal/fair_share.c
index 792479f..f629446 100644
--- a/drivers/thermal/fair_share.c
+++ b/drivers/thermal/fair_share.c
@@ -95,7 +95,7 @@ static int fair_share_throttle(struct thermal_zone_device 
*tz, int trip)
continue;

cdev = tzp->tbp[i].cdev;
-   instance = get_thermal_instance(tz, cdev, trip);
+   instance = thermal_instance_get(tz, cdev, trip);
if (!instance)
continue;

diff --git a/drivers/thermal/thermal_sys.c b/drivers/thermal/thermal_sys.c
index ffaf6d3..44e89c0 100644
--- a/drivers/thermal/thermal_sys.c
+++ b/drivers/thermal/thermal_sys.c
@@ -170,7 +170,7 @@ int get_tz_trend(struct thermal_zone_device *tz, int trip)
  }
  EXPORT_SYMBOL(get_tz_trend);

-struct thermal_instance *get_thermal_instance(struct thermal_zone_device *tz,
+struct thermal_instance *thermal_instance_get(struct thermal_zone_device *tz,
struct thermal_cooling_device *cdev, int trip)
  {
struct thermal_instance *pos = NULL;
@@ -191,7 +191,7 @@ struct thermal_instance *get_thermal_instance(struct 
thermal_zone_device *tz,

return target_instance;
  }
-EXPORT_SYMBOL(get_thermal_instance);
+EXPORT_SYMBOL(thermal_instance_get);

  static void print_bind_err_msg(struct thermal_zone_device *tz,
struct thermal_cooling_device *cdev, int ret)
diff --git a/include/linux/thermal.h b/include/linux/thermal.h
index e8ec9d8..e2a49e1 100644
--- a/include/linux/thermal.h
+++ b/include/linux/thermal.h
@@ -239,7 +239,7 @@ struct thermal_cooling_device 
*thermal_cooling_device_register(char *, void *,
  void thermal_cooling_device_unregister(struct thermal_cooling_device *);

  int get_tz_trend(struct thermal_zone_device *, int);
-struct thermal_instance *get_thermal_instance(struct thermal_zone_device *,
+struct thermal_instance *thermal_instance_get(struct thermal_zone_device *,
struct thermal_cooling_device *, int);
  void thermal_cdev_update(struct thermal_cooling_device *);
  void thermal_notify_framework(struct thermal_zone_device *, int);







--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH RESEND 04/11] thermal: rename get_thermal_instance to thermal_instance_get

2013-04-17 Thread Zhang Rui
On Mon, 2013-04-08 at 12:07 -0400, Eduardo Valentin wrote:
> To follow the prefix names used by the thermal exported functions,
> this patch renames get_thermal_instance to thermal_instance_get.
> 
> Signed-off-by: Eduardo Valentin 

NACK.

with the change of building all thermal governors into thermal_sys
module, get_thermal_instance becomes an internally helper function,
rather than external API.
thus I think it is okay to use the current name get_thermal_instance.
But you remind me a need a cleanup patch to remove these APIs. :)

thanks,
rui
> ---
>  Documentation/thermal/sysfs-api.txt |2 +-
>  drivers/thermal/fair_share.c|2 +-
>  drivers/thermal/thermal_sys.c   |4 ++--
>  include/linux/thermal.h |2 +-
>  4 files changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/Documentation/thermal/sysfs-api.txt 
> b/Documentation/thermal/sysfs-api.txt
> index 4b23190..059b3bf 100644
> --- a/Documentation/thermal/sysfs-api.txt
> +++ b/Documentation/thermal/sysfs-api.txt
> @@ -358,7 +358,7 @@ are supposed to implement the callback. If they don't, 
> the thermal
>  framework calculated the trend by comparing the previous and the current
>  temperature values.
>  
> -5.2:get_thermal_instance:
> +5.2:thermal_instance_get:
>  This function returns the thermal_instance corresponding to a given
>  {thermal_zone, cooling_device, trip_point} combination. Returns NULL
>  if such an instance does not exist.
> diff --git a/drivers/thermal/fair_share.c b/drivers/thermal/fair_share.c
> index 792479f..f629446 100644
> --- a/drivers/thermal/fair_share.c
> +++ b/drivers/thermal/fair_share.c
> @@ -95,7 +95,7 @@ static int fair_share_throttle(struct thermal_zone_device 
> *tz, int trip)
>   continue;
>  
>   cdev = tzp->tbp[i].cdev;
> - instance = get_thermal_instance(tz, cdev, trip);
> + instance = thermal_instance_get(tz, cdev, trip);
>   if (!instance)
>   continue;
>  
> diff --git a/drivers/thermal/thermal_sys.c b/drivers/thermal/thermal_sys.c
> index ffaf6d3..44e89c0 100644
> --- a/drivers/thermal/thermal_sys.c
> +++ b/drivers/thermal/thermal_sys.c
> @@ -170,7 +170,7 @@ int get_tz_trend(struct thermal_zone_device *tz, int trip)
>  }
>  EXPORT_SYMBOL(get_tz_trend);
>  
> -struct thermal_instance *get_thermal_instance(struct thermal_zone_device *tz,
> +struct thermal_instance *thermal_instance_get(struct thermal_zone_device *tz,
>   struct thermal_cooling_device *cdev, int trip)
>  {
>   struct thermal_instance *pos = NULL;
> @@ -191,7 +191,7 @@ struct thermal_instance *get_thermal_instance(struct 
> thermal_zone_device *tz,
>  
>   return target_instance;
>  }
> -EXPORT_SYMBOL(get_thermal_instance);
> +EXPORT_SYMBOL(thermal_instance_get);
>  
>  static void print_bind_err_msg(struct thermal_zone_device *tz,
>   struct thermal_cooling_device *cdev, int ret)
> diff --git a/include/linux/thermal.h b/include/linux/thermal.h
> index e8ec9d8..e2a49e1 100644
> --- a/include/linux/thermal.h
> +++ b/include/linux/thermal.h
> @@ -239,7 +239,7 @@ struct thermal_cooling_device 
> *thermal_cooling_device_register(char *, void *,
>  void thermal_cooling_device_unregister(struct thermal_cooling_device *);
>  
>  int get_tz_trend(struct thermal_zone_device *, int);
> -struct thermal_instance *get_thermal_instance(struct thermal_zone_device *,
> +struct thermal_instance *thermal_instance_get(struct thermal_zone_device *,
>   struct thermal_cooling_device *, int);
>  void thermal_cdev_update(struct thermal_cooling_device *);
>  void thermal_notify_framework(struct thermal_zone_device *, int);


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/